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MAGELLAN NAVIGATION PROFESSIONAL PRODUCTS - LIMITED WARRANTY

(North, Central and South America)

Magellan Navigation warrants their GPS receivers and hardware accessories to be free of defects in mate-
rial and workmanship and will conform to our published specifications for the product for a period of one 
year from the date of original purchase. THIS WARRANTY APPLIES ONLY TO THE ORIGINAL PUR-
CHASER OF THIS PRODUCT. 

In the event of a defect, Magellan Navigation will, at its option, repair or replace the hardware product 
with no charge to the purchaser for parts or labor. The repaired or replaced product will be warranted for 
90 days from the date of return shipment, or for the balance of the original warranty, whichever is longer. 
Magellan Navigation warrants that software products or software included in hardware products will be 
free from defects in the media for a period of 30 days from the date of shipment and will substantially 
conform to the then-current user documentation provided with the software (including updates thereto). 
Magellan Navigation's sole obligation shall be the correction or replacement of the media or the software 
so that it will substantially conform to the then- current user documentation. Magellan Navigation does 
not warrant the software will meet purchaser's requirements or that its operation will be uninterrupted, 
error-free or virus-free. Purchaser assumes the entire risk of using the software.

PURCHASER'S EXCLUSIVE REMEDY UNDER THIS WRITTEN WARRANTY OR ANY IMPLIED WAR-
RANTY SHALL BE LIMITED TO THE REPAIR OR REPLACEMENT, AT MAGELLAN NAVIGATION'S 
OPTION, OF ANY DEFECTIVE PART OF THE RECEIVER OR ACCESSORIES WHICH ARE COVERED BY 
THIS WARRANTY. REPAIRS UNDER THIS WARRANTY SHALL ONLY BE MADE AT AN AUTHORIZED 
MAGELLAN NAVIGATION SERVICE CENTER. ANY REPAIRS BY A SERVICE CENTER NOT AUTHO-
RIZED BY MAGELLAN NAVIGATION WILL VOID THIS WARRANTY.

To obtain warranty service the purchaser must obtain a Return Materials Authorization (RMA) number 
prior to shipping by calling 800-229-2400 (U.S.) or 408 615 3981 (International), or by sending a 
repair request on-line at http://www.magellangps.com/support/. The purchaser must return the product 
postpaid with a copy of the original sales receipt to the address provided by Magellan Navigation with the 
RMA number. Purchaser's return address and the RMA number must be clearly printed on the outside of 
the package.

Magellan Navigation reserves the right to refuse to provide service free-of-charge if the sales receipt is 
not provided or if the information contained in it is incomplete or illegible or if the serial number is 
altered or removed. Magellan Navigation will not be responsible for any losses or damage to the product 
incurred while the product is in transit or is being shipped for repair. Insurance is recommended. Magel-
lan Navigation suggests using a trackable shipping method such as UPS or FedEx when returning a prod-
uct for service.

EXCEPT AS SET FORTH IN THIS LIMITED WARRANTY, ALL OTHER EXPRESSED OR IMPLIED WAR-
RANTIES, INCLUDING THOSE OF FITNESS FOR ANY PARTICULAR PURPOSE, MERCHANTABILITY 
OR NON-INFRINGEMENT, ARE HEREBY DISCLAIMED AND IF APPLICABLE, IMPLIED WARRANTIES 
UNDER ARTICLE 35 OF THE UNITED NATIONS CONVENTION ON CONTRACTS FOR THE INTERNA-
TIONAL SALE OF GOODS. Some national, state, or local laws do not allow limitations on implied war-
ranty or how long an implied warranty lasts, so the above limitation may not apply to you.

The following are excluded from the warranty coverage: (1) periodic maintenance and repair or replace-
ment of parts due to normal wear and tear; (2) batteries and finishes; (3) installations or defects result-
ing from installation; (4) any damage caused by (i) shipping, misuse, abuse, negligence, tampering, or 
improper use; (ii) disasters such as fire, flood, wind, and lightning; (iii) unauthorized attachments or 
modification; (5) service performed or attempted by anyone other than an authorized Magellan Naviga-
tions Service Center; (6) any product, components or parts not manufactured by Magellan Navigation; 
(7) that the receiver will be free from any claim for infringement of any patent, trademark, copyright or 
other proprietary right, including trade secrets; and (8) any damage due to accident, resulting from inac-
curate satellite transmissions. Inaccurate transmissions can occur due to changes in the position, health 
or geometry of a satellite or modifications to the receiver that may be required due to any change in the 
GPS. (Note: Magellan Navigation GPS receivers use GPS or GPS+GLONASS to obtain position, velocity 
and time information. GPS is operated by the U.S. Government and GLONASS is the Global Navigation 
Satellite System of the Russian Federation, which are solely responsible for the accuracy and mainte-



nance of their systems. Certain conditions can cause inaccuracies which could require modifications to 
the receiver. Examples of such conditions include but are not limited to changes in the GPS or GLO-
NASS transmission.) Opening, dismantling or repairing of this product by anyone other than an autho-
rized Magellan Navigation Service Center will void this warranty.

MAGELLAN NAVIGATION SHALL NOT BE LIABLE TO PURCHASER OR ANY OTHER PERSON FOR ANY 
INCIDENTAL OR CONSEQUENTIAL DAMAGES WHATSOEVER, INCLUDING BUT NOT LIMITED TO 
LOST PROFITS, DAMAGES RESULTING FROM DELAY OR LOSS OF USE, LOSS OF OR DAMAGES 
ARISING OUT OF BREACH OF THIS WARRANTY OR ANY IMPLIED WARRANTY EVEN THOUGH 
CAUSED BY NEGLIGENCE OR OTHER FAULT OF MAGELLAN NAVIGATION OR NEGLIGENT USAGE OF 
THE PRODUCT. IN NO EVENT WILL MAGELLAN NAVIGATION BE RESPONSIBLE FOR SUCH DAM-
AGES, EVEN IF MAGELLAN NAVIGATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAM-
AGES.

This written warranty is the complete, final and exclusive agreement between Magellan Navigation and 
the purchaser with respect to the quality of performance of the goods and any and all warranties and rep-
resentations. This warranty sets forth all of Magellan Navigation's responsibilities regarding this product. 
This limited warranty is governed by the laws of the State of California, without reference to its conflict of 
law provisions or the U.N. Convention on Contracts for the International Sale of Goods, and shall benefit 
Magellan Navigation, its successors and assigns.

This warranty gives the purchaser specific rights. The purchaser may have other rights which vary from 
locality to locality (including Directive 1999/44/EC in the EC Member States) and certain limitations 
contained in this warranty, including the exclusion or limitation of incidental or consequential damages 
may not apply. 

---

For further information concerning this limited warranty, please call or write:

Magellan Navigation, Inc., 960 Overland Court, San Dimas, CA 91773, Phone: +1 909-394-5000, Fax: 
+1 909-394-7050 or

Magellan Navigation SA - ZAC La Fleuriaye - BP 433 - 44474 Carquefou Cedex - France  Phone: +33 
(0)2 28 09 38 00, Fax: +33 (0)2 28 09 39 39

 



MAGELLAN NAVIGATION PROFESSIONAL PRODUCTS LIMITED WARRANTY

(Europe, Middle East, Africa)

All Magellan Navigation global positioning system (GPS) receivers are navigation aids, and are not 
intended to replace other methods of navigation. Purchaser is advised to perform careful position chart-
ing and use good judgment. READ THE USER GUIDE CAREFULLY BEFORE USING THE PRODUCT.

1. MAGELLAN NAVIGATION WARRANTY

Magellan Navigation warrants their GPS receivers and hardware accessories to be free of defects in mate-
rial and workmanship and will conform to our published specifications for the product for a period of one 
year from the date of original purchase or such longer period as required by law. THIS WARRANTY 
APPLIES ONLY TO THE ORIGINAL PURCHASER OF THIS PRODUCT. 

In the event of a defect, Magellan Navigation will, at its option, repair or replace the hardware product 
with no charge to the purchaser for parts or labor. The repaired or replaced product will be warranted for 
90 days from the date of return shipment, or for the balance of the original warranty, whichever is longer. 
Magellan Navigation warrants that software products or software included in hardware products will be 
free from defects in the media for a period of 30 days from the date of shipment and will substantially 
conform to the then-current user documentation provided with the software (including updates thereto). 
Magellan Navigation's sole obligation shall be the correction or replacement of the media or the software 
so that it will substantially conform to the then- current user documentation. Magellan Navigation does 
not warrant the software will meet purchaser's requirements or that its operation will be uninterrupted, 
error-free or virus-free. Purchaser assumes the entire risk of using the software.

2. PURCHASER'S REMEDY

PURCHASER'S EXCLUSIVE REMEDY UNDER THIS WRITTEN WARRANTY OR ANY IMPLIED WAR-
RANTY SHALL BE LIMITED TO THE REPAIR OR REPLACEMENT, AT MAGELLAN NAVIGATION'S 
OPTION, OF ANY DEFECTIVE PART OF THE RECEIVER OR ACCESSORIES WHICH ARE COVERED BY 
THIS WARRANTY. REPAIRS UNDER THIS WARRANTY SHALL ONLY BE MADE AT AN AUTHORIZED 
MAGELLAN NAVIGATION SERVICE CENTER. ANY REPAIRS BY A SERVICE CENTER NOT AUTHO-
RIZED BY MAGELLAN NAVIGATION WILL VOID THIS WARRANTY.

3. PURCHASER'S DUTIES

To obtain service, contact and return the product with a copy of the original sales receipt to the dealer 
from whom you purchased the product.

Magellan Navigation reserves the right to refuse to provide service free-of-charge if the sales receipt is 
not provided or if the information contained in it is incomplete or illegible or if the serial number is 
altered or removed. Magellan Navigation will not be responsible for any losses or damage to the product 
incurred while the product is in transit or is being shipped for repair. Insurance is recommended. Magel-
lan Navigation suggests using a trackable shipping method such as UPS or FedEx when returning a prod-
uct for service.

4. LIMITATION OF IMPLIED WARRANTIES

EXCEPT AS SET FORTH IN ITEM 1 ABOVE, ALL OTHER EXPRESSED OR IMPLIED WARRANTIES, 
INCLUDING THOSE OF FITNESS FOR ANY PARTICULAR PURPOSE OR MERCHANTABILITY, ARE 
HEREBY DISCLAIMED AND IF APPLICABLE, IMPLIED WARRANTIES UNDER ARTICLE 35 OF THE 
UNITED NATIONS CONVENTION ON CONTRACTS FOR THE INTERNATIONAL SALE OF GOODS. 

Some national, state, or local laws do not allow limitations on implied warranty or how long an implied 
warranty lasts, so the above limitation may not apply to you.

5. EXCLUSIONS

The following are excluded from the warranty coverage: 

(1) periodic maintenance and repair or replacement of parts due to normal wear and tear; 

(2) batteries; 

(3) finishes; 



(4) installations or defects resulting from installation; 

(5) any damage caused by (i) shipping, misuse, abuse, negligence, tampering, or improper use; (ii) 
disasters such as fire, flood, wind, and lightning; (iii) unauthorized attachments or modification; 

(6) service performed or attempted by anyone other than an authorized Magellan Navigations Service 
Center; 

(7) any product, components or parts not manufactured by Magellan Navigation, 

(8) that the receiver will be free from any claim for infringement of any patent, trademark, copyright or 
other proprietary right, including trade secrets 

(9) any damage due to accident, resulting from inaccurate satellite transmissions. Inaccurate transmis-
sions can occur due to changes in the position, health or geometry of a satellite or modifications to the 
receiver that may be required due to any change in the GPS. (Note: Magellan Navigation GPS receivers 
use GPS or GPS+GLONASS to obtain position, velocity and time information. GPS is operated by the 
U.S. Government and GLONASS is the Global Navigation Satellite System of the Russian Federation, 
which are solely responsible for the accuracy and maintenance of their systems. Certain conditions can 
cause inaccuracies which could require modifications to the receiver. Examples of such conditions 
include but are not limited to changes in the GPS or GLONASS transmission.).

Opening, dismantling or repairing of this product by anyone other than an authorized Magellan Naviga-
tion Service Center will void this warranty.

6. EXCLUSION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES

MAGELLAN NAVIGATION SHALL NOT BE LIABLE TO PURCHASER OR ANY OTHER PERSON FOR ANY 
INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES WHATSOEVER, INCLUDING BUT NOT LIM-
ITED TO LOST PROFITS, DAMAGES RESULTING FROM DELAY OR LOSS OF USE, LOSS OF OR DAM-
AGES ARISING OUT OF BREACH OF THIS WARRANTY OR ANY IMPLIED WARRANTY EVEN THOUGH 
CAUSED BY NEGLIGENCE OR OTHER FAULT OF MAGELLAN NAVIGATION OR NEGLIGENT USAGE OF 
THE PRODUCT. IN NO EVENT WILL MAGELLAN NAVIGATION BE RESPONSIBLE FOR SUCH DAM-
AGES, EVEN IF MAGELLAN NAVIGATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAM-
AGES.

Some national, state, or local laws do not allow the exclusion or limitation of incidental or consequential 
damages, so the above limitation or exclusion may not apply to you.

7. COMPLETE AGREEMENT

This written warranty is the complete, final and exclusive agreement between Magellan Navigation and 
the purchaser with respect to the quality of performance of the goods and any and all warranties and rep-
resentations. THIS WARRANTY SETS FORTH ALL OF MAGELLAN NAVIGATION'S RESPONSIBILITIES 
REGARDING THIS PRODUCT. 

THIS WARRANTY GIVES YOU SPECIFIC RIGHTS. YOU MAY HAVE OTHER RIGHTS WHICH VARY FROM 
LOCALITY TO LOCALITY (including Directive 1999/44/EC in the EC Member States) AND CERTAIN 
LIMITATIONS CONTAINED IN THIS WARRANTY MAY NOT APPLY TO YOU.

8. CHOICE OF LAW.   

This limited warranty is governed by the laws of France, without reference to its conflict of law provisions 
or the U.N. Convention on Contracts for the International Sale of Goods, and shall benefit Magellan Nav-
igation, its successors and assigns.

THIS WARRANTY DOES NOT AFFECT THE CUSTOMER'S STATUTORY RIGHTS UNDER APPLICABLE 
LAWS IN FORCE IN THEIR LOCALITY, NOR THE CUSTOMER'S RIGHTS AGAINST THE DEALER ARIS-
ING FROM THEIR SALES/PURCHASE CONTRACT (such as the guarantees in France for latent defects 
in accordance with Article 1641 et seq of the French Civil Code).

---

For further information concerning this limited warranty, please call or write:

Magellan Navigation SA - ZAC La Fleuriaye - BP 433 - 44474 Carquefou Cedex - France.

Phone: +33 (0)2 28 09 38 00, Fax: +33 (0)2 28 09 39 39
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Chapter 1: Introduction

What is GNSS Solutions?

GNSS Solutions is the indispensable software tool for all surveyors who need 
to be efficiently and smoothly assisted in their surveys. GNSS Solutions really 
offers high standards of performance, processing speed, compactness and 
flexibility. It is extremely user-friendly, simplifying many of the office tasks, a 
feature which will be appreciated by novice and experienced users alike.
GNSS Solutions can support a wide range of surveying applications, whether 
conducted in post-processing or real time. What is more, GNSS Solutions is 
capable of handling post-processing and real-time data within the same 
project.
GNSS Solutions is also GIS friendly. Any file in ESRI format available for the 
considered working area can smoothly be imported into the open project as a 
background map. In addition, raster images of various formats can in the same 
way be imported as part of the background map thus extending the possibili-
ties for surveyors to present their field results.

Post-Processing:

GNSS Solutions includes components designed to assist you in all stages of 
planning and post-processing a survey:

- Mission planning
- Data transfer
- Vector processing
- Network adjustment
- Quality analysis
1



1 Introduction
Role of GNSS Solutions in a GPS Survey
- Coordinate transformation
- Report generation
- Exporting

GNSS Solutions integrates one of the fastest post-processing engines avail-
able, as well as superior blunder detection to ensure proper processing the first 
time. As the processing takes place, GNSS Solutions continuously updates a 
graphical display to provide a a true representation of your fieldwork.

Real-Time:

GNSS Solutions includes all the necessary tools to prepare a real-time job and 
upload it to your field unit.
After field operations, GNSS Solutions will let you download the results of your 
survey into a project so that you can create a report just as you would with your 
post-processed jobs.

Role of GNSS Solutions in a GPS Survey

Post-Processing:

Once you have conducted your survey, GNSS Solutions provides the ability to 
accurately determine site locations within the parameters you establish. With 
the post-processing completed, GNSS Solutions allows you to perform blunder 
detection, adjust your network, and review quality metrics.
Once the automatic processing is complete, GNSS Solutions transforms your 
raw data into a polished final report that can be produced in a variety of for-
mats to suit the client’s needs.
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Real-Time:

Before the survey, you can use GNSS Solutions to prepare the field job, i.e. 
create a file containing the job’s target and reference points and then upload 
this file to the field equipment.
After the survey, you can download the results to a project and create the final 
report for your customer. You may combine these results with post-processing 
results in a single project. If raw data was recorded during the real-time survey, 
you can even re-process the data as you would with post-processing data for 
double-checking.

Utility Programs Provided

Different built-in tools are provided in GNSS Solutions. They are used to:
- Edit / manage coordinate systems used by GNSS Solutions
- Transform coordinates from a known system to another known system
- Set leap seconds involved in the GPS-to-UTC time conversion at any given 

date
- Transform GPS week & time into local date & time.
In addition, GNSS Solutions is delivered with 7 separate utility programs:
- Mission Planning is used to depict the GPS constellation seen from any 

given point located on the Earth surface, at any given time in the past or 
future. Mission Planning provides both qualitative and quantitative figures 
about the constellation then visible.
You can then use Mission Planning to choose the best moment to perform a 
survey. In addition, the Curtain function allows you to simulate the impact 
of close obstructions on the number of usable satellites, on the GDOP, etc.
3
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Mission Planning can also be used when post-processing files as a monitor-
ing tool, for example for better understanding of what happened when log-
ging the raw data files.

- WinComm is used to communicate with a GPS/GNSS Magellan receiver, 
directly from the PC to which it is attached, via the set of proprietary com-
mands available (NMEA 0183 compatible). From WinComm, you can 
check / modify the receiver settings (configuration) or run raw data record-
ing sequences in manual or automatic mode.

- Geoids allows you to exploit most of the geoid models existing to date. In 
practice, you can use Geoids to extract part of the data from a geoid model, 
according to the geographical region you choose, and load this data 
directly to the Magellan receiver or data collector for further use in the 
field. In this way, any position fix performed in reference to the ellipsoid 
will be corrected through this model to give elevation.

- RINEX Converter is used to translate single or multiple RINEX-formatted 
data files to Magellan “Ashtech”-formatted files, and, alternatively, convert 
Magellan “Ashtech” data files to RINEX format.

- DSNP to RINEX (DTR) is used to convert Magellan raw data files (DSNP 
SBIN, SVAR, SFIX) into RINEX-compatible files for further use in any other 
system compatible with the RINEX format.

- GNSS Download is used to download field raw data to your computer. While 
doing this, GNSS Download analyzes and splits the raw data into different 
types of files (e*, b*, etc.).

- SurvCom is used to perform data exchange between GNSS Solutions and 
the data collector of the ProMark 500 or Z-Max system. This utility pro-
gram allows data exchange in both directions of transfer.

- Internet Download allows you to download compact RINEX raw data, or pre-
cise orbit files from the FTP site you choose.

- Project Management allows you to manage your projects (delete/backup/
restore).
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Minimum System Requirements

- Personal Computer, PC type
- Operating system: Windows 2000 / XP

Warning! Installation on XP operating system must be run with the admin-
istrator login otherwise some GNSS Solutions functions won’t work.

- Processor: Pentium 233 or 300 MHz recommended (*)
- RAM: 64 or 128 MB recommended (*)
- Space required for installation: 200 MB

Warning! Allow for a minimum of 124 MB on disk C: when you install 
GNSS Solutions on a different drive. Whatever the installation disk you 
choose for GNSS Solutions, this 124-MB space is always required on disk 
C: for common files.

- CD-ROM drive
- PC card drive is recommended if you use receivers collecting their field 

data on PC Cards 
- RS232 or USB serial ports

(*) Recommended by Microsoft for XP and sufficient for GNSS Solutions.

Customizing GNSS Solutions

GNSS Solutions can be customized using the Tools>Preferences command.
With the default configuration installed, GNSS Solutions is more particularly 
intended for post-processing surveys. The Insert Background Map function is 
also available in this case.
There are four additional features that you can validate through customization, 
depending on your needs: 1) RTK, 2) Data Management, 3) CAD and 4) Ad-
vanced Coordinate System Management. These features are described in 
Chapters 7, 11 & 12 in this manual.
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Installing GNSS Solutions

- Close all the applications running in Windows
- Insert the GNSS Solutions CD-ROM in the drive. The Autorun program 

should normally start automatically. If an earlier version of GNSS Solutions 
is present on your computer, the installation program will first ask you to 
uninstall this earlier version. You will then have to re-launch manually the 
installation program.

- If the Autorun program does not start automatically from the CD-ROM, in 
the Windows task bar, click on Start and select Run...

- Type x:\setup (where x is the name of the CD-ROM drive) and then press 
Enter. After you specify where to install GNSS Solutions programs and 
projects, your computer will complete the installation process.

- Before launching the program, don’t forget to connect the dongle to the 

PC’s parallel or USB port, depending on the model of dongle you ordered. 
(This dongle is part of the delivery if you have ordered a protection of the 
hardware type.)
With an absent dongle, GNSS Solutions will however run full-featured for 
30 days. After this grace period, GNSS Solutions will refer to the content 
of the dongle to know which options are really enabled, depending on the 
detail of the purchase. Obviously, if the dongle is still missing at that time, 
the “L1/L2 Post-Processing” option will not be made available to the user 
even if he bought it. Only the presence of the dongle will “tell” the soft-
ware this option can be unlocked.

 ProMark3 users do not need to worry about the grace period or the use of a don-
gle. Their equipment is a single-frequency receiver and so does not require that the 
“L1/L2 Post-Processing” option be unlocked in GNSS Solutions.
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Dongles are well suited for sedentary users, especially for those who wish 
to use GNSS Solutions on two or more of their office computers.
Conversely, users that travel extensively may be interested in having soft-
ware protection devices installed on their PCs rather than easily mislaid 
dongles.
See Using a License File Rather Than a Dongle on page 9 for more infor-
mation on this protection choice. Remember however that the software-
type protection cannot be moved from one PC to another as it is closely 
tied to the PC hardware.

- To list the available software options after installation, launch GNSS Solu-
tions. To start GNSS Solutions, from the Windows task bar, select succes-
sively Start, Programs and GNSS Solutions. Once the GNSS Solutions 
main window is open, on the GNSS Solutions menu bar, select Help>About 
GNSS Solutions. The dialog box that appears lists all the possible options. 
Each option is followed by its current status: Yes means the option is 
enabled; Yes - xx day(s) means the option is enabled for xx days only; No 
means the option is disabled.
In the example below, all the options are available for use:

Please note that the “Real-Time Job Transfer” and “L1 Post-Processing” 
options are always valid even after the grace period has expired.
7



1 Introduction
Installing GNSS Solutions
Unlocking a Software Option
After a certain time using your GNSS Solutions program, you may need to un-
lock the L1/L2 processing option that you did not initially purchase. After or-
dering this new option, do the following:
- On the GNSS Solutions menu bar, select Help>About GNSS Solutions
- In the About GNSS Solutions dialog box that opens, click on Click here to 

unlock options. A new dialog box opens, which should look like the one 
below if a dongle is connected to the PC’s USB or parallel port:

- To get the password needed to run the “L1/L2 Post-Processing” option, 
and also to be registered as a GNSS Solutions user, write down your regis-
tration code (displayed in third line in dialog box above) and then click on 
the web link. If your PC is equipped with a connection to the Internet, you 
will be able to access our web site to make your request. From the registra-
tion code you will send us, we will be able to generate a password for you. 
Once you receive it, type in this password in the lower edit box (see dialog 
box above) and then click OK. This unlocks the software option making it 
available for use.
8
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Using a License File Rather Than a Dongle
For those of you who prefer not to use a dongle and have their options enabled 
from a license file, do the following the first time you run GNSS Solutions:
- On the GNSS Solutions menu bar, select Help>About GNSS Solutions
- In the About GNSS Solutions dialog box that opens, click on Click here to 

unlock options. A new dialog box opens, which should look like this in the 
absence of a dongle on the parallel or USB port:

- To get the password needed to run the “L1/L2 Post-Processing” option, 
and also to be registered as a GNSS Solutions user, write down your regis-
tration code (displayed in third line in dialog box above) and then click on 
the web link. If your PC is equipped with a connection to the Internet, you 
will be able to access our web site to make your request. From the registra-
tion code you will send us, we will be able to generate a password for you. 
Once you receive it, type in this password in the lower edit box (see dialog 
box above) and then click OK. This unlocks the software option you have 
purchased, thus making it available for use.
9
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What Do I Do First?

If you are transitioning from standard surveying techniques to GNSS, you may 
find GNSS technology baffling or even intimidating. However, once you be-
come familiar with the basic techniques, you will find that GNSS is a powerful 
productivity tool. The following scenario is recommended for users new to 
GNSS.
1. Skim through all the GNSS Solutions documentation to familiarize yourself 

with content and organization.
2. Following the instructions in the receiver manual, use the receiver to do an 

actual miniature survey, such as a parking lot or park.
- OR -
Spend some time working through the examples in the tutorial to under-
stand the reasoning and terminology underlying GNSS Solutions. 

3. Transfer your data to your PC, and run GNSS Solutions software as 
instructed in the present Reference Manual. 

4. Print out your data in the format that you want. 
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Chapter 2: Getting Started

This chapter describes the fundamentals of GNSS Solutions, including starting 
the software, navigating through the software, and using the various windows. 
It is assumed that GNSS Solutions was installed with the default choices.

Starting GNSS Solutions

To launch GNSS Solutions, double-click the GNSS Solutions icon located on 
your computer workspace:

Or from the Windows task bar, click on Start, then Programs, then select GNSS 
Solutions and then GNSS Solutions again.
The GNSS Solutions splash screen appears momentarily, followed by the Reg-
ister Online dialog:

This box will only appear the first time you run GNSS Solutions, i.e. just after 
installing this program. You will still be able to display this dialog by selecting 
Help>Register Online.
11
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Clicking on the web link will directly take you to a web page on our Magellan 
site –provided your computer has an operating Internet connection– where you 
will be able to fill out a contact form. As prompted in the dialog, it is highly 
recommended to fill out this form as it will give you significant advantages.
After filling out the web form, come back to the GNSS Solutions window. Click 
OK in the Register Online box. The Welcome dialog is now displayed, as shown 
below.

You use this dialog to open an existing project, create a new project, open the 
last project you worked on, or run GNSS Solutions without a project.
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Accessing Utility Programs

While using GNSS Solutions, you will sometimes need to run a utility program. 
To run one of these programs, from the Windows task bar, click on Start, then 
Programs, and then select Tools. The screen will display a number of utilities 
at this point, as shown in the figure below.

Run the desired utility by making the appropriate selection in the menu.

Quitting GNSS Solutions

You can quit GNSS Solutions at any time by selecting Exit from the File menu. 
GNSS Solutions will automatically save the project you were working on.
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Navigating Through the Software

The GNSS Solutions main display has three windows to view and work with 
your data: the Survey View window (1), the Time View window (2) and the Work-

book window (3). You need to open a project in GNSS Solutions to view these 
three windows. (See figure below.) All the tasks necessary to successfully pro-
cess and adjust your data can be accomplished within these windows. Addi-
tionally, the Command pane (4) allows you to easily access the right command 
at the right time.

(1)(4)

(3)

(2)
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Use the following tools to control the layout of the different views within the 
GNSS Solutions main window:
- The View>As Workbook option allows you to fit the views with tabs. (All the 

tabs are grouped at the bottom of the view windows). You can then easily 
display a view by simply clicking on the corresponding tab.
If you clear the View>As Workbook option, all tabs disappear from the main 
window but you can still read the list of available views in the Window 
menu. If you close a view, you will be able to re-open it by selecting this 
view in the Window menu.

- The Dock button ( ) located in the right-upper edge of each view allows 
you to keep this view always visible. Once you have docked the view, move 
it to the desired location by dragging it from its title bar. While dragging, 
GNSS Solutions will draw an empty frame indicative of the final size and 
shape of the view, depending on where the mouse cursor is. When you 
agree with the location and shape, just release the mouse button and the 
view will appear where desired. You can dock several views at a time.

- The Window>Cascade, Tile Horizontally & Tile Vertically options apply to the 
displayed views regardless of whether View>As Workbook is checked or not. 
These options do not affect the view docked to the GNSS Solutions main 
window (if there is one).

When you launch GNSS Solutions for the first time, and as long as you do not 
clear this option, the View>As Workbook option is checked.
When you create a new project, GNSS Solutions creates and opens a number 
of views that are organized as follows:
- Survey view and Time view shown in the upper-right part of the GNSS Solu-

tions main window
- Workbook docked to the lower part of the GNSS Solutions main window.
15
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 Using the Survey View Window

The Survey View window displays points (sites), baselines, vectors, error el-
lipses and observation files from the open project.
When the zoom setting is appropriate, the Survey View also shows the positions 
of reference stations located in the vicinity of the project. Reference stations 
are represented as yellow and blue triangles:

For more information on reference stations, see Corrections Providers & Refer-
ence Stations on page 219. 
When you move the mouse over the Survey View, you can continually see the 
coordinates of the mouse cursor in the status bar at the bottom of the GNSS 
Solutions main window. These coordinates are expressed in the coordinate sys-
tem defined for the project (see Creating a New Project on page 35).
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Map Toolbar and Other Controls
The following tools are associated with the Survey View:
A. Map Toolbar located at the bottom of the screen:

(1): Select tool: Selects one or more objects shown on the map. Multiple 
selection is accomplished either by dragging the mouse cursor around the 
desired objects or by selecting the objects one after the other. You have to 
hold down the Shift key to add new objects to the first selected object.
(2) Zoom In: Zooms in on the area where you click or drag. You can also 
drag a rectangle around the desired area to adjust the scale accordingly.
(3) Zoom Out: Zooms out from where you click or drag
(4) Zoom To Fit: Adjusts the map scale so that all the visible objects 
present on the map can be seen
(5) Grabber tool: Shifts the map as instructed. The map shift directly 
results from the length and orientation of the segment you drag on the 
map.

(1) (2) (3) (4) (5) (6) (7) (8)
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(6) Distancemeter tool: Measures the distance between two points that you 
indicate with the mouse. To use this tool, hold down the mouse button on 
the first point and then drag the mouse to the second point. The tool then 
continually indicates the distance between the start point and the current 
position of the mouse cursor.
This function uses gravity to help you position the mouse cursor exactly on 
the two points (points act as magnets that attract the mouse cursor when 
located in the vicinity). Distance measurements are expressed in the unit 
chosen for the project.
(7) Scale factor: choose a preset value from the combo box. Clicking on the 
zoom-to-fit button will also cause the scale factor to be up-dated to reflect 
the changes then produced
(8) Draw Point tool (see Adding a New Point to the Project on page 25)

B. The same tools are available from the popup menu attached to the Survey 
View (right-click anywhere within the view to access this menu), as well as from 
the Map menu on the GNSS Solutions menu bar.

C. The mouse wheel combined with the following keys:
- The mouse wheel used alone drags the map vertically, upward or 

downward depending on the direction in which you rotate the wheel
- The mouse wheel combined with the depressed Shift key drags the 

map horizontally, to the left or to the right, depending on the direction 
in which you rotate the wheel

- The mouse wheel combined with the depressed Ctrl key zooms in or 
out on the map, keeping the map’s central point immobile. You zoom 
in or out, depending on the direction in which you rotate the wheel.
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D. The following keys on the numeric pad:
- The + key to zoom in
- The - key to zoom out.

Changing the Viewing Settings
The Survey View has a number of viewing options that you can change at your 
convenience.
Right-click anywhere within the Survey View and select Document Settings in 
the Popup menu. This opens the Map Properties window shown below:
19
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The viewing options, grouped at the bottom of the window, are described in the 
table below:

Setting Description Resulting View with 
Button Checked

Resulting View with 
Button Cleared

Display 
Ruler

Shows/hides grid coordinates 
on the map.

Display Grid Shows/hides grid lines on the 
map.

Display 
Compass

Shows/hides the compass on 
the map. The compass is 
always shown in the upper-left 
corner.

Display Ori-
entation

Shows/hides the arrow indi-
cating the orientation of each 
vector displayed on the map.

Display 
Error 

Ellipses

Shows/hides the error ellipse 
relevant to each vector.

Schematic 
Representa-

tion

Performs two different func-
tions:
1) Redraws vectors so that 
they all precisely connect to 
the expected points or keeps 
them as determined.
2) Relocates observations, i.e. moves observation icons and associated filenames next 
to the points or keeps them at their original locations.

See Notes below for more detail.
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 In case of loop misclosure, you may want to see all the concerned vectors join up 
at the same point on the Survey View although the process results show that these 
vectors do not exactly converge. To obtain such a simplified view, you just need to 
check the Schematic Representation option.

 Each observation file is represented on the map by a diskette icon and a filename 
next to it. Before processing, GNSS Solutions locates the icon and filename on the 
map according to the sole observation data present in the file (in fact an autono-
mous GPS solution is determined from this data). After processing, GNSS Solutions 
accurately locates each vector on the map but keeps the relevant observation icon 
and filename at the initial location. To avoid any confusion and simplify the view, 
you can move the observation information next to the point by checking the Sche-
matic Representation option.

The following settings can also be made from this window:
• Changing the coordinates of the point occupying the middle of the map. 

This is equivalent to using the Grabber tool on the map toolbar (see Map 
Toolbar and Other Controls on page 17).

• Changing the map scale. This is equivalent to using the Scale factor box on 
the map toolbar (see Map Toolbar and Other Controls on page 17).

• Choosing a coordinate system specific to the view, i.e. without affecting 
the choice of coordinate system you made at project level.
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Selecting an Object on the Survey View

- To select an object on the Survey View, click  on the Map toolbar (or 
select this button on the Map menu), and then click on the desired object 
on the map document.
If the area where you click is not populated with too many objects, then 
GNSS Solutions will be able to find the object you want to select and will 
highlight it on the map when it is identified.
If the area is densely populated with objects and you click on this area, 
GNSS Solutions will do one of the following:

• If the number of objects close by is less than 6, a popup menu will be dis-
played listing the names of these objects. You will just have to select the 
desired object by clicking on its name in the popup menu.

• If the number of objects is greater than or equal to 6, a new dialog box will 
open listing all the possible objects found in this area. You can then tell 
the software which object you would like to select. Below is an example of 
what this dialog box looks like:
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- In this case, just select the desired object in the list, specify the selection 
type (Add to... or Replace current selection) and then click OK (you can also 
directly double-click on the desired object in the list to select it). As earlier 
mentioned, GNSS Solutions will then highlight the selected object on the 
map document so you can proceed.

 If you zoom in sufficiently on the area before trying to select an object, GNSS 
Solutions will readily find the object without having to resort to the above dialog box.

Point Types and Symbols Used on the Survey View

Icon Type

Logged Point

Intermediate Point

Control point:

- Not fixed

- Fixed vertically

- Fixed horizontally

- Fixed vertically and horizontally

Reference Point Before Survey

Reference Point After Survey

Target Point Before Survey

Target Point After Survey
23
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Vector Conventions Used on the Survey View

Error Displays
After you adjust the network, the vertical and horizontal error is displayed for 
each point. Horizontal error is represented as an elliptical region around the 
point, and estimates real error on the ground. Vertical error is represented as a 
bold black line; the longer the line, the greater the error.

The Survey View window constantly displays the error legend (bottom right) al-
lowing you to readily estimate these errors. The error legend is updated when-
ever you change the zoom settings of the Survey View.

On Survey View Line Type & Color
Unprocessed Thin, dashed, red (baselines)

Processed Thin, green - Processing QA pass
Thin, red- Processing QA fail

Adjusted Thick, green- Adjustment QA pass
Thick, red- Adjustment QA fail

Loop Thin, double gray

Selected Thin, double, dark-blue

Excluded Thin, gray (disabled vectors)

Vertical Uncertainty

Horizontal Uncertainty
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Adding a New Point to the Project
- Click anywhere on the Survey View

- On the Map toolbar at the bottom of the screen, click 
- Move the mouse cursor over the map and left-click where you want to cre-

ate the new point. A new dialog box opens showing the coordinates of the 
new point resulting from where you clicked on the map.

In this dialog box, GNSS Solutions prompts you to create a fixed control 
point, i.e. the control coordinates that result from where you have just 
clicked on the map are also defined as the point’s survey coordinates.
25
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- If the displayed control coordinates are not exactly those of the control 
point, correct these coordinates in the dedicated fields. If the control point 
is a 3D point, check the Height check box and type the known Height coor-
dinate for the point.

- Complete the fields, top left, defining the control point. The dialog box 
might then look like this:
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  Geographical coordinates can be typed in using one of the following three for-
mats (<sp> stands for “space”, ):

- DDD.DDDDD<N/S or W/E>
- DDD<sp>MM.MMMMM<N/S or W/E>
- DDD<sp>MM<sp>SS.SSSSS<N/S or W/E>

Where:<sp>: space, D: Degree digit, M: Minute digit, S: Second digit, <N/S or W/
E>: North or South for latitude, West or East for longitude.

Whatever the format you choose when typing in your coordinates, GNSS Solutions 
will always use the DDD°MM”SS.SSSS<N/S;W/E> format when later on you re-open 
this Point Properties window.

- Click OK. The new point now appears on the map. Its representation on the 
map is in compliance with Point Types and Symbols Used on the Survey 
View on page 23. 
You can quickly add as many points of the same type as needed by holding 
down the Shift key and clicking repeatedly on the map where you want 
these points to be created. In this case, GNSS Solutions skips the display 
of the Points properties dialog box and automatically creates the points.
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Showing/Hiding Items on the Survey View
- On the map pop-up menu, select Legend. This dialog box provides the list 

of all the possible items. If the button before each item name is checked, 
then all these items will be visible on the Survey View. Conversely, if this 
button is cleared, none of these items will be visible.

Deleting a Point from the Survey View
- On the Survey View, select the point you want to delete
- Press the Del key or on the menu bar, select Edit>Delete. A warning message 

appears asking you to confirm your choice
- Click Yes to allow GNSS Solutions to delete the point.

Viewing the Reference Stations Located in the Vicinity
- Just zoom out until you can see them (if there are any).
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Using the Time View Window

The Time View window displays the observations for each file loaded into the 
project. This display provides a quick and easy look at the observation time for 
each site:

The horizontal axis of the Time View window shows the date and time of data 
collection.
The vertical axis of the Time View window provides the file name of each ob-
servation. The diagram shows the duration of each observation. Inside each 
static observation is the name of the point where the observation took place.
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An observation file may consist of one or more occupations which are basically 
either static or kinematic. The following graphic conventions are therefore used 
to represent the different possible occupations in an observation:
- Bars for static occupations.
- Continuous lines for kinematic occupations.
- Dotted lines for excluded occupations corresponding to intervals of time 

for which GNSS Solutions is not expected to produce any result (points or 
trajectory). Excluded occupations are usually the periods of time during 
which field operators have to move from one point to the next (typically 
Stop & Go Surveys).

 Remember that for the sake of preserving system initialization throughout field 
operations, the field equipment has in fact to continuously collect data, including 
during those idle periods of time.

- Short vertical lines separate kinematic occupations from excluded occupa-
tions.

The table below shows how these conventions are used in typical cases of sur-
veys.

You can double-click any occupation in an observation to view its information. 
In case of ambiguity on which occupation you clicked or double-clicked, GNSS 
Solutions opens a dialog asking you to choose an occupation. Choose the de-
sired one from the prompted list and click OK. Then right-click and select Prop-
erties to view the information pertaining to this occupation.

Static (base, rover): a single bar.

Stop & Go (rover): static occupations separated by 
excluded occupations.

Kinematic (rover): a single line.

Kinematic (rover), two trajectories collected in the 
same data file with a pause in between: two lines sep-
arated by an excluded occupation.
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An observation file may include events. Events are time markers represented 
on the Time view as warning road signs (see below). Like occupations, events 
can be edited in GNSS Solutions (see Observation Properties on page 67):

The following tools are available to work in the Time View:
A. Map Toolbar located at the bottom of the screen:

(1): Select tool: Selects an item shown on the Time View.
(2) Zoom In: Zooms in on the area where you click or drag
(3) Zoom Out: Zooms out from where you click or drag
(4) Zoom To Fit: Adjusts the map scale so that all the visible objects 
present on the Time View can be seen
(5) Grabber tool: Shifts the view as instructed. The map shift directly 
results from the length and orientation of the segment you drag on the 
view.

B. The same tools are available from the popup menu attached to the Time 
View, as well as from the Time menu on the GNSS Solutions menu bar.

You can also split an occupation into more occupations so you can process 
these occupations separately or reject them from the processing. See Filtering 
Occupations on page 75 for more information.

(1) (2) (3) (4) (5)
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Using the Workbook Window

The Workbook window has tabs to display different kinds of information, from 
coordinates to network precision statistics.

- Switch between displays by clicking a different tab.
- Double-click on any column header to sort the data in ascending or 

descending order.
- Right-clicking in any column or highlighted row gives access to a menu 

allowing you to select one of the following functions:
• Tabs: to define the tabs you want to include in or exclude from the Work-

book window.
• View: to change the coordinate system used in the Workbook window 

(and not at project level)
• Data: To define the data columns you want to show/hide in the displayed 

tab
• Sort: To sort the data rows in the viewed tab according to 1 to 3 different 

criteria
• Properties: (for a highlighted row only) To view the properties of the item 

displayed in the highlighted row.
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- Highlighting a row in a Workbook tab –by clicking in the leftmost cell- 
highlights the corresponding item displayed in the Survey View. For exam-
ple, clicking in the leftmost column of a Point row in the Points tab high-
lights this point in the Survey View.

Output pane:
Below the Workbook is the Output pane, which displays summary information, 
activity log information, and warnings. Although the text is not editable, you 
can select text and copy to the clipboard or other applications by right-clicking. 
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Using the Command Pane

The Commands pane is designed to help you choose the right command at the 
right time. The available commands are organized by topic and are in fact 
those accessible from the GNSS Solutions menu bar -more particularly those 
from the Project menu- but here they are shown as icons, with command names 
displayed after icons. To run one of these commands, simply click the icon.
The number of topics contained in the tab is context-sensitive. Among these 
topics is the Utilities topic, permanently available, and that you can customize 
using the command Tools>Customize... (Tools tab). To open a topic when several 
topics are available, click the horizontal topic bar showing the name of the top-
ic.

 For the sake of conciseness, we will generally mention in this manual how to 
access a command by navigating through the menus (the “>” symbol will be used 
between the different selections you have to do to access a command; e.g. 
Project>Check Loop Closure). You must be aware though that most commands can 
more quickly be accessed through the Command pane. 

Selected topic

Topic barsCommand icons available 
in the open topic
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Chapter 3: Projects

GNSS Solutions uses a Project for manipulating data files and for processing 
site locations. This chapter describes the creation, modification, and manipu-
lation of a project once you have collected survey data with a GPS receiver. It 
is still assumed that you installed GNSS Solutions with the default choices.
A project can be considered a repository for raw data files (received from GPS 
receivers) and site information (site IDs, site names, and antenna heights) re-
corded in the handheld or manually in a logbook.
If you are creating a new project, proceed to the next paragraph below. If you 
want to access an existing project, refer to Opening an Existing Project on 
page 43.

Creating a New Project

You can create a new project at startup or any time the software is running.
 To create a project with GNSS Solutions running:

• Type Ctrl+N, or
• Click the New button on the toolbar, or
• Select New from the File menu. This closes -and saves- any open project 

and opens a new project. Go to Step 2 to continue with the project setup.
To create a project at startup:

1. Start GNSS Solutions from the Windows task bar by selecting successively 
Start>Programs>GNSS Solutions>GNSS Solutions.
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A momentary screen opens, followed by the Welcome dialog shown below:

2. Click on Create a new project. The New Project dialog appears.

This tab allows you to enter the name of the new project, e.g. Smith Survey
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3. In the same dialog, click on Modify Default Settings. Note that the new dialog 
presents three tabs: Region, Precise Ephemeris and Miscellaneous.

The Region tab lets you define the coordinate system. The defaults, 
WGS84, GMT+01:00 Time Zone and Meters unit, appear the first time you 
use the software. You can change these parameters to your preferred set-
tings, after which your preferred settings become the new defaults. Refer 
to Chapter 7: Coordinate Transformations on page 119 for more informa-
tion about coordinate system settings.
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4. Click on Precise Ephemeris to switch to the Precise Ephemeris tab (see 
below).

This tab contains the three data subsets described below:
- Precise Orbit Files:

Path

Use this field to specify the path and folder where GNSS Solu-
tions can find the precise orbit files (in SP3 or EF18 format). This 
field is irrelevant to broadcast orbits.
If Automatically Import and use ephemeris files in the project 
folder is enabled (see below), then Path is automatically set to 
provide the path to the folder of the open project and you are not 
allowed to change it.
If Automatically Import and use ephemeris files in the project 
folder is disabled, then Path is automatically set to the default 
orbits folder but you can choose another path if you wish.

Default is

Use this field to specify the type of precise orbit data to be used by 
default in the project. There are three possible choices:
- Broadcast (default choice)(orbit data from satellites)
- Precise SP3
- Precise EF18
38



Projects
Creating a New Project

P
ro

je
c
ts
- Internet Download: Use this subset to tell GNSS Solutions how to 
deal with ephemeris files.

Automatically 
import and use 

ephemeris files in 
the project folder

If enabled, this option asks GNSS Solutions to use the ephemeris 
files stored in the project folder. When enabling this option, you 
may also set the two parameters below.

Downloaded from 
Internet

If enabled, this option will allow GNSS Solutions to import ephem-
eris files from the Internet if the required file cannot be found in 
the project folder. GNSS Solutions will use a software submodule 
from Internet Download to perform this operation. Messages will 
appear on the screen when files are downloaded from the Internet 
to the project folder.

Stored in the local 
data base

If enabled, this option will allow GNSS Solutions to import ephem-
eris files from the local database if the required file cannot be 
found in the project folder. The local database is located in the 
...\Program Files\Common Files\Magellan Pro\Orbit folder and 
cannot be moved elsewhere. 
This option can be used with the Downloaded from Internet 
option also enabled. In this case, GNSS Solutions will first search 
for the file in the local database. If it cannot be found there, then 
the file will be downloaded from the Internet, if it’s available.

Delete files...

Use this button to delete all ephemeris files from either the local 
database or project folder, or from both. Two options are avail-
able:
Delete Ephemeris stored in the local database: If checked on, 
all ephemeris files stored in the local database will be deleted 
after you click OK.
Delete Ephemeris stored in the project folder: If checked on, 
all ephemeris files stored in the project folder will be deleted after 
you click OK.
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- Data Centers: This data subset needs to be set only if the Automatically 
import and use ephemeris files in the project folder option is enabled. Each 
ephemeris data type can be downloaded from a different data center.
The Browse Data Center button allows you to access a database from 
which you can view the characteristics of each of the available data 
centers. See also Adding an Ephemeris Data Center on page 46.
GNSS Solutions will always try to get the most precise data from a 
given data center. In order of preference, the following files will be 
imported if they are all available from the chosen data center: 1) 
Final, 2) Rapid, and 3) Ultra-Rapid.
A warning message will appear in the GNSS Solutions output pane if 
precise data normally available from a data center cannot be deliv-
ered at the time of request.

5. Click on Miscellaneous to switch to the Miscellaneous tab (see below)

This tab contains the four data subsets described below:
- Blunder Detection. Define the two criteria required to run the Blunder 

Detection test:
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- Network Adjustment. GNSS Solutions allows you to weight the net-
work adjustment results. The Confidence scaling factor field can be 
used for this purpose. Unless you are familiar with this parameter, 
keep it unchanged (default value: 1). See also Chapter 6: Adjustment 
on page 109.

- Quality Control:

- Satellites: Select the satellite systems you wish to use in your project 
(GPS,GLONASS, SBAS). Any combination is possible.

- VRS Max. Range: In the VRS process, this parameter is used to limit 
the number of usable stations to only those located at a distance from 
the survey point less than this value. All reference stations located 
beyond this distance will not appear in the list of usable stations. 
Default value: 200 km (125 miles). See also VRS Data Processing on 
page 231.

Minimum 
observation time 

span

Minimum amount of observation time in a data file allowing 
this file to be imported.
Enter a value in minutes (default: 5 minutes). For example, 
if this value is 15 seconds, enter “0.25”.
No data file will be imported if the observation time is less 
than the value specified in this field.

Valid antenna 
height range
From... To...

Lower and upper limits of the antenna height from the 
ground. Enter these values in the selected unit.
Any antenna value outside this range is considered a blun-
der and displays with a warning. 

Horizontal

Use this field to enter the desired horizontal accuracy for all vec-
tors processed and adjusted in the project. Computed uncertain-
ties of adjusted data will be compared to this threshold value. Any 
data not meeting this accuracy will be flagged in the QA attribute 
as Failed.

Vertical

Use this field to enter the desired vertical accuracy for all vectors 
processed and adjusted in the project. Computed uncertainties of 
adjusted data will be compared to this threshold value. Any data 
not meeting this accuracy will be flagged in the QA attribute as 
Failed.

Maximum 
acceptable control 

error

Use this field to enter the maximum permitted deviation between 
the known coordinates of any control, target or reference point 
and the surveyed coordinates for this point.
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- Processing scenario control (Rebuild process scenario automatically on 
any change parameter). If you make changes to the project that impact 
the processing scenario determined by the program, GNSS Solutions 
will refer to this parameter to know how to respond. If the button is 
checked, the processing scenario will be updated automatically. If the 
button is cleared, GNSS Solutions will prompt you to update the sce-
nario, which you can accept or reject.

(Feature Code List tab: See Editing the Feature Code List on page 162.)

6. At this point you have finished setting up the project, but the project con-
tains no raw data to process; you must now add raw data to the project. 
Click OK to close the Default Project Settings dialog and OK again to close 
the New dialog. The Import dialog appears (see below). For information on 
adding data files to your project, refer to Chapter 4: Adding Data Files to a 
Project on page 49.
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Opening an Existing Project

You can open an existing project at startup or any time the software is running.
To open a previously created project at start up:
1. In the Welcome dialog, click on Open an Existing Project.

2. In the Open dialog that opens, navigate to the filename of the project you 
wish to open:

3. Double-click the filename or highlight the filename and click OK. The 
project opens with the Time View/Survey View and Workbook windows. 
GNSS Solutions displays the project name in the title bar.
43



3 Projects
Saving a Project
To open a project with GNSS Solutions running:
• Click the Open button on the toolbar, or
• Select Open from the File menu, or
• Click the Project topic bar in the Command pane and then click on the 

Open Existing Project icon.
This closes the open project and opens the Open dialog. Then proceed 
as explained in steps 2 and 3 above.

After opening a project, you may need to add data files. To add files, refer to 
Chapter 4: Adding Data Files to a Project on page 49.

Saving a Project

You can save an open project at any time with one of the following methods:
• Type Ctrl+S
• Click the Save button on the toolbar
• Select Save from the File menu

You can also save the current project under a different name by selecting Save 
As from the File menu. The Save As function is not a Rename function. What 
this function actually does is it duplicates the current project, names it as in-
structed, closes the current project and opens the newly created project in the 
main window.
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Project Settings

The project settings are either the default values or were set when the project 
was created. To view project settings, select Project>Edit Settings. The Project 
Settings dialog appears, as shown below.

The Project Settings dialog lets you set the same parameters as the New Project 
dialog. You can edit any of the parameters within the Region and Miscellaneous 
tabs.
Once you have modified the parameters, click OK to save the project settings 
and close the dialog.
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Adding an Ephemeris Data Center

- From the menu bar, select Tools>Ephemeris Data Centers. This opens a new 
dialog box showing the default data centers.

- Click on  in the upper-right corner of the Ephemeris Data Centers win-
dow. This opens a two-tab Properties dialog box.

- Click on the Description tab and then enter the following parameters:
• Name: Data center name (mandatory)
• Comment: More information about the data center (optional)
• Info: Web site giving more information on this data center (optional)

- Click on the Services tab.

- Click on  in the upper-right corner of the window. This opens the Ser-
vice dialog box.
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Note that this dialog box will be slightly different depending on whether 
the access to the web site is public or restricted.

This dialog box is organized, and should therefore be used, as follows:
• Name: Enter the service name or any other information relevant to the 

desired service. For example enter “Precise ephemeris data”
• Host: Enter the web address from which to download
• Data Type: Choose the type of data delivered by this service. The choice 

refers to both rate (Final/Rapid/Ultra-Rapid) and type (Precise orbit 
files/ Precise clock files/Precise ionospheric data files).

• Time Span: GNSS Solutions needs to know the period of time covered by 
any of the files delivered by this service. Enter this time in minutes. 
Ask the data center or consult its web site if you do not know this 
value.
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• OBS Files: GNSS Solutions needs to know where the files are stored on 
the data center’s web site and how they are named. You should then 
enter the path to files followed by the syntax used in the filenames. The 
“+” button located on the right of this field allows you enter this syntax 
in a more friendly way. Note that you can use [SSSS] to specify a wild 
string.
Ask your data center or consult its web site if you do not know the path 
and the syntax of filenames.

• Comment: Enter your personal notes regarding the service (optional)
• More Info: For example, use this field to enter the address of a particular 

page on the data center’s web site.
• Passive mode: Enable this option to bypass your local firewall.
• Public/Restricted Access radio buttons: Choose the appropriate option. If 

you check Restricted Access, then you will have to enter a user name 
and a password in the next two fields.

• Log in: If you have checked Restricted Access, enter the user name nor-
mally supplied by the provider to access the specified web site

• Password: If you have checked Restricted Access, enter the password 
normally supplied by the provider to access the specified web site.

- Click OK to save the service you have just defined. This closes the dialog 
box and takes you back to the previous dialog box where you can see the 
list of existing services defined for this data center.

- To create a new service, click  again and resume the above instruc-
tions.

- Click OK when all the services have been defined. This takes you back to 
the Ephemeris Data Centers window where the new data center is now 
listed. 
48



Adding Data Files to a Project
Downloading Data From Z-Max or ProMark3

A
d
d
in

g
 D

a
ta
Chapter 4: Adding Data Files to a 
Project

This chapter describes the process for adding data files to a project. This pro-
cess uses the Download and Internet Download modules of GNSS Solutions. 
The following tasks are described:
• Downloading Data From a Receiver
• Importing Data from Files
• Downloading Base Data from the Internet
• Importing Positions, Vectors or Features From Files

Downloading Data From Z-Max or ProMark3

The data logged on the data card or receiver memory during your field surveys 
can be downloaded into a GNSS Solutions project via the Download utility pro-
gram using the Project>Download Raw Data from Z-Max or ProMark3 command in 
GNSS Solutions.

Warning! Atom raw data (G*.* files) cannot be downloaded using this com-
mand. Only the Project>Import Raw Data from Files or ProMark 500 can be used to 
download Atom raw data (see Importing Data from Files or ProMark 500 on 
page 51).

Downloading data from a receiver can generally be performed according to one 
of the following two methods:
- Via the USB port
- Via serial port

 It is recommended to use the USB port rather than a serial port as this connec-
tion offers a faster transmission speed (up to 50 kB/s for USB, only 10 kB/s for a 
serial port).
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A third method also exists in which you have to remove the data card from the 
receiver and insert it into the card reader installed in or connected to your PC. 
This method is the fastest one as the data is routed directly from the data card 
to the Download module, but you need the appropriate card reader.
The diagram below summarizes the three download methods.

To download data from the card installed in the receiver, do the following:
- Power on the receiver and connect it to the Office PC via USB port
- On the GNSS Solutions menu bar, select Project>Download Raw Data from 

Z-Max or ProMark3. This starts the Download utility program and opens its 
main window on the screen.

- On the menu bar in Download, select File>Connect>Receiver>Connect via 
USB, then choose Thales Navigation USB device# in the Connect via USB 
dialog box that opens, and finally click OK. After communication is estab-
lished with the receiver, Download shows the files in the PC current direc-
tory on the right pane, and the files present in the data card on the left 
pane

- On PC side, select the directory where you want to download the files 
(default directory: project directory)

- On the left pane, select the file(s) to be downloaded and drag them to the 
PC pane. Download copies the file to the PC. A progress dialog box indi-
cates the status of the download.

 The Project>Download Raw Data from Z-Max or ProMark3 command should not 
be confused with the Project>Import Raw Data from Files or ProMark 500 command. 
The latter command can only import pre-converted data files, ready for processing, 
whereas the former command, in which the Download module is involved, is used to 
download AND convert the raw data files that come direct from the field and that 
Download splits up into several files for GNSS Solutions to process them.

GNSS Download

Data Card Reader

Office PC

GPS Receiver

USB port

Serial port

Solutions
DownLoad Data

DownLoad Data

DownLoad Data

Utility
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Importing Data from Files or ProMark 500

This is a key function in GNSS Solutions as not only does it allow you to add 
data to your projects but also to do the following:
• Before importing the data to the project:

1. Check/edit the Site IDs associated with the observation files you are 
importing

2. Check/edit the file type (fully dynamic or static, with or without static 
occupations)

3. Check edit the antenna characteristics (antenna type, height and 
height type)

4. Display the time view giving the relationship between all the observa-
tion files selected for import

5. For each observation file selected for import, plot the S/N ratio, eleva-
tion and carrier phase for each satellite received during this observa-
tion

6. Set control points and possibly fix some of them.
• Rather than running the Import Data function alone, you can ask GNSS 

Solutions to automatically run one or more functions after this one – this is 
one of the most outstanding features in GNSS Solutions. Here are the dif-
ferent possibilities:

1. Import: you just want to add data to the project. You will run the 
processing later on.

2. Import and process single sites: In addition to importing data, GNSS 
Solutions will also compute –in autonomous GPS mode– the locations 
of the points associated with the observation files.
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3. Import and process baselines: you want GNSS Solutions to automati-
cally process the data once imported in the project.

4. Import, process and adjust: Same as previously except that in addi-
tion, GNSS Solutions will then adjust the vectors based on the control 
points you will have set and fixed before importing the data.

Follow the instructions below to use the Import Data command:
- Press F4 or select Project>Import Raw Data from Files or ProMark 500. If you 

want to import raw data directly from a ProMark 500, connect this unit to 
your office computer via a USB cable.

- Choose the type of data you want to import. The table below summarizes 
all the input formats supported by GNSS Solutions.

- Browse on your disk to select the folder containing the files to import and 
then select these files. If you are importing raw data directly from a Pro-
Mark 500, browse this unit, seen as a USB device, and then select the 
desired raw data files.

- Click the Open button. This opens the Importing GPS Data dialog box.

Import Format
Atom (G*.*)
Ashtech (B*.* file)
RINEX (*.*o or *.*d file)
DSNP (*.bin, *.var or *.d* file)
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This dialog (see example below) is one of the key dialog boxes in GNSS 
Solutions for post-processing applications as it gives you full view upon, 
and full control over what’s going to be post-processed and how.

 

The upper table allows you to read the properties of the files selected for 
import.

- Check and, if necessary, edit the following parameters:
1. Name of point (site) associated with observation file
2. File type (Dynamic/static). GNSS Solutions automatically detects the 

type of the file. (The box is cleared if the file is static.)
3. Antenna height value

Displays Time View

Displays data of selected file

Adds more files to the raw data table

Use this table to define 
your control points
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4. Height type. Tells GNSS Solutions how you measured the antenna 
height (through a vertical, true or slant measurement)

5. Antenna type. If the mentioned antenna type is unknown to GNSS 
Solutions, it will appear in bold characters in the field. This means 
you will have to define its properties when you import the file (a dia-
log will appear at that time so you can enter these properties).
If the field is blank, this means the file does not mention the type of 
antenna that was used in the field. You must now specify this antenna 
type by selecting this type from the list of known antennas. If neces-
sary, ask the field operator if you don’t know the type of antenna that 
was used. If it turns out that the antenna used is unknown to GNSS 
Solutions, you must first create this antenna type (see Creating a New 
Antenna Type on page 88).

- Three buttons in the upper right corner are associated with this table:

: Displays a time diagram showing the static occupations 
detected in the files listed in the upper table. Static occupations are 
represented by gray rectangles and dynamic occupations by gray 
lines. If you click on this button after selecting one of the files in the 
table, then the static occupation corresponding to this file will appear 
in dark blue. See also Observation Properties on page 67.

: Displays a time diagram showing the data for each satellite, as 
read from the selected file. See also Observation Properties on 
page 67.

: Allows you to remove the selected file from the table because 
you do not want to import it anymore.
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- If you wish, you can right now set control points, i.e. BEFORE importing 

the files using the table at the bottom of the dialog. You can still set and 
fix control points after importing data files (see Chapter 5: Data Process-
ing).
Control points can only be points derived from the files present in the 
upper table. After you select a point in the first cell (Name cell), press the 
Tab key to edit the properties of the control point. These properties are 
derived from the corresponding data file. You can edit these properties. For 
example you can:

- Change its coordinates if you know the true values of some or all of its 
coordinates

- Define its type, i.e. which of the coordinates are accurately known 
(hence 1D, 2D or 3D). In the Control cell, select “Ver.” for 1D, “Hor.” 
for 2D and “Hor.&Ver.” for 3D.

- “Fix” some of its coordinates, i.e. force GNSS Solutions to keep the 
coordinates you supply for this point rather than allow it to determine 
these coordinates through post-processing. At this stage, you usually 
fix only one of the points that you set as control points. In the Fixed 
cell, select “blank” to not fix the control point, “Hor.” to fix it hori-
zontally (Lat/Lon or X/Y), “Ver.” to fix it vertically (Elev./Height) or 
“Hor.&Ver.” to fix all its coordinates.

The Add Raw Data button allows you to add more files to the upper table 
without having to resume the whole file import process. Files may have dif-
ferent sources (your disk, Internet or your field equipment). See Download-
ing Base Data from the Internet on page 58 to learn how to download data 
from the Internet.
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- When you are ready to import files, click on the OK button. A drop-down 
menu is displayed in which you can choose to simply import the files or 
automatically run one or more operations in succession after file import:

- Choose the option that suits you best:
• Use To Import if you just want to import the files. You may want to do this 

because you prefer to break down the whole processing into distinct basic 
steps. Why? Because you want full control over each of these steps. You 
will then analyze the processing scenario prompted by GNSS Solutions and 
make changes to it if required. You will then run the baseline processing as 
such followed by a network adjustment step, if appropriate.

• If you use the To Import and Process Single Sites option, GNSS Solutions will 
import the files and then will determine the locations of all the points cal-
culated from the imported files. Use this option to preview all the points of 
a dynamic or stop & go survey prior to processing the baselines.

• Use To Import and process Baselines to import and then process the base-
lines according to the processing scenario found by GNSS Solutions. You 
will skip the checking of the processing scenario when you choose this 
option.
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• Use To Import, Process and Adjust if you want to obtain the results in the 
fastest possible manner. This implies however that you entirely rely on 
GNSS Solutions in the choices of the processing options since you will not 
be able to check the processing scenario or analyze the results before net-
work adjustment. You will however be able to thoroughly check all the 
results once they are made available on the screen.

• VUse To Import and Process Using VRS if you want to post-process your field 
data using the VRS base raw data file you have asked GNSS Solutions to 
generate rather than the base raw data from a given base. See also VRS 
Data Processing on page 231.

Suggestions & Recommendations:

• Choose To Import, Process and Adjust only if the project contains redundant 
measurements.

• If you are working on geodetic networks, you should NOT fix more than one 
control point at this stage as it is essential that you start with a minimally 
constrained adjustment before proceeding to a fully constrained adjust-
ment.
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Downloading Base Data from the Internet

Base data can easily and rapidly be downloaded from the web using the Inter-

net Download utility.
You need to use this functionality when you do not have your own equipment 
to collect the base raw data you need for post-processing your field data. You 
need base raw data for a given period of time corresponding to the time when 
you were working in the field with your survey equipment.
You will preferably download raw data from the available base station the clos-
est to your working area. If this station is shown on the Survey View, a new au-
tomatic procedure now available in GNSS Solutions lets you download raw data 
from this station through a few clicks of the mouse (see Downloading Data 
From a Reference Station Shown on the Survey View on page 60).
Remember that for a reference station to be visible on the Survey View, it must 
have been added to GNSS Solutions by creating a new provider (see Adding a 
New Provider on page 221).
In all cases, the recommended order to add data to your project is first you im-
port or download the rover data and then you download base raw data. If you 
operate in this order, you will automatically set the date & time parameters in 
Internet Download to be consistent with the date & time of the rover data.

General Case
You can invoke the Internet Download utility either separately from the Win-
dows task bar or from the Importing GPS Data dialog (see Importing Data from 
Files on page 51) when you are adding data to the open project from files on 
your PC disk. In this dialog, click on the Add Raw Data button located at the 
bottom of the dialog and then select Downloaded from Internet.
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This opens the Internet Download main window:

Follow the instructions below to use Internet Download:
- In the Provider field, choose the name of the provider Internet Download 

will have to connect to to get the required data. For your information, when 
selecting a provider in this field, its web address appears at the bottom of 
the window.

- In the Service field, choose the type of data you want to download from the 
provider.

- In the Station field, choose the station from which you want data.
- In the Time Zone field, choose the time zone relevant to your working area.

Note that the Start Date and Start Time fields are automatically set to cover 
the period of time defined by the observation files already present in the 
open project (or about to be added to the project). You may however 
change these settings if required.
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- In the Target Path field, enter the path and folder on your PC where you 
want Internet Download to store the downloaded files.

- Click the Download button to start downloading the files. This may take a 
while. Messages will appear at the bottom of the window to keep you 
informed on the operations in progress.

- When downloading is complete, click on the Close button to close the 
Internet Download window and return to the Importing GPS Data dialog.

Downloading Data From a Reference Station Shown on the 
Survey View
You can go even more quickly to acquire the required base raw data by down-
loading them from the reference station icon shown on the Survey View:

- In the map toolbar, click on .
- In the Survey View, double-click on the icon of the reference station from 

which you wish to download data. This opens a dialog box showing the 
properties of the station.

- Click on the Download Data button. This launches the Internet Download 
utility. Note that the now non-editable Provider and Station fields have auto-
matically been preset to match those of the station.

- Choose the type of data you want to download from this station (Service 
field). If you choose one of the possible three orbit data types, the Station 
field will disappear from the dialog box.

- Enter the date, time and duration for which you want base data.
- Click on the Download button to start downloading the data. At the end of 

the sequence, “Process completed successfully” appears in green at the bot-
tom of the Internet Download window. The downloaded files can be found 
in the project folder.

- Click the OK button to close Internet Download.
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Importing Positions, Vectors or Features From 

Files

- In the Command pane, click on the Import topic bar and then on the Import 
Geo Data from Files icon.

- Choose the type of data you want to import and then click OK. The table 
below summarizes all the input formats supported by GNSS Solutions ver-
sus the type of imported data.

*: Available only if Show CAD functions option is enabled in Tools>Preferences.

For more information on the user-defined format, see Creating Custom Formats on 
page 154.

Import Format Points Vectors Features*
NMEA (*.txt file)
TDS (*.CR5 file)
Carlson (*.CRD file)
User-defined
Ashtech (O*.* file)
AutoCAD (*.DXF file)
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- Browse on your disk to select the folder containing the files to import and 
then select these files.

- Click the Open button. GNSS Solutions then imports the data contained in 
the chosen file(s) into the open project. A message in the Output pane 
indicates the end of data import. The imported data can be seen in the 
Survey View and the Workbook window.

Deleting a Data File from a Project

Any raw GPS data file loaded into a project can later be deleted from the 
project. Be aware that vectors generated by these observations will NOT be re-
moved automatically from the project.
To delete data files:
• Switch to the Files tab in the Workbook window.
• Select the row containing the file name of the files you wish to delete 

(click in the leftmost cell to select the entire row)
• Press the Delete key. A confirmation message appears
• Confirm that you want to delete the file by clicking on the Yes button.
After deleting a data file, you must add the data file to the project again in or-
der to use it.
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Deleting a Point from a Project

Deleting a point from a project causes all vectors based on this point to be de-
leted as well.
• Select the point in the Points tab of the Workbook window.
• Press the Delete key on your keyboard.

Merging Two Points

You may need to merge two points together because they are in fact the same 
point. You usually need to do that to clean the data coming from the field 
where, for any reason, a number of additional points were unnecessarily creat-
ed.
To merge two points into a single one:
• Select the two points on the Survey View
• From the menu bar, select Project>Merge Points. A message will appear 

informing you of the distance between these two points and asking you 
whether you really want to merge these two points.

• Click Yes. A new window is displayed asking you to specify which of the 
two points is the real one. This point is the point that will continue to exist 
after the merge operation.
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• Choose this point from the list and then click OK. The two points are then 
merged into a single one.

 Merging two points is different from deleting the unwanted point in that it pre-
serves all the baselines connected to the unwanted point. These baselines are then 
all attached to the remaining (real) point.

 You cannot merge more than 2 points at a time. 
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Chapter 5: Data Processing

Raw data collected by a receiver must be processed to determine the differen-
tial relationship between the points occupied during data collection. The result 
of processing GPS raw data is a vector defining this relationship. Computation 
of these vectors is the role of the data processing module within GNSS Solu-
tions.
The data processing module automatically analyzes the quality of the raw data 
files and adjusts processing parameters to produce the best vector possible, 
transferring most of the processing effort from the user to the processing soft-
ware. In GNSS Solutions, the actual processing of your data is limited to a sim-
ple press of the Process button, safe in the knowledge that you will get the best 
answer.
GNSS data is processed in three steps:
• Pre-process data analysis: Point and observation properties, such as Site 

IDs, antenna height parameters, and control point information are verified 
and/or entered. As explained in Chapter 4: Adding Data Files to a Project, 
this step can be run BEFORE importing data files into a project.

• Processing: A push of a button invokes the processing engine to produce 
GNSS vectors from raw data.

• Post-process data analysis: Processed GNSS vectors are analyzed using 
supplied analysis tools, to determine the quality of processed data.

This chapter outlines the steps for processing your raw GNSS data.
65



5 Data Processing
Pre-Processing Analysis: Editing Data
Pre-Processing Analysis: Editing Data

The processing of GNSS vectors relies on two sources of data, raw GNSS data 
collected by the receiver, and observation and point-specific data provided by 
the user. When using a handheld or a GNSS receiver with an integrated user 
interface, much of the user-supplied data can be entered in the field during 
data collection. In this case, verify the data before processing. If a handheld 
was not used, this data must be entered manually.
Verification and editing of user-supplied observation and point data can be per-
formed in more than one location within GNSS Solutions. Primarily, the Obser-
vation Property dialog is used for this task. The next section in this chapter 
outlines the user-supplied data that can be viewed and edited in this dialog.
You should analyze your data before processing. Pre-processing data helps you 
through the preparation of data for baseline processing. You will also be able 
to identify and correct common problems.
To begin the pre-process analysis:
• If you have not done so already, load all the data files into your project. See 

Chapter 4: Adding Data Files to a Project for more information.
• Verify that the Time View window and the Workbook window with the Files 

tab are open.

If you logged point information in the field using a handheld or integrated user-
interface on the receiver and have confirmed that Site IDs, observation time, 
and antenna heights are correct, then you may not need to edit your data.
However, when viewing the data during the preprocess analysis, you may find 
that you need to change some values. For example, if you conducted a static 
survey without entering point information, you need to set the Site IDs and an-
tenna heights for every observation, or edit a point name entered incorrectly on 
the handheld.
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Observation Properties
User-supplied observation data consists of the observation Site ID and antenna 
height parameters. If this information was entered in the field using a hand-
held or integrated user-interface to the receiver, verify the information is cor-
rect. If this point information was not entered in the field, it needs to be 
entered manually prior to processing.
You can view the properties of each observation by selecting the Files tab in the 
Workbook window and double-clicking the leftmost cell of the row correspond-
ing to this observation. You can also double-click the filename in the Survey 
view.
The observation properties are presented on three tabs, the File, Occupations 
and Events tabs.
1. The File tab contains the following information:
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- Graphic area on top showing Signal-To-Noise Ratio, Satellite Elevation or 
Carrier Phase versus Time. This information can be plotted for each satel-
lite, or for all satellites in view during the observation by clicking the corre-
sponding tab in the lower part of the graphic area.

Clicking  in the right-upper corner will maximize the graphic area on 
the PC screen for maximum reading comfort. You can zoom in on a partic-
ular region by dragging a rectangle around this region. Press the Esc key to 
zoom out.
Flags will be shown on the curves wherever something happened during 
data collection: loss of lock (X), possible loss of lock (!), carrier phase 
questionable (?). To read the meaning of a flag, simply click on this flag.
Markers can also be shown on the curves. They represent the time of basic 
data acquisition from a given satellite.
Selecting the desired viewing options for the graphic area is achieved by 
right clicking anywhere in this area and making the desired choices on the 
pop-up menu.
The following characteristics of problem satellite data can cause poor 
results when processed:

- Segments of satellite data that contain multiple flags. This is charac-
teristic of an obstructed satellite.

- Gaps in the data caused by extended loss of lock of the satellite. This 
is characteristic of an obstructed satellite.

- A satellite with rapidly varying signal-to-noise ratio compared to other 
satellites. This is characteristic of a satellite affected by multipath or 
an active ionosphere.
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- A segment of a satellite with rapidly varying signal-to-noise ratio com-
pared to the rest of the same satellite data. This is characteristic of a 
segment of a satellite affected by multipath or an active ionosphere.

- A satellite contributing a very small amount of data compared to the 
other satellites in the data set. Sometimes such a satellite causes 
problems with processing.
For all these reasons, it is highly recommended to mask or delete this 
data before running the process.

- File pane: Shows non-editable parameters describing the observation (file-
name, GPS time at the beginning of the observation, measurement type, 
file size in bytes, observation duration, recording rate -sampling- in sec-
onds)

- Default Site pane: Shows the name (ID) given by the operator to the point 
associated with the file. If the operator forgot to name the point, GNSS 
Solutions will name the point using the name of the observation file. 

- Antenna pane: Shows the antenna type used during the observation, as 
read from the observation file, or as specified previously when importing 
the file (see page 54). A button next to the field allows you to view the 
physical properties of this antenna.
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2. The Occupations tab contains the following information:

• Graphic area on top showing ALL the observation files present in the 
project. For more information about the graphic conventions used, refer to 
Using the Time View Window on page 29. The dark-blue occupation repre-
sents the currently selected occupation in the Time pane (see below).

Clicking  in the right-upper corner will maximize the graphic area on 
the PC screen for maximum reading comfort. Using the pop-up menu, that 
you can have access to by right-clicking anywhere on the graphic area, you 
can zoom in or out on the diagram. Once you have zoomed in several 
times, you can also browse the diagram horizontally using the Panoramic 
command, also available from the pop-up menu.
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• Select Occupation pane:
- Select Occupation combo box: Identifies the currently selected occu-

pation (date and start time). Also allows you to select another occupa-
tion in the same observation file (will cause the selection to move to 
the corresponding line or bar on the graphic area).

- File: Observation filename (non-editable).
- Site ID: Site ID associated with the selected occupation. This field is 

normally completed by the field operator. It can be:
• A 4- to 9-character string representing the Site ID associated with 

the selected static or kinematic occupation.
• Or a blank field if the occupation is an excluded one.
You can edit this field either to modify the Site ID chosen by the field 
operator or to change the nature of the occupation:
• Clearing the field will cause the occupation to become an excluded 

one (and the Static/Dynamic choice will be made invalid).
• Conversely, entering a four-character string if the field is initially 

blank will transform the occupation into a static or kinematic occu-
pation, depending on whether you select Static or Dynamic (see 
below).

In any case, changing this parameter will cause GNSS Solutions to 
update the processing scenario when you click OK to close the dialog.

- Description: Description of the site (editable; 31 characters max.)
- Static/Dynamic choice: Valid only when the Site ID field contains at 

least 4 characters. This choice is normally software-set on importing 
the observation file. You can however change it at your convenience.

- Kinematic initialisation using initializer bar check box: When checked, 
indicates that initialization was performed with the rover antenna 
placed at the end of the base’s initializer bar (for OTF initialization or 
initialization at a known point, it’s cleared). This is analyzed by GNSS 
Solutions when importing rover files. The check box is then set 
accordingly. You are not supposed to change this setting. There will 
be no impact on the processing if you clear this check box that GNSS 
Solutions checked on. On the other hand, you will introduce an error 
in the processing if you check on the box that GNSS Solutions 
cleared. 
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• Split Occupation pane:
See also Filtering Occupations on page 75 for more information on how to 
use the Split function.

- Start: Click this button to split the selected occupation into two dis-
tinct occupations of the same nature. The resulting first occupation 
represents about 10% of the initial occupation and the second one, 
about 90%. On splitting the occupation, GNSS Solutions automati-
cally selects the first (shorter) occupation (shown in dark blue on the 
time chart below). The exact duration of the selected occupation (and 
hence of the second) can be set by editing the Time Span field.

- End: Click this button to split the selected occupation into two dis-
tinct occupations of the same nature: The resulting first occupation 
represents about 90% of the initial occupation and the second one, 
about 10%. On splitting the occupation, GNSS Solutions automati-
cally selects the first (longer) occupation. The exact duration of the 
selected occupation (and hence of the second) can be set by editing 
the Time Span field. 

- Merge with Next button: Allows you to merge the selected occupation 
with the next one. The resulting occupation is of the same nature as 
the occupation you initially selected.

- Time Span: Indicates the duration of the selected occupation (edita-
ble). Changing this parameter always affects the end time, not the 
start time, of the occupation. Consequently, it also affects the start 
time of the next occupation.
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To validate the new value assigned to this field without closing the 
dialog, you just have to click inside another field in the dialog.

- End Time: Indicates the end of the selected occupation, taking into 
account the Time Span setting.

• Antenna pane:
- Antenna height: Antenna height for the selected occupation.
- Height Type: Type of measurement used to measure the antenna height 

(slant, vertical, true) for the selected occupation.
- Apply to All button: Click this button to apply the two antenna parame-

ters to all the occupations in the observation file. Caution! This can-
not be undone.

3. The Events tab contains the following information (for more information 
about events -what they are for, how they are processed- please refer to Pro-
cessing Events on page 94):
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• Graphic area on top showing the events from ALL the observation files 
present in the project. The dark-blue event represents the currently 
selected event in the Select Event pane below.

• Select Event pane:
- Select Event combo box: Identifies the currently selected event (date 

and time). Also allows you to select another event in the same obser-
vation file (will cause the selection to move to the corresponding 
event in the graphic area)

- File: Name of the observation file containing the selected event.
- Site ID: Name of the selected event (9 characters max.). If you are cre-

ating a new event, this field is blank and so you have to enter a name 
for the new event. If the selected event was imported from the obser-
vation file, the event already has a name: you may change it or not.

- Description: Additional information about the selected event (31 char-
acters max.)

• Manage Event pane:
- Add new button: Allows you to create a new event in the observation 

file mentioned in File.
- Delete button: Allows you to delete the selected event.
- Time: Allows you to set the time of occurrence of an event you are cre-

ating or change the time of occurrence of the selected event. To see 
where GNSS Solutions places the event on the time chart (graphic 
area on top of the dialog) once you have set the time, click inside 
another field in this dialog (this action is equivalent to validating the 
value typed in the Time field).
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Filtering Occupations
Filtering occupations is the process through which GNSS Solutions can reject 
unwanted parts in an observation file from the processing. Unwanted parts may 
be periods of time during which GNSS reception was poor or field operations 
were questionable or useless, etc.
Filtering occupations in GNSS Solutions is mainly obtained using the split 
function, as introduced on page 72, combined with appropriate settings for the 
Site ID and Time Span fields. It should be noted that splitting an occupation in 
no way affects the previous and next occupations in the observation file.
As an example, the split function allows you to crop the two ends of a static 
occupation in a Stop & Go survey, for example in order to make sure the occu-
pation is truly static from start to end. Here is how you can do this.
1. In the project, click on the Time View tab
2. On the Time view, use the Zoom In and Grabber commands to locate the 

occupation that needs cropping and then double-click this occupation.
3. On the top diagram in the Files properties window, use the context-sensi-

tive menu (Zoom In, Zoom Out, Panoramic commands) to optimize the 
view of the selected occupation.

4. Click the End button. This splits the occupation into two occupations. If 
necessary, adjust the Time Span value for the selected occupation, then 
click inside another field in the dialog to validate the new time span value.
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5. From the combo box in the Select Occupation pane, select the shorter 
occupation resulting from the splitting. As the combo box remembers the 
currently selected selection, you just have to select the next occupation in 
the list.

6. Clear the Site ID field for this occupation. As a result, the occupation 
changes nature to become an excluded occupation.

7. From the combo box in the Select Occupation pane, select the longer 
occupation resulting from the splitting (i.e. the previous one in the list).

8. Click the Start button. This splits the occupation again into two occupa-
tions. If necessary, adjust the Time Span value for the selected occupation, 
then click inside another field in the dialog to validate this new value.

9. Clear the Site ID field for the selected occupation. As a result, the occupa-
tion changes nature to become an excluded occupation. The two ends of 
the static occupation have now been cropped to the desired values:

10.Click OK to close the File properties window and validate all the changes 
made.
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This is just an example of what can be done with the Split function, combined 
with the use of the Site ID and Time Span fields, to filter your occupations. There 
are a lot of other cases of use. For example, you can remove sections of a tra-
jectory or transform a kinematic occupation into a static occupation, etc. 

Point Properties
User-supplied site data consist of Site ID, site descriptor, and, if available, 
known site coordinates. If any sites occupied during data collection have 
known coordinates, these should be entered as control sites for processing, for 
you should begin processing with known coordinates at a minimum of one site. 
This is referred to as the seed site for processing.
GNSS Solutions can process raw data without a seed site. In such a case, 
GNSS Solutions selects one site to use as the control for processing. The raw 
data coordinates for this site are used as the seed coordinates. In some cases 
this may introduce error in the processed vectors in the amount of approxi-
mately 2-4 ppm of vector length. If this level of error is significant to your sur-
vey, you should use a control site to process the data. The following message 
is issued in the output pane when the processing is run without a control point:

Warning: process starts from an approximated base station position... 

Kinematic data needs special attention when preparing the data for process-
ing. If the kinematic survey was initialized on a known vector, i.e. two known 
sites, the coordinates for the sites on each end of this vector must be entered 
as control sites. If initialization was performed using a Kinematic Initialization 
bar, the base site should be identified as a control site. If this site does not 
have known coordinates, use the raw data coordinates.
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You can view the properties of each point by selecting the Points tab in the 
Workbook window and double-clicking the leftmost cell of the row correspond-
ing to this point. You can also double-click the point name in the Survey view.
Fundamentally, GNSS Solutions handles 5 point types:
- Logged point: Point surveyed in the field in real-time or post-processing 

mode
- Intermediate point: Logged point of lesser interest (e.g. a point in a trajec-

tory)
- Control point: Surveyed point whose accurate position is already known. 

This known position can be set as a fixed input to the processing or simply 
used as comparison material to assess the quality of the survey:

- Reference point: A point materialized in the field whose theoretical coordi-
nates are known in the local system and that will be surveyed for calibra-
tion purposes.

- Target point: A point whose theoretical coordinates, known in the local sys-
tem, are provided for staking-out purposes

Control point (not fixed)

Control point fixed vertically

Control point fixed horizontally

Control point fixed vertically and horizontally
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The table below summarizes the different icons used in GNSS Solutions to rep-
resent these point types. Additional information is also provided about their co-
ordinates and error reports.

NA=Not Applicable

(1): Where applicable, GNSS Solutions calculates the deviations between the theo-
retical and surveyed coordinates.

(2): Only if the coordinate system used in the project is a projected system.

 As the control coordinates of control points are expressed in the project’s system, 
they are automatically transformed if you change the project’s system.

 As the control coordinates of target and reference points are target coordinates 
expressed in the local system, they are kept unchanged when you change the 
project’s system (for example when you run a calibration to make the project’s sys-
tem your local system).

Icon Type Control Coordinates 
Expressed on

Survey Coordinates 
Expressed on

Error 
Report (1)

Logged point NA Project’s system NA

Intermediate point NA Project’s system NA

Control point Project’s system Project’s system Yes

Reference point 
before survey

Local system
NA NA

Reference point 
after survey Project’s system Yes (2)

Target point 
before survey Local system

NA NA

Target point after 
survey Project’s system Yes (2)
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Although point properties may take various forms and meanings depending on 
context and point type, they however all comply with the same box layout, as 
shown below: (Typically, to open this dialog box, double-click any point dis-
played in the Survey view.)

(1): This area shows the type and name of the point as well as its description, 
the layer it belongs to, and a possible comment attached to the point. All point 
types contain these properties.
 (2): This area provides the control coordinates (+ uncertainties) of the point 
as well as the name of the coordinate system in which these coordinates are 
expressed. The field containing the name of the coordinate system is set by the 
software itself.

(1)

(2)

(3)
(5)

(4)
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What control coordinates basically are depends on the point type:
- For a control point, they describe its true position. The coordinates of this 

position is expressed in the coordinate system of the project.
- For a reference point, these are the point’s coordinates expressed in the 

local system
- For a target point, these are the target coordinates that will be used in the 

surveying device to guide the field operator to this point. They are also 
expressed in the local system.

- For a logged or intermediate point, i.e. a point surveyed in the field, this 
area is not displayed, as no control coordinates are known for this point.

L The check boxes before the coordinate fields indicate whether the point 
is 1D (Height box checked), 2D (East, North or Long, Lat boxes checked) or 
3D (all boxes checked). Any coordinate you type in a field will not be involved 
in any processing if you do not check the box located before the field.
(3): This area provides the result coordinates of the point as well as the name 
of the coordinate system in which these coordinates are expressed (software-
set field). Obviously, if you are still in the preparation phase of your survey, and 
as long as field results have not been downloaded to the project for the point, 
this area is not displayed in the Point Properties dialog box. This is true for all 
types of points, except for control points. When you create a control point, 
GNSS Solutions automatically fixes it, which means survey coordinates are de-
fined and set equal to the control coordinates you enter.
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L The check boxes before the coordinate fields allow you to fix the coordi-
nates of the point. What you do when you check one of these boxes is that you 
overwrite the survey coordinate with the control coordinate. The status of each 
coordinate is provided between square brackets after each coordinate label 
and depends on how far you are in the survey and the way you want GNSS So-
lutions to handle these coordinates. The possible values of status are: Import-
ed, Estimated, Processed (Static), Processed (Dynamic), Fixed and Adjusted.
 (4): This area is displayed only when both control AND survey coordinates ar-
eas are displayed. It shows the deviation (error) between each control and sur-
vey coordinate of the point. A total error is also provided on top of the area. If 
it is shown on a green background, this means that the total error is less than 
the Maximum acceptable control error (see Project>Edit settings, Miscellaneous tab). 
Otherwise, it will appear on a red background.
 (5): This area provides a geographical representation of the point. The point’s 
control coordinates, if any, always define the center of the chart whereas the 
point’s survey coordinates can be anywhere on the chart depending on the po-
sition deviation produced by the two sets of coordinates. 
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Setting a Control Point
When processing GNSS raw data collected simultaneously within a network, 
coordinates of one or more points should be held fixed. Normally, these are the 
known coordinates for one of the points. These coordinates are called seed co-
ordinates and the point a control point. You should always choose a site with 
known coordinates as your control point. If you are not concerned about the 
control point, GNSS Solutions automatically chooses a point to behave as the 
control point but it does not however transform this point into a control point.
The coordinates for known control points can be entered for use as the seed 
point in vector processing and as fixed control for the adjustment. Control 
points can be used as horizontal control only, vertical control only, or both. You 
have the option of entering a control point but not holding the control values 
fixed. The advantages of this capability are:
• You can enter all known control points at any time. You may choose to 

enter all control at the very start of the project. You would select just one 
point to hold fixed horizontally and one vertically (can be the same point) 
for processing and the minimally constrained adjustment. When it 
becomes time to perform the fully constrained adjustment, you simply 
need to inform the software to hold fixed the other control points.

• You can perform a Control Tie Analysis. You enter all control prior to the 
minimally constrained adjustment but hold fixed only one horizontally and 
one vertically. The Control Tie tab of the Workbook will then display the 
comparisons between the known control values and the adjusted values for 
those control points you entered values for but did not hold fixed. A large 
deviation may indicate a problem with the control.
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You can set a control point in four different ways:
1. Before importing data, as explained in Chapter 4: Adding Data Files to a 

Project.
2. By selecting the Project>Define Control Points command. This opens a dialog 

in which you can set a control point according to a procedure similar to the 
one described in Chapter 4: Adding Data Files to a Project.

3. By using the Project>Change Into command. This opens a dialog in which 
you can change the selected point into a control point. When you do that, 
GNSS Solutions assigns default control coordinates to the control point. 
(default control coordinates=survey coordinates). To change the control 
coordinates of the point, see 4. below.

4. By editing the properties of the point you want to set as a control point:
• In the Survey View or the Workbook window (Points tab), double-click the 

point you want to set as a control point
• In the field top left, select Control Point

The dialog box is updated to allow you to enter the control coordinates 
of the point. By default, these coordinates are preset to those sur-
veyed.
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• Enter the control coordinates of the point in the bottom left fields:

• Unless known, set the standard errors of each value to zero (0). The control 
point will be made a 1D, 2D or 3D control point depending on which check 
boxes are set before the three coordinate fields (all boxes checked=3D 
control point).

The dialog box then gives a visual representation and the value of the 
deviation between the control position and the surveyed position. This 
information is also visible in the Control Tie tab of the Workbook win-
dow.
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You can also fix the control point by clicking the check boxes located 
underneath the lock symbol. When you do that, you assign the control 
coordinates to the point thus eliminating the notion of error between 
the surveyed and control coordinates since there is no more surveyed 
coordinates retained for the point. You usually fix only one control 
point when you start the processing. In the next step, you will be led 
to fixing more control points (see Chapter 6: Adjustment).

- Click OK to validate the control point and close the dialog. In the Sur-
vey view, the symbol used for that point is now a triangle.

Editing Site IDs
The Site ID is a very important property of a point. Each point must have a 
unique Site ID. When an observation is entered into the project with a specific 
Site ID, a point is created. The Site ID of any existing point can be edited to a 
different ID. Observations with this Site ID are automatically changed to the 
new ID.
You can edit a Site ID in a number of different ways:
• Click on the Points tab in the Workbook window and double-click in the 

leftmost cell of the corresponding row. Modify the Name field.
• Double-click (or right-click >Properties) on the observation bar of a point in 

the Time View window to open the Observation Parameters dialog and mod-
ify the Site ID name.

• Double-click (or right-click >Properties) on the point within the Survey View 
to open the Point Properties dialog and then modify the Name field.

Changing the Site ID in the Point Properties sheet has a different effect than 
changing it in the Observation Properties sheet. In the Site Properties sheet, a 
change in the Site ID changes all observations containing this Site ID to the 
new value. In the Observation Properties sheet, a change of the Site ID only 
affects that particular observation.
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Editing Antenna Parameters
Invalid antenna parameters are a major cause of blunders during processing 
including, but not limited to: transposing numbers when writing down the an-
tenna height, reading the height incorrectly, or occupying the wrong point.
If incorrect data (or no data) were entered into the data files, GNSS Solutions 
provides the opportunity to modify these measurements to ensure valid and re-
liable processing of the data.

 To determine if antenna parameters were incorrectly entered via the handheld, 
review the field notes from the survey(s).

The three elements defining the location of the GNSS data collection point are 
Antenna Height, Height Type, and Antenna Type. The Antenna Height and 
Height Type are inseparably tied together. 
Antenna Height:

The Antenna Height is one of three elements that define the vertical offset 
between the location of the GPS data collection point and the feature 
being surveyed (survey mark, topo ground shot, etc.). The processing soft-
ware requires this information to report the elevation of the surveyed fea-
ture.

• If the selected Height Type is Slant, then the Antenna Height is the meas-
ured distance between the feature being surveyed and the Slant Height 
Measurement Point of the antenna (edge of antenna or ground plane).

• If the Height Type is Vertical, then the Antenna Height is the measured dis-
tance between the feature being surveyed and the Antenna Reference 
Point (ARP). The ARP is the very bottom of the antenna. 

• If the Height Type is True, then the Antenna Height is the measured dis-
tance between the feature being surveyed and the C1 phase center of the 
antenna.
With this information and a selected Antenna Type, GNSS Solutions auto-
matically determines the location of the GPS data collection point and 
computes elevation values of the surveyed feature.
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Antenna Type:
The Antenna Type is one of three elements that define the vertical offset 
between the location of the GNSS data collection point and the feature 
being surveyed (survey mark, topo ground shot, etc.). To properly deter-
mine the elevation of the feature being surveyed, the correct Antenna Type 
must be selected for each observation.
With the proper Antenna Type selected, along with the Antenna Height and 
Height Type, GNSS Solutions automatically determines the location of the 
GNSS data collection point and computes the correct elevation values of 
the surveyed feature.
You can select the antenna used for an observation in its Files properties 
dialog (File tab).

Creating a New Antenna Type
You can create a new Antenna to add to the list of Antenna Types using the 
Tools>GNSS Antenna command or from the File Properties dialog of any obser-
vation by selecting <New> in the Antenna Type field.
To create a new antenna using the Tools>GNSS Antenna command:
- Select Tools>GNSS Antenna. The GNSS antenna dialog lists all the antenna 

types that can be used in GNSS Solutions

- In this dialog, click 
- Enter the following parameters in the GNSS Antenna dialog:
• Antenna Model: Usual name of the antenna
• R(m): Radius, in meters, of the antenna radome
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• h(m): Vertical distance in meters between the bottom of the antenna (ARP) 
and the point on the antenna used to measure the slant height 
(SHMP=Slant Height Measurement Point)

• C1(m): Vertical distance in meters between the bottom of the antenna 
(ARP) and the C1 phase center (L1 frequency)

• C2(m): Vertical distance in meters between the bottom of the antenna 
(ARP) and the C2 phase center (L2 frequency)

• Description: Additional information about the antenna (optional)

- If you need to enter more parameters describing the exact locations of the 
L1 and L2 phase centers, click on the Advanced button. This opens a new 
dialog box in which you can, for each phase center:

• Enter North and East deviations, in mm, from the central vertical axis.
• Enter up to 19 different vertical deviations, in mm, from the nominal 

height value as a function of satellite elevation angle. The nominal height 
values you entered previously in the C1 (m) and C2 (m) fields are displayed 
for convenience in the two Height (mm) fields

ARP

SHMP
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Example of advanced parameters screen:

- Click OK to validate the advanced parameters and close the dialog box
- Click OK again to create the new antenna type and close the dialog box.

 When you import an observation file collected with an antenna type that is 
unknown to GNSS Solutions, this antenna type will appear in bold characters in the 
Import Data dialog. This means you will have to define its properties when you start 
importing the file (a dialog will appear at that time so you can enter these proper-
ties).

N

Nominal height

Example:
North: +1.2 mm 
East: -1.9 mm “+” Height deviation

“-” Height deviation

Antenna Top View

“-” East deviation “+” East deviation

“-” North deviation

“+” North deviation

Antenna Side View
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Processing Data

Checking the Processing Options
Run this function after importing raw data files and before running the base-
line processing.
- Select Project>Process Options. The dialog box that opens shows the pro-

cessing scenario. An example of processing scenario is shown in the table 
below:

The processing scenario consists of a series of processes. In the Process 
Options dialog box, each process occupies a row. A process describes the 
way a baseline can be processed to produce one or more vectors (one in 
static, several in dynamic or Stop & Go). 
GNSS Solutions automatically builds the processing scenario after you 
import raw data files into the project or when you run the Project>Rebuild 
Process Scenario command. The way GNSS Solutions operates to determine 
the scenario relies on the principle explained hereafter. GNSS Solutions 
orients each baseline described in the scenario in such a way that the first 
point mentioned is more likely than the other to be a reference point.
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The probability is all the more important as the point is held fixed by the 
user, is involved in a large number of baselines, and is associated with a 
long observation.
In addition, GNSS Solutions lists the processes in logical order, after 
determining which priority should be given to each process, some of them 
being dependent on the results provided by some others.
However, you are allowed to freely change the scenario if you think it 
should be different from what is suggested by GNSS Solutions.
You can for example:

- Move a process up or down by clicking  or  after selecting the 
corresponding row

- Delete a process by clicking  after selecting the corresponding row

- Invert the orientation of a baseline by clicking  after selecting the 
corresponding row

- Change the definition of a process by editing any cell in the corre-
sponding row. For example, you can change the processing mode 
(static/dynamic), the elevation mask angle or the type of orbit data to 
be used in the processing. You can also intentionally reject L2 meas-
urements or some satellites from the processing. Finally, you can cre-
ate a mask to be placed over the observation file.

- To create an observation mask for a process, click  in the Mask 
column. The Mask dialog box opens in which you can define a mask 
graphically for each constellation used (GPS, SBAS, GLONASS). Use 
the commands available from the pop-up menu to create masks. For 
example in the figure below, SV No. 17 has been masked from 17:20 
to 17:30. To place a mask, right-click on the diagram, select the Mask 
command in the menu and drag a rectangle over the desired satellite 
and period of time.
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- When you agree with the displayed scenario, click on the OK button. A 
drop-down menu is then displayed so you can choose which option suits 
you best:

• The To Save option will only save the processing scenario and close the dia-
log box.

• The To Save and Process selected Baselines option will save the processing 
scenario and then will process the selected baselines in this scenario. 
Then the results for these baselines will appear in the different open docu-
ments.

• The To Save, Process Baselines and Adjust option will in addition adjust the 
network compared to the second option.
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Processing Baselines
- Press the F5 key, or select Project>Process All Baselines (F6 will only process 

the still unprocessed baselines). GNSS Solutions will run the last saved 
processing scenario. The results will appear in the various open views. You 
will get the following colors to qualify the vectors:

• Green: QA test was successful for these vectors
• Red: QA test failed for these vectors.

Processing Events
Some user applications require that GNSS Solutions be capable of determin-
ing the exact position of the rover any time during a kinematic occupation. The 
notion of “event” serves this purpose.
Rovers equipped with an external event input can log the exact time when an 
external signal is applied to this input. This information is marked in the ob-
servation file, along with the raw data the rover continuously records.
Events present in an observation file are visible when editing the properties of 
this file (see Observation Properties on page 67).
When processing an observation file, GNSS Solutions also processes the 
events contained in this file, if any. As a result:
• A point of the type “logged point” (see Point Properties on page 77) is cre-

ated for each event present in the file.
• Each logged point will have the same name as the corresponding event.
• The position of each of these logged points will result from the interpola-

tion of the coordinates of the intermediate point immediately preceding 
the event and the one that immediately follows along the trajectory.

I121
I122

I123 I124
I125

1245
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Post-Processing Data Analysis

The primary product of processing GPS raw data between two points is a vector 
defining the relationship between these points. Point coordinates are by-prod-
ucts of the processed vector. When a vector is processed, the coordinates of 
one point are always held fixed. From the processed vector, coordinates are de-
termined for the unknown point.
Prior to adjustment, the point coordinates are derived exclusively from the pro-
cessed vectors to this point. For points with multiple vectors, the displayed co-
ordinates are derived from the vector with the lowest uncertainties. Adjustment 
of the data results in more accurate and reliable point coordinates.
GNSS Solutions has indicators to help determine the quality of processed vec-
tors and computed point coordinates. The quality indicators for processed vec-
tors includes a process QA flag, solution type, and vector uncertainties. Quality 
indicators for computed point coordinates are point position uncertainties and 
a position status flag.
The vector uncertainties give an estimate of the quality of the processed vector. 
Experience helps to determine what level of uncertainties can be expected for 
varying vector lengths. In general, the uncertainties should be similar to the 
accuracy specifications of the receiver. Also, vectors of similar lengths should 
have similar uncertainty values.
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Notice that the amount of data available for processing a vector has an effect 
on the vector uncertainty. If too little data is available, the uncertainty values 
will increase. Refer to your receiver manual to obtain guidelines about the 
amount of data required for obtaining good results.
The solution type is an indication of the success of determining the integer am-
biguities for each satellite in the calculation of a vector. If most of the integer 
ambiguities were determined, the vector solution is considered a Fixed solution 
(ambiguities Fixed to integers). A Fixed solution is the best possible solution.
A vector with a solution type Float indicates that not all of the integer ambigu-
ities were determined. In most cases, a vector with a solution type of Float will 
be poor in quality. If you have a float solution on a shorter vector, there is prob-
ably a problem with the data used to produce this vector.

 In former Magellan software products, the solution status could also be “Partial” 
which is an intermediate status between “Fixed” and “Float”. GNSS Solutions algo-
rithms will never produce such “Partial” solutions.

In GNSS Solutions however, some points will be qualified as “Partial” in the follow-
ing case: These points, determined earlier by a former Magellan product, were 
declared as “Partial” solutions and you have imported these points into your GNSS 
Solutions project.

The process QA flag examines the magnitude of the vector uncertainties to de-
termine the quality of the processed vector. The magnitude of the vector un-
certainties is compared to a threshold value. If the uncertainties are greater 
than the threshold, the QA test fails and the vector is flagged. The threshold 
value has been selected based on the expected accuracy for vectors collected 
and processed in the receiver.
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It is important to remember that a flagged vector does not indicate conclusively 
that the vector is bad. The QA test is designed to warn you of potential prob-
lems with a vector. Include flagged vectors in the adjustment. The analysis 
tools in the adjustment provide additional means to determine if the vector is 
indeed problematic. If so, it can be eliminated.
The point uncertainties estimate the quality of the computed point position. 
The uncertainties are derived directly from the vector uncertainties for a point. 
If multiple vectors exist for a point, the point adopts the uncertainties from the 
last processed vector. An adjustment on the data improves the point coordi-
nates and reduces uncertainties. 
The position status flag gives an indication of how the coordinates for the point 
have been derived. Flag settings are Estimated, Processed, and Adjusted. Each 
represents a different level of reliability and accuracy, with Raw being the least 
reliable and accurate, and Adjusted being the most reliable.
The quality indicators discussed here are presented in different ways within 
GNSS Solutions, depending on the view used for analysis. The remainder of 
this section shows how to analyze these indicators in graphical and tabular 
form.

Graphical Review
Once GNSS Solutions has processed the raw GNSS data, the Survey View 
changes to show the results of the processing.
The points from the raw data have been processed displaying various informa-
tion:
• Error ellipses: Graphical display of the horizontal uncertainties of the vec-

tor
• Vertical Error Bar: Graphical display of the vertical uncertainties of the vec-

tor
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• Vectors: A solid line represents each processed vector. If the vector passes 
the QA test and has a “Fixed” solution type, the line is green. If the vector 
fails the test or has a “Float” solution type, the vector is red.

Editing a Vector
The properties of a vector are presented on a two-tab dialog box. Typically, to 
open this box, double-click a vector displayed in the active map document.
The Vector tab contains the following information:
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- From: The point taken as reference, and from which the vector originates 
(shown in dark blue in the above diagram). If the list contains several 
points, this means that other vector solutions exist that also end to the 
point mentioned below (in the To: field). These vectors are shown in gray in 
the above diagram.

- To: The point where the vector ends
- Start time: The beginning of the static occupation that has allowed GNSS 

Solutions to calculate the vector. If two or more start times are listed in 
this combo box, several solutions then exist for the vector joining the two 
points selected above (repeat vectors). The displayed vector solution corre-
sponds to the selected occupation time.

- Span: Duration of the selected static occupation (non-editable)
- Solution: Solution status (software set): “Fixed” or “Float”
- Enabled box: If checked, the vector will be included in the adjustment. If 

it’s not the vector will be rejected from the adjustment phase.
- Adjusted check box: Software set. Indicates whether the displayed vector 

solution has been adjusted (checked) or not (cleared). If the box is 
checked, then the lower part of the dialog box also shows the Adjustment 
Results as well as the resulting Residuals. If it is clear, then only Process 
Results are provided in the lower part of the dialog box.

- Residuals button: Provides access to a full-screen diagram showing the Car-
rier Phase Doubled Difference Residuals versus Time. This information can 
be plotted for each satellite, or for all satellites in view during the observa-
tion by clicking the corresponding tab in the lower part of the window. Note 
the presence of two vertical, dot & dash lines showing the limits of the 
concerned static occupation.
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- You can zoom in on a particular area by dragging a rectangle around this 
area (then press the Esc key to zoom out). Setting the viewing options for 
this diagram is achieved by right clicking anywhere on the diagram and 
making the desired choices on the menu that pops up (see menu in figure 
below).

The following characteristics of problem satellite data can cause poor 
results when processed:

- Gaps in the data caused by extended loss of lock of the satellite. This 
is characteristic of an obstructed satellite. If all satellite plots have 
gaps during the same time periods, the missing data may be with the 
reference satellite. 

- A satellite with residuals noticeably larger than other satellites. This 
is a characteristic of a satellite affected by multipath and/or an active 
ionosphere. If all satellite plots have residuals that seem larger than 
normal, the problem may be with the reference satellite. 
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- A segment of a satellite with residuals noticeably larger than the rest 
of the same satellite. This is characteristic of a segment of satellite 
data affected by multipath and/or an active ionosphere. If all satellite 
plots have a segment with residuals that are larger than the rest or the 
residuals, the problem may be with the reference satellite. 

- A satellite with a sloped residual plot. Residual plots should not be 
sloped and should have a mean value of 0 cycles. A sloped plot usu-
ally indicates a problem with the satellite data. If all plots are sloped, 
this usually indicates that the reference satellite is a problem. 

- A satellite contributing a very small amount of data compared to the 
other satellites in the data set. Sometimes such a satellite causes 
problems with processing.

You can remove any data exhibiting the above characteristics and repro-
cess the vector.

- Process Results: Provides the following results for the vector: DX, DY, DZ 
components and associated uncertainties, plus vector length, in the 
selected unit

- Adjustment Results: Same as Process Results. Displayed only after the vector 
has been adjusted (Adjusted button checked)

- Residual: Displayed only if Adjustment Results are available and displayed. 
For each result, this pane provides the deviation between initial process 
and adjustment.

The Point tab provides the properties of the point where the vector ends.

Clearing Process Results
You may need to delete all the process results in a project because you realize 
the processing was run with incorrectly set options. To do this:
- Select Project>Clear Process Results. GNSS Solutions will then delete all the 

baseline processing results which will then disappear from the various 
open views.
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Case of Kinematic Surveys

The processing of GPS data collected in Static mode is rather straight forward 
with the required steps discussed earlier in this chapter. Processing of GPS 
data collected in stop&go kinematic and continuous kinematic modes require 
some additional steps that will be outlined here.

Control Points for Kinematic Initialization
The processing of data collected in kinematic mode is successful only if the 
kinematic survey was properly initialized at the start of the survey and each 
time initialization is lost due to an insufficient number of satellites.
To initialize a kinematic survey, the post-processing software must be able to 
precisely establish the coordinates of one of the points observed by the rover 
receiver (initialization point) during kinematic data collection.
Alternatively, the precise coordinates of one of the points observed by the rover 
(initialization point) can be supplied to the processing software. In this case, 
the coordinates of the initialization point must be precisely known relative to 
the coordinates of the base point.
There are a number of different methods to accomplish this. Each method is 
handled differently by the processing software.
Let’s examine each initialization method in detail and discuss the additional 
steps, with regard to control points, required to prepare the post-processing 
software to process the data.
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1. Static Survey Initialization

One method to determine the precise coordinates of a rover point is to perform 
a static survey on the first point observed by the rover. By observing this first 
point in static mode for the required period of time, the processing software 
will be able to compute the position of this point. This supplies the required 
point for initialization of the remainder of the kinematic survey. 
Processing of kinematic data initialized by first performing a static survey re-
quires no special steps compared to static processing. If you know the coordi-
nates of the kinematic base station and want to hold them fixed, enter them 
in the Control Positions tab. Otherwise, the software will use an approximate po-
sition for the base station and hold it fixed for processing automatically. The 
software will first determine the position of the initialization point and then de-
termine the position of the remaining kinematic points.

2. Bar Point Initialization

The concept of initialization using the initializer bar is similar to using a static 
survey to initialize your kinematic survey. By performing a 5-minute observa-
tion on the bar, you are establishing the coordinates of the rover receiver on 
the other end of the bar. Once the coordinates of the rover location are estab-
lished, the kinematic survey can be initialized. A 5-minute observation is all 
that is needed because we have some initial information regarding the short 
vector between the base and rover receivers. We know that the vector is exactly 
0.200 meters long (the length of the bar). We also know that the delta height 
of the vector is 0.000 (base and rover receivers are at the same HI). Based on 
this given information, the coordinates of the rover location can be established 
with a short 5-minute observation.
Processing of kinematic data initialized by using the bar does require one spe-
cial step not found in processing static data. The observation on the bar by the 
rover receiver produces a unique point with its own unique Site ID.
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The processing software must be told that this point is the rover initialization 
point located on the bar. This is the only way that the software knows to con-
strain the length of the vector and the delta height of the vector for processing. 
There are two ways to identify a point as the bar initialization point:
- During data collection, the handheld software will automatically tag the 

bar initialization point. Any point collected with the INI? flag set to Y is 
tagged in the D-file as the bar initialization point. The processing software 
will read this tag from the D-file and automatically set the point as the bar 
point for processing.

- If a bar point was inadvertently not identified as such during data collec-
tion, it can be set in the Point tab of the Point Properties dialog.

Once the bar initialization point is identified, the processing of the kinematic 
data is again similar to that of processing static data. If you know the coordi-
nates of the kinematic base station and want to hold them fixed, enter them 
in the Control Positions tab. Otherwise, the software will use an approximate po-
sition for the base station and hold it fixed for processing automatically. The 
software will first determine the position of the bar initialization point and then 
determine the position of the remaining kinematic points.

3. Known Point Initialization

If two or more points in your kinematic survey project area have known coordi-
nates, these points can be used to initialize your kinematic survey. The base 
receiver is set up on one of the known points. The rover observes the second 
known point for a short period of time (10 seconds for example). This provides 
a rover point with known coordinates for the processing software to initialize 
the kinematic survey. If initialization is lost at any time during the kinematic 
survey, the same or a different known point can be observed for re-initializa-
tion. The re-initialization point can even be a point surveyed just moments ago 
during this kinematic survey. 
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It's very important to note that the relationship between the base point and the 
known point to be used to initialize must be very accurately established. For 
this reason, it is highly recommended that you only initialize on a known point 
that has been previously established by a GPS survey either with a direct mea-
surement between the base and known point or through a network including 
both the base and known point.
To process kinematic data where known point initialization was used, the co-
ordinates of the known point(s) must reside in the project file containing the 
kinematic data to be processed. This can be accomplished in different ways:
- The kinematic data to be processed could be added to an existing project 

file containing the known coordinates of the base point and initialization 
points. For example, a project file may exist containing data from a static 
survey performed earlier that established the coordinates of the known 
points. The kinematic data to be processed could be added to this project 
and processed. The processing software will automatically grab the 
required coordinates for processing of the kinematic data.

- The coordinates of the known points could be added to the project contain-
ing the kinematic data to be processed by entering them in the Control 
Positions tab. 

If re-initialization was performed on a point observed earlier in the same kine-
matic survey, there is nothing special that needs to be done to prepare the soft-
ware to accept this re-initialization. The software will automatically access the 
coordinates of this point when needed.
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4. On-The-Fly Initialization

On-the-fly initialization requires no special data collection procedures. The ki-
nematic survey is initialized without a special initialization process. The user 
simply turns on the rover GPS receiver and begins collecting kinematic data. 
If the user can collect a long enough session of continuous data without loss-
of-lock on satellites, the kinematic survey will initialize on its own. 
The time period of continuous data required to ensure initialization varies de-
pending on a number of factors, the most important of which is GPS receiver 
type. If using a dual-frequency receiver, on-the-fly initialization can occur with 
just a couple of minutes of continuous data without loss-of-lock. Under some 
conditions, up to 10 minutes of data may be needed. On the other hand, if the 
GPS receiver being used is a single-frequency receiver, such as the ProMark3, 
you could require 20 minutes of continuous data for initialization.
Processing of kinematic data with on-the-fly initialization requires no special 
steps compared to static processing. If you know the coordinates of the kine-
matic base station and want to hold them fixed, enter them in the Control Po-
sitions tab. Otherwise, the software will use an approximate position for the 
base station and hold it fixed for processing automatically.
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Kinematic Surveys using Multiple Base Stations
It is possible to perform a kinematic survey with more than one base station. 
Multiple base stations provide for redundant observations to the kinematic 
points being surveyed. There are no special requirements to processing kine-
matic data with multiple base stations. Follow the procedures outlined above 
as if there were only one base station in the survey. The processing software 
will automatically accommodate the other base stations.
For example, let’s say that a kinematic survey is performed using two base sta-
tions and a rover. At one base station, the kinematic survey is initialized using 
the initializer bar. Data collection proceeds as normal, as if there is only one 
base station.
During the processing of this data, the processing software will first process 
the vector between the two base stations. Next, the software will process the 
vectors between the base station with the initializer bar and all rover points. 
The software knows which base station has the initializer bar by examining the 
approximate positions of the base stations and the initialization point. Finally, 
the software will process the vectors from the second base station to the rover 
points, using one of the already processed rover points to initialize on.
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Conclusion
Adjustment
In most situations, there is no benefit in adjusting vectors that have been col-
lected using the kinematic mode of data collection. This is because there is no 
redundancy in most kinematic surveys. Only one observation exists between 
the base and each rover point. This leaves nothing to adjust. The exception to 
this is the situation were multiple base stations are used during the kinematic 
survey. In this case, closed loops exist between the base points and each rover 
point. This survey has redundancy therefore can be adjusted.

Conclusion

Once you have completed the pre-process analysis, processing, and post-pro-
cess analysis, and are satisfied the processed data have no observable errors, 
you can adjust the data. 
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Chapter 6: Adjustment

Adjusting your survey observations is one of the most important tasks to ensure 
accurate, reliable results. A network adjustment is performed to accomplish 
two results:
- To test for blunders and errors in the observations (vectors between points 

in our case)
- To compute final coordinates for your survey points which are consistent 

with the existing control points that you used.

 Only data sets with redundant observations (closed loops) benefit from an adjust-
ment. Performing an adjustment on radial vectors (such as those obtained from a 
kinematic survey with only one base station) will not identify errors in the observa-
tions nor improve the accuracy of the points surveyed.

Adjustment takes place after you have processed the raw data and are satisfied 
that there are no unaccountable errors in the processed results. There are typ-
ically two stages in the adjustment:
- The first, the minimally constrained adjustment, is used to detect prob-

lems in the observations and control coordinates. You may have to iterate 
several times, using a number of different tools to check for blunders.

- Once you are confident that no blunders remain, you can proceed to the 
second stage, the constrained adjustment, where you hold fixed all the 
control points and readjust to obtain final site positions and accuracies.

This chapter takes a step-by-step approach through the adjustment procedure, 
and highlights what tools you should use and when to use them. Since it is 
task-oriented, it does not deal with the theory of adjustments in any depth. In-
stead, refer to Blunder Detection Tools on page 358. You will find it helpful to 
review this section before actually performing an adjustment.
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Minimally Constrained Adjustment
You do not need to select anything in the project before running the Adjust 
command as GNSS Solutions will automatically run this command on the en-
tire project, taking into account the possible changes that you have made on 
some points. Typically, you may have fixed some points horizontally, vertically 
or both to “anchor” your field survey to known points. You may also have 
cleared the “Enabled” button for some of the computed vectors in order to re-
ject them from the adjustment phase (see Enabled box in Editing a Vector on 
page 98).

Minimally Constrained Adjustment

The first stage of adjusting your data set is to perform a minimally constrained 
adjustment; the final product of this stage will be a blunder-free adjustment.
1. With an open project containing a processed data set, click on the Adjust-

ment Analysis tab of the Workbook window.
2. Notice all the fields are blank. No data are available until you perform an 

adjustment on the data set.

 You may choose to hold one site fixed at this point. However, if you do not, the 
software automatically uses the site with the lowest uncertainty. It is important that 
you do not hold more than one site fixed.

3. Press F7 to perform an adjustment or select Project>Adjust Network....
A progress dialog opens, indicating the adjustment progress and status; 
you may cancel the adjustment at any time. Relevant messages are dis-
played in the Output pane.

4. Once the adjustment is complete, data appears in the Adjustment Analysis 
tab of the Workbook window. The table below describes the Adjustment 
Analysis tab.
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The first test GNSS Solutions performs is the Network Connectivity test. 
This test ensures that the network does not contain any subnetworks that 
are not connected. Refer to Network Connectivity Test on page 358 for 
more information. After this test, text similar to the following appears in 
the Output pane:

Network connectivity test: passed
Number of sites: 6
Number of vectors: 9

If this test fails, there are actually two or more unconnected networks in 
the project. You must either observe more vectors to connect the networks, 
exclude the vectors for all but one of the networks, or create a new project 
for each network.

Component Description
Reference / Rover Names of the points forming the vector

Start_Time Month, day and time for the vector

Adj_QA Button cleared if any residual component of the vector does not 
pass the QA test. Otherwise, checked.

Tau_Test Button cleared if any residual component of the vector does not 
pass the Tau test. Otherwise, checked.

Adj_Length 3D spatial distance of the vector in the linear unit system 
selected in the Project Settings dialog

Length_Residual Residual of the adjusted vector length

Adj_DX Adjusted vector component in the x direction

DX_Residual Residual of the adjusted vector component (x)

Adj_DY Adjusted vector component in the y direction

DY_Residual Residual of the adjusted vector component (y)

Adj_DZ Adjusted vector component in the z or vertical direction

DZ_Residual Residual of the adjusted vector component (z)
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Minimally Constrained Adjustment
GNSS Solutions then performs a Chi-Square test. For more information 
about the Chi-Square test, refer to Chi-Square Test on page 361. After per-
forming this test, text similar to the following appears in the output pane:

Chi-square test: passed
Lower limit: 4.403788
Upper limit: 23.336664
Chi-square: 22.083307

 Actual measurements may differ in the adjustment of your data files.

After passing the Chi-Square test, the program performs a Tau test for each 
vector. A Tau test is performed on the residuals of each vector as a test for 
blunders. The Tau test result for each vector is displayed in the Adjustment 
Analysis tab of the Workbook window. Only those vectors that fail the test 
are indicated. For more details on the background of the Tau test, refer to 
Tau Test on page 365.
It is important to note that even if some vectors are flagged as failing the 
Tau test, if the residuals of the vectors are not significantly larger than 
those for other vectors, it is probably acceptable to ignore the results of the 
test.
Other tests that are useful in detecting blunders, especially in larger net-
works, are the Repeat Vector test and the Loop Closure test. Both tests can 
be used to identify problem vectors - you can exclude them from further 
adjustment if necessary. See also Loop Closure Analysis on page 366 and 
Repeat Vector Analysis on page 367.

5. If no residuals are flagged, you should now have a blunder-free adjust-
ment.
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6. If more than one control point was entered in the Control Positions tab and 
only one was held fixed (remember that you should hold no more than one 
fixed at this stage), GNSS Solutions performs a control tie analysis auto-
matically. To see the results, click on the Control Tie tab of the Workbook 
window.
This test provides an indication of how well your survey agrees with the 
established control you have entered. If the ties to one of the control points 
fail and are significantly larger from ties to other control points, then there 
is good reason to suspect that that control point may be in error. This con-
trol point should not be used in the constrained adjustment.

7. Once you have completed the minimally constrained adjustment and have 
ensured that your network is free of blunders, you can hold fixed all of the 
control points you have available and perform a constrained adjustment to 
derive final site positions and network accuracy.

Constrained Adjustment

The purpose of this final stage is to adjust your network, holding all your con-
trol points fixed to obtain final positions that are consistent with the estab-
lished control.
1. Select Project>Define Control Points icon
2. Change the fixed status for each control point. You can have points which 

are horizontal control only, points that are vertical control only, and points 
which are both. Then click OK to close the dialog.

5. Press the F7 key to perform the adjustment again. You should see text in 
the Output pane similar to the following:

Adjustment type: Over constrained
Control stations Constraints
0002 Latitude Longitude Elevation
_ASH Latitude Longitude Elevation

All the tasks described in this Network Adjustment section are summarized in 
the figure below.
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Uncertainties are too pes-
simistic. Scale them down. 
Rerun adjustment.

Uncertainties are 
too optimistic. 
Scale them up. 
Rerun adjust-
ment.

Variance of 
unit weight

Chi-square 
test

Tau test

Residuals of 
Flagged Vectors

Minimally Constrained Adjustment

Fail

PassClose 
to 1

Some residuals 
flagged

No residuals 
flagged Should have a blunder-

free adjustment

All small
Ignore flagged residuals

Residuals of 
Flagged Vectors

Much greater than 1

Much less than 1

All 
small

Some 
large

Data set probably contains 
one or more blunders. Iso-
late and resolve/remove 
blunders. Use loop closure 
analysis and repeat vector 
analysis to assist if needed. 
Rerun adjustment.

Some 
large

Adjustment completed. Uncertainties 
present estimated accuracy of adjusted points

Control Tie 
Analysis

Fail

Pass

Constrained Adjustment

Examine error of problem 
point(s). If close to accuracy 
specification, may be able 
to ignore. If not close, do not 
hold fixed problem control 
point(s) if OK with client.
114



Adjustment
Clearing Adjustment Results

A
d
ju

stm
e
n
t

Clearing Adjustment Results

You may need to clear the adjustments results to resume this phase with dif-
ferent settings. To do this:
- Select Project>Clear Adjustment Results. GNSS Solutions will then delete all 

the data resulting from the last run Network Adjustment function. The 
adjustment results will then disappear from the Survey View and the Work-
book window.

Running a Loop Closure Test Manually

- Select at least three vectors forming a loop on the Survey View
- Select Project>Check Loop Closure. GNSS Solutions then performs the loop 

closure test on these vectors. At the end of the test, GNSS Solutions 
selects the Loop Closure tab in the Workbook window so you can read the 
results of the test:

Loop Properties:

- Select a row on the Loop Closure tab in the workbook
- Right-click and select Properties. A new, two-tab, dialog box is displayed 

showing the content of the selected row in a different form:
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Running a Loop Closure Test Manually
The first tab shows the points involved in the definition of the vectors form-
ing the loop. The second tab give the same results as in the row except 
that you can choose to view the misclosure results either in a linear, ppm 
or ratio form.
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Suggestions and Recommendations

A minimally constrained adjustment is essential:
• Use the Control Tie tab to evaluate the closure on the remaining control 

points
• Determine what control points are valid and which ones are not
• Do not make a fully constrained adjustment to control points that do not fit 

together within your error budget
• Print a site positions report from the fully constrained adjustment
• Make sure the control points are well balanced around the project; 

Remember the saying, “Make a box and work inside the box.”
Compare the results of your fully constrained adjustment with the results of 
your minimally constrained adjustment:
• No points in the survey project should shift by amounts greater than the 

closing errors shown on the Control Tie tab in the minimally constrained 
adjustment.

• If any point in the project shifts by an amount greater than the closing 
error, that means the control points are not in balance.

• Control points that are not in balance should not be used to constrain a 
survey project.

• The purpose of a fully constrained survey is to distribute the closing error 
in the control points.

• If constraining the control points projects error instead of distributing error, 
then the control points should not all be constrained.

Sometimes a minimally constrained adjustment is the best adjustment. 
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Chapter 7: Coordinate 
Transformations

One of the primary advantages of GNSS Solutions is the ability to work within 
your own coordinate system from the start of your project - you no longer need 
to be concerned with transforming to and from the WGS-84 datum, to which 
all GPS data references. GNSS Solutions allows you to work in five types of hor-
izontal coordinate systems:
• Geocentric
• Geographic (Geodetic)
• Projected (Grid system)
• Projected with Horizontal Correction (Local Grid)
• Ground.
In addition you can choose to use either ellipsoidal heights or orthometric 
heights. (This is done by setting the Vertical Datum field on the System tab.) 
Although GNSS Solutions includes many predefined system, you can easily 
create your own custom coordinate system.
The different types of coordinate systems can be seen to build upon one an-
other. At the heart of any system lies the geodetic datum, with a known rela-
tionship to WGS-84, represented by the Geodetic system. On top of that might 
exist a Grid system, consisting of one or more zones, each utilizing one of the 
several available projections. Finally, a Local Grid can be superimposed over a 
Grid system.
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Introduction
 Ground Systems can also be created when you wish to produce coordinates in 
your project area that are compatible with point coordinates derived using con-
ventional total stations. Although different in nature, ground systems are clas-
sified in GNSS Solutions as projected systems in which the projection 
properties are determined by the software itself after you have entered the re-
quired parameters (mainly L-G coordinates of the origin point and system ori-
entation).
Typically you select or define the coordinate system you wish to use when you 
create a new project. From that point on, all coordinates are presented in that 
system. However, it is possible at any time to change to a different system, and 
all your coordinates automatically transform to the new system.
Experience indicates that users work primarily in the same coordinate system. 
For convenience, the coordinate system in a new project is automatically set 
to the system that was used last.

Introduction

Coordinate systems are organized as summarized in the table below:

System Coordinates Definition

Geocentric X ECEF, Y ECEF, Z ECEF Datum + System Definition (name units, 
labels)

Geographic Latitude, Longitude, Height Datum + System Definition (name, 
units, labels, vertical datum)

Projected Easting, Northing, Height Datum + Projection + System Definition 
(name, units, labels, vertical datum) 

Ground Easting, Northing, Height

Datum+geographical coordinates of ori-
gin point+assigned coordinates to origin 
point in ground system+system orienta-
tion
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GNSS Solutions strictly complies with OpenGIS concerning coordinate trans-
formations.
GNSS Solutions supports the following projections:
- Transverse Mercator
- Transverse Mercator OSTN02 (projection grid)
- Transverse Mercator 27
- Transverse Mercator Alaska 27
- Transverse Mercator 34
- Cassini Soldner
- Lambert Conformal Conic 1SP
- Lambert Conformal Conic 2SP
- Lambert Conformal Conic 27
- Stereographic
- Oblique Stereographic
- Oblique Stereographic RD2000 (projection grid)
- Oblique Stereographic RD2004 (projection grid)
- Oblique Mercator
- Oblique Mercator 83
- Oblique Mercator 27
- Oblique Mercator HD72
- Krovak Oblique Conic Conformal
- Hotine Oblique Mercator
- Ground System
- Ground System Azimuth
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Selecting a Coordinate System
Selecting a Coordinate System

If you create a new project and you do not define its coordinate system during 
the creation phase, then GNSS Solutions will automatically allocate the coor-
dinate system of the last open project to this new project. To define the coor-
dinate system during the project creation phase, click on the Modify Default 
Settings button in the New dialog box, and then complete the Region tab.
Once the project has been created, you can come back to the definition of the 
coordinate system by clicking on the Commands pane, then on the Project topic 
bar, and then on the Project Settings icon. Then click on the Region tab. As ex-
plained elsewhere in the manual (see Project Settings on page 45), you select 
the desired coordinate system for the project in the Spatial Reference System 
field.
Remember that the choice you make in this field is for the entire project but 
you will be allowed to choose a system specific to each document created with-
in the project without affecting the present choice.
The list of systems attached to the Spatial Reference System field contains at 
least the following three options:

- Selecting <Local> will allow you to work in the unknown local system
- Selecting <WGS 84> will directly select WGS 84 as the project’s coordinate 

system.
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You can edit the definition of the WGS 84 by clicking the  button next to 
the field. If you change and enable any of the parameters defining the 
WGS 84, GNSS Solutions will create a new system named WGS 84~1 by 
default.

- Selecting <New> will display the following dialog box:

- If you check SELECT a PRE-DEFINED system and you click the Next button, 
GNSS Solutions will display the list of pre-defined systems (more than 
500 available). In this case you just have to select a system in the right-
hand list (see example below) and click the Finish button. 
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Creating a Projected System
The selected system name will then appear in the Spatial Reference System 
field. From now on, this system will also be available from the list attached 
to this field.

- If you check either Define a NEW PROJECTED system or Define a NEW GEO-
GRAPHIC system, then GNSS Solutions will allow you to define a new sys-
tem (see next pages).

Creating a Projected System

The process of creating a new projected system goes through three distinct 
phases corresponding to three different dialog boxes, as explained below. To 
access the first of these dialog boxes, do the following:
- Run the Tools>Coordinate Systems command

- Click , check the Define a NEW PROJECTED system option and click the 
Next button. This opens the ...Wizard-Datum dialog box (continued below).

Defining the datum
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- There are two different scenarios to define a datum for a new system:
- The new system relies on a known datum: just select a name from the 

list attached to the Datum name field. The rest of the dialog box (i.e. 
ellipsoid name and definition + position in space) is updated to 
match your selection.

- The new system relies on an unknown datum: type the name of the 
new datum in the Datum name field, then type the name of the associ-
ated ellipsoid in the Ellipsoid name field. Enter the two characteristics 
of the ellipsoid in the next two fields and then define the position in 
space of this ellipsoid with respect to the WGS 84 in the remaining 7 
fields.
Note that the datum and the ellipsoid that you create in this second 
scenario are also intrinsically tied to each other.

- When you have finished defining the datum, click the Next button to dis-
play the next dialog box (see below).

Defining the projection
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Creating a Projected System
- Select the desired type of projection from the list attached to the Projection 
Class field, and then complete the fields underneath

- If the new system includes a horizontal correction, check the box top right. 
This action unveils a number of fields in the right-hand part of the dialog 
box that you must complete to define the horizontal correction.

- When you have finished defining the projection, click the Next button to 
display the next dialog box (see below).

Defining the system

- Enter the following parameters to complete the definition of the new pro-
jected system:

- Projected system name
(Labels and orientation of the three axes cannot be changed)
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- Vertical datum: Choose the option representing the geoid model you 
would like to use. Choose the “Ellipsoid” option when you wish to use 
the ellipsoid you have selected earlier for the datum as the vertical 
reference.

- Vertical correction: check the corresponding box if the local system 
includes a vertical correction, and then enter the parameters defining 
this correction.

- Click OK to create the new system and close the dialog box. The new sys-
tem then becomes the one selected in the Spatial Reference System field.

 This last dialog will contain more information if, from the menu bar, in 
Tools>Preferences, you check the Advanced Coordinate System settings option. 
With this option enabled, you will be able to set the units and labels used by the 
system, namely:

- Labels associated with coordinates

- Unit used for horizontal coordinates (meters, US feet or International feet). For 
your information, the Meters per unit field indicates the value, in meters, of the 
selected unit (e.g. 1 Int foot=0.3048 m)

- Unit used for vertical coordinates (Meters per unit field: same as above). The check 
box located bottom left allows you to define the same unit for ALL coordinates when 
checked.

Creating a Geographic System

Follow the same procedure as when you create a projected system. The only 
difference is that you do not have to define a projection.
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Creating a Geocentric System

Defining a geocentric system is much like defining a geographic system except 
that you do not have to define a vertical datum.
Geocentric systems are incompatible with maps and so, in GNSS Solutions, 
can only apply to table or graph documents. This is the reason why you cannot 
select a geocentric system at project level. To create a new geocentric system:
- Run the Tools>Coordinate Systems command

- Click , check the Define a NEW GEOCENTRIC system option and click the 
Next button.

- Complete the two screens allowing the definition of a geocentric system. 

Creating a Ground System

You can create a Ground System in two different ways as explained in the next 
two sections.

From Within an Open Project
This is the best method to create a Ground System as the definition of the or-
igin point and the orientation of the system is easier. Also, you do not have to 
specify a datum as the project datum will automatically be used.
- Open your project.
- Select Project>Compute Ground System. This opens the Compute Ground Sys-

tem dialog box.
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- Enter the name of the Ground System in the System Name field.
- Click the arrow to the right of the Point field and select the origin point for 

the Ground System from the list presented.
After selecting an origin point, the latitude and longitude stored in the 
project for the selected point will be displayed.
If you would rather set the origin point to a location other than an existing 
project point, simply enter the latitude and longitude of your origin without 
selecting a project point. By default, the ground coordinates of the origin 
point are defined as (0,0). You can enter values other that (0,0) as ground 
coordinates for the origin point. This is helpful when the origin point is in 
the center of the project site. Assigning ground coordinates such as 
(10000,10000) to the origin point will lessen the likelihood of some of the 
project points having negative ground coordinates.

- Enter the desired coordinates of the origin point, in the Ground System, in 
the Ground Northing and Ground Easting fields. Example:

- If you now click OK, the new ground system will be computed based on a 
0° azimuth to the North for the orientation of the ground system.
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If you want a different orientation, click More>>. The window is extended to 
show the possible choices for the orientation of the ground system:

• The To North option defines 0° azimuth of the Ground System to match 
Geodetic North (default option).

• The To Point option defines 0° azimuth of the Ground System as the azi-
muth between the origin point and a second point defined by either select-
ing the point from the list of existing points in the project or defining a new 
point by entering the Latitude and Longitude of the point.

• The Angle option defines 0° azimuth of the Ground System as offset from 
Geodetic North by the entered angle. A positive angle results in the 0° azi-
muth of the Ground System being rotated counter-clockwise from Geodetic 
North.

- After defining the desired orientation, click OK to save the Ground System 
and close the dialog.

Using the Coordinate System Window
- Run the Tools>Coordinate Systems command

- Click , check the Define a NEW PROJECTED system option and click the 
Next> button. This opens the ...Wizard-Datum dialog box.

- Define the datum used and click Next>. This opens the ...Wizard-Projection 
dialog box.

- Select one of the following options in the Projection Class field:
• Ground_System if you would like to define a Ground System with North or 

“To Point” orientation
• Or Ground System_Azimuth if you would like to define a Ground System 

whose orientation is given by an angle.
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- Depending on this choice, enter the required parameters to complete the 
definition of the Ground System

- Click Next>. Enter the name of the Ground System in the System Name field.
- Click Finish to save the Ground System and close the dialog.
- Close the Coordinate Systems dialog box.

Managing Coordinate Systems

- On the GNSS Solutions menu bar, select Tools>Coordinate Systems.... The 
dialog box that opens looks like the one below:

The content of this dialog box determines the list of coordinate systems 
attached to the Spatial Reference System field on the Region tab of the 
Project Settings dialog box or on the View tab of any Map or Table Properties 
dialog box.
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The following functions can be performed from this box:

- Edit the properties of a system: select this system and click 

- Add a new coordinate system to this list: click , choose the type of 
coordinate system you want to define and then define this system, or 
simply select it from the list of pre-defined systems.

- Delete a coordinate system from the list: click  after highlighting a 
system in the list. You can only delete a pre-defined system from this 
list, not from the list of pre-defined systems. Conversely, a system you 
have created yourself will be definitively deleted from the coordinate 
system library if you delete it.

- Import a coordinate system from a file in csl format: click , select 
the file to be imported from the folder you choose and then click 
Open. The imported system will appear in the list of coordinate sys-
tems. Files in csl format are ASCII files that can be uploaded to the 
data collector.

- Export the selected system to a file in csl format: click  after 
selecting the coordinate system you want to export. Specify the target 
folder and click Save.
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Using Datum Grids

GNSS Solutions lets you work with the following datum grids:
- NADCON
- GR3DF97A
- 3DIM
These grids are somewhat hidden in the software. To use any of them, do the 
following when you create a coordinate system:
- When you define the datum used, type the name of the desired datum grid 

(NADCON, GR3DF97A or 3DIM) in the Datum name field. This field is a 
combo box but you can also directly type text in this field. As a result, a 
message is displayed in the right-hand part of the dialog box (see example 
below with NADCON).

If some points in your surveys happen to be located beyond the geographi-
cal area covered by the datum grid, a warning message will appear in the 
lower part of the Point properties dialog box.
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Performing Coordinate Calibration

Use the Coordinate Calibration function to determine the local system after you 
have surveyed a number of points in the field that are in fact reference points 
in the local system. Determining the local system is typically performed in the 
field but you can resume this calculation with GNSS Solutions as a safety mea-
sure.

 Remember that performing a calibration procedure is possible only if the project 
contains logged reference points with associated field results.

- Select successively each of the surveyed points that are reference points in 
the local system and, unless already done, change each of them into a ref-
erence point so you can enter their known coordinates as control coordi-
nates

- On the map document, make a multiple selection including all these refer-
ence points

- On the GNSS Solutions menu bar, select Project>Coordinate Calibration.... 
The Compute Local System dialog box appears listing all the reference points 
you have just selected (see example below).
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In this dialog box, the Advanced... button allows you to fix a number of 
parameters in the horizontal grid, if some of them are already known, 
before running the Coordinate Calibration command. If you do not know any-
thing about the horizontal grid, then do not fix any of its parameters.
The Edit and Remove buttons allow you to edit or remove a reference point 
you select in the list. By giving you access to a dialog box listing all the ref-
erence points present in the project, the Add button allows you to involve 
more reference points in the calibration if needed. The larger the number 
of reference points involved, the better the coordinate calibration (max.: 
20 reference points).

- Once the list of reference points is okay, click the Compute button to let 
GNSS Solutions determine the local system. The dialog box is then 
refreshed to show the Horizontal and Vertical Residuals (see example 
below).

By clicking the Results... button, you will be able to read the characteristics 
of the local system (Datum + Projection + System) resulting from the cali-
bration process. Note that in this case, all the fields are non-editable 
fields.
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Computing Datum Shifts

This function should be used exactly in the same way as the Performing Coor-
dinate Calibration on page 134. The only difference is that the present func-
tion only determines the set of parameters defining the datum and so assumes 
that the projection used is correct.

Testing Coordinate Transformations

Use the Tools>Test Transfo.. command to test coordinate transformations from 
a system to another. You must specify the source and target coordinate sys-
tems. Transformations can be run in one direction or the other, which means 
the functions of “target” and “source” systems can be swapped between the 
two systems involved, depending on the direction you choose for the transfor-
mation. 
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Making Coordinate Transformations 
Between Any Two ITRF’s

GNSS Solutions allows you to convert coordinates from a given International 
Terrestrial Reference Frame (ITRF) to another. The conversion can be run for 
any given day, month and year.
- From the menu bar, select Tools>Test TRF.
- Select the “source” ITRF in the Left TRF field
- Select the “target” ITRF in the Right TRF field
- In the Date field, set the day, month and year for which you want the con-

version to be made
- Enter the “source” coordinates in the left-hand part of the dialog (X ECEF, 

Y ECEF, Z ECEF fields)
- Click the thin vertical button marked with a “>” to convert the coordinates 

to the target ITRF. The result is shown in the the three fields (X ECEF, Y 
ECEF, Z ECEF) on the right-hand part of the dialog (see conversion example 
below).

Note that conversions can also be made the other way round using the “<“ 
button. 
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Chapter 8: Background Maps

GNSS Solutions allows you to import background maps into a project. Once im-
ported, background maps are shown in the Survey View window.
If the open project contains survey results in the same geographic area, these 
results will be superimposed on the background maps. The presence of back-
ground maps can significantly improve the quality of the reports you print for 
your customers.
Two different types of background maps can be imported into your projects:
• Raster maps (in BMP, JPG, JPEG2000 or non-compressed TIF format)
• Vector maps (in SHP, MIF or DXF format)

Background maps can be uploaded to an external device, e.g. for use in the 
field. With this functionality, field operators can more easily locate themselves 
and find their working areas.
When uploaded to an external device, a vector map is converted into a raster 
map. This means each individual feature that was initially described in the 
original vector map cannot be selected on the display screen of the external 
device. When uploading a raster map, the file is first converted into Geotiff for-
mat before being uploaded.

Enabling the Background Maps Function

The Background Maps function is one of the options you can find in the Pref-
erences dialog.
If you keep the default choices when installing GNSS Solutions, then this func-
tion will automatically be made active by the installation program.
To check that the function is enabled, select Tools>Preferences. The Show Back-
ground Map functions option should be checked.

 To deactivate the function, just clear the check box and click OK.
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Importing a Vector Map

- Select Project>Import Vector Layers. This causes the Browse dialog box to 
appear.

- From the Look in combo box, select the folder containing the vector map 
you want to import (a MIF, SHP or DXF file).

- Select the file you want to import.
- From the Spatial Reference System combo box, select the coordinate system 

used in the selected file. You are supposed to know this system. If you 
don’t, ask the person who generated the file. If the coordinate system you 
need is absent from the list of coordinate systems, select <New> to create 
it. See Chapter 7: Coordinate Transformations for more information on how 
to create a new coordinate system.

- If you want to make a copy of this file into your project folder, check the 
Copy... box.

- Click Open to import the selected file and close the dialog.
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If an error message is reported in the output pane, if no map is displayed 
at all or if the map appears somewhat distorted, please resume the import 
operation using the appropriate coordinate system.

Importing a Raster Map

- Select Project>Import Raster Layers. This causes the Browse dialog box to 
appear.

- From the Look in combo box, select the folder containing the raster map 
you want to import (a BMP, JPG, JPEG2000 or non-compressed TIF file).

- Select the file you want to import.
- If you want to make a copy of this file into your project folder, check the 

Copy... box.

A new dialog box opens showing part of the map stored in the selected file.
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(Click  if you wish to reduce the size of this window:)

- In the Map name field, enter a name for the raster map, e.g. “Carquefou”
- In the Spatial Reference System field, select the name of the coordinate sys-

tem on which the raster map is based. This system may be different from 
the one selected in the project. GNSS Solutions will automatically perform 
coordinate transformations whenever necessary. (If you don’t know the 
name of the coordinate system used, ask the person in charge of scanning 
the maps to give you these coordinates.) If the coordinate system used is 
not listed in the combo box, select <New> and create this system (for more 
information on how to create a coordinate system, see Chapter 7: Coordi-
nate Transformations.)

Sizing & Importing the Raster Image:

The raster map being still dimensionless, you need to give it geographical di-
mensions. To do this, you have to define at least three reference points whose 
coordinates are accurately known in the system used.
- In the Raster Map window, right-click on the map and select Add reference 

points.
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- Find marks on the map –generally cross-hairs– surrounding your working 
area for which the original paper map can provide accurate coordinates. By 
“original paper map” we mean the map you scanned to create the raster 
file you are now importing.

- Determine these coordinates on the paper map, reading the map’s legend 
and grid lines, and then write down these coordinates. (If you don’t have 
the original paper map, ask the person in charge of scanning the maps to 
give you these coordinates.)

- In the Raster Layer window, find and click on the first mark and then enter 
its coordinates in the dialog box that shows up nearby.

- Then click OK.
- Use the horizontal and vertical scroll bars to access the second mark.
- As previously, click exactly on this point and then enter its coordinates. 
- Create a third reference point using the same procedure.

Make sure your reference points are evenly distributed over the working 
area.
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If you created a reference point with wrong coordinates or you simply want 
to delete this point, do the following:

• Top right of the window, click  then click on the reference point you 
want to edit or delete

• Click  to delete the point then confirm the deletion

• Or click  to edit its coordinates. Then correct the wrong values and 
click OK.

- Once all the reference points are created, click OK at the bottom of the 
dialog to import the file and close this dialog. The raster map will appear in 
the Survey View. You may need to adjust (zoom/pan) the view to see the 
raster map.
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Deleting a Background Map

You can delete a background from a project by doing the following:
- Right-click anywhere on the Survey View and select the Legend option.
- Scroll down the list of layers until you can select the background map you 

wish to delete.

- Select this background map, click on  located in the upper-right cor-
ner of this dialog box and then click OK. As a result, the background map 
will disappear both from the Survey view and the project.

Uploading a Background Map to ProMark3

You can upload several raster or vector maps to ProMark3. You can even upload 
a combination of several of these maps through a single upload procedure.
If you select one or more vector maps for uploading, GNSS Solutions will merge 
all these maps into a single one before uploading it to the ProMark3. For this 
reason, GNSS Solutions will ask you to name the resulting map (default name: 
Detail00).
If you select more than one raster map for uploading, GNSS Solutions will keep 
these maps unchanged and as many maps will be seen on ProMark3 after the 
uploading.
Follow the procedure below. The map or maps you want to upload must have 
been imported in the open project otherwise no data will be uploaded.
- Connect the ProMark3 to a USB port on your office computer using the 

cable supplied with your ProMark3.
- Turn on the ProMark3 and then double-tap the Surveying icon to launch 

this function.
- On the PC, unless already done, launch GNSS Solutions and open the 

project containing the map you want to upload.
- Select Project>Upload Maps to External Device.
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- Check on the buttons corresponding to the map you want to upload. For 
example to upload a raster map named “District#101”, check on the Ras-
ter button and the “District#101” button.

- In the same dialog, at the bottom, select the USB port used to communi-
cate with the ProMark3.

- If the map you want to upload is a vector map, you can rename the map 
(default name: “Detail00”) so this name be used on the external device to 
identify this map. You cannot rename a raster map.

- Click OK to upload the map. 
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Chapter 9: Reports

This chapter covers the procedures for producing a printed copy of your project 
data. The report software lets you select the information you want to print, and 
automatically inserts the selected parameters into a standard RTF-formatted 
report that can be edited and printed by any standard word processing pro-
gram. It is assumed that you have created a project and completed the pro-
cessing described in the preceding chapters, and you now want to compile the 
results.
GNSS Solutions allows you to create almost instantly a survey report for your 
clients or for your archives. This report will be part of the project and, in the 
GNSS Solutions main window, will share the same area as the Time and Survey 
views. To switch from the report view to the Time or Survey View, simply click 
on the corresponding tab at the bottom of this area.
The process of creating a survey report is based on the use of a VB Script macro 
stored in the ...\Studio\Macro folder.
You can create as many reports as necessary in a project. GNSS Solutions will 
automatically name these reports in the form “Land Survey Report#”.
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Customizing Reports

Before generating a report, select Tools>Preferences and then click on the Re-
port tab. You can now make the following choices:

• Automatic word selection. If you clear this option, you can select any section 
of text from within the generated report. If you check it, GNSS Solutions 
will automatically extend your selection to entire words.

• Ruler Units (inches, centimeters, points, picas): Defines the graduations 
used on the ruler located on top of the report window once a report has 
been generated.

• Word wrap: Depending on this choice, the text present in the report will 
either extend to the right without any limit (No wrap) or will be pushed to 
the next line when coming up against the right fence of the window (Wrap 
to window) or the right end of the ruler (Wrap to ruler).
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Creating a Report

To create a report:
1. Press the F9 key or select Project>Land Survey Report

This opens the following dialog in which you can choose which topics you 
wish to include in the report:

2. Check the topics you want to include, clear those you want to exclude
3. Name the report
4. Click OK to let GNSS Solutions create the report according to your request.
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This is a sample of what a survey report looks like on the screen:)

Once generated, reports can freely be edited: sections of text can be deleted 
or replaced, etc. With the report window active in GNSS Solutions, you can also 
use the functions available from the Report menu to format the document:
• Font...: Lets you choose a font for the current selection
• Bullet Style: Adds/removes a bullet at the beginning of the selected para-

graph
• Paragraph...: Lets you define the characteristics of the selected paragraph
• Tabs...: Lets you set tabs for the selected paragraph.
You can also define the width of the document by selecting all the text in the 
report and then dragging the 2 markers on the ruler to the desired positions.
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Inserting a Map into a Report

By adding maps into your reports, you will give more legibility to your results 
and make your clients happier.
Follow the procedure below to insert maps:
• Make sure the report document in which you would like to insert a map is 

open.
• Click on the Survey View tab.
• Set this View in such a way that all the elements you would like to see on 

this view are visible.
• Click anywhere within the Survey View to make it the active view in GNSS 

Solutions.
• From the menu bar, select Edit>Copy view.
•  Click on the tab showing the name of your report to make this report the 

active view in GNSS Solutions.
• Click inside the report where you would like to insert the content of the 

Survey View (indicate the insertion point)
• From the menu bar, select Edit>Paste. As a result, the exact duplicate of 

the Survey View appears in the report as an image. This image is placed at 
the insertion point.

• From the menu bar, select File>Save report to save the report file.

 You can insert as many different maps from the Survey View as necessary. To do 
this, resume the procedure above as many times as necessary. Each time you do 
that, make sure the Survey View shows what you would like to insert in the report 
and also make sure you indicate the insertion point in the report document before 
pasting. 
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Chapter 10: Exporting Data

Exporting Data to a File

- Select the data you want to export. You can make this selection on a map 
document or in a table document showing this data.

- On the GNSS Solutions menu bar, select Project>Export Geo Data to File.... 
The table below summarizes all export formats supported by GNSS Solu-
tions versus the type of exported data.

- Browse on your disk to select the folder where to store the export file and 
enter a name for this file

- Click the Save button to export the data to that file.

Export Format Points Vectors Features
NMEA (*.txt file)
TDS (*.CR5 file)
Carlson (*.CRD file)
User-defined
Ashtech (O*.* file)
AutoCAD (*.DXF file)
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Creating Custom Formats

With GNSS Solutions, you can easily create a data import or export format suit-
ed to your needs. All the creation process takes place within a single dialog box 
that you can access by following the procedure below, after opening a project 
in GNSS Solutions: 
- On the GNSS Solutions menu bar, select Project>Import Geo Data from Files... 

or Project>Export Positions to Files on Disk...
- In the left-hand area of the dialog box that opens, select Points or Vectors, 

depending on the type of object for which you want to create a custom for-
mat

- Click on  to create a new format, or  to make changes to an existing 
custom format after selecting its name in the right-hand list. The dialog 
box that opens allows you to define a new format or to modify the existing 
custom format.

This dialog box is divided into 5 main areas as shown in the figure on the next 
page:
- Area allowing you to name the file that will contain the created custom for-

mat (1)
- Area allowing you to choose the parameters that can be inserted into the 

custom format + insert button + Header/Body selection buttons (2)
- Area for editing the header of the custom format (3)
- Area for editing the body of the custom format (4)
- Area allowing you to view a file containing data that you would like to out-

put via the custom format you are currently defining. (5).
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Dialog box allowing you to create a custom format:

To create a new custom format, follow the instructions below:
1. In the Name field, enter a name for the new format. In the Extension field 

just below this field, enter the file extension (3 characters max.; default: 
txt) for the created file

2. Start with the definition of the header by checking the Format Header radio-
button. All the fields that can be inserted into the header are listed in the 
Field Selection list box

3. Choose one of these fields from the list and click on the Insert... button. A 
new dialog box opens asking you to specify formatting instructions for this 
field

(1)

(2)

(4)

(3)

(5)
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Depending on the type of the field, you will have to define its length 
(width), the number of decimal places if it’s a numeric field, its format if 
it’s a date, time or geographical coordinate, and possibly the associated 
text (use \t to insert a tab within the text box).
For example, you can enter the following formatting instructions in this box 
after you have selected $Project in the list:

4. Click OK. The Format Header edit box now contains the following informa-
tion:
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You can change the formatting parameters by selecting them directly from 
within this edit box.

 The “Width” parameter you have just defined is located just after the field name, 
within the square brackets, and is separated from the name by the “:” symbol.

If you could have defined a number of decimal places for this field, this number 
would have been inserted just after the “Width” parameter, also separated from this 
parameter by a “:”.

Example: SdZ:8:2 means that the “SdZ” numeric field will occupy a total of 8 char-
acters, 2 of which will be dedicated to the fractional part. If the field value fits in 
less than 8 characters, then leading spaces will be inserted to fill the field. The dec-
imal point occupies one character.

5. In the Format Header edit box, you can also create a new line, by inserting a 
carriage return, to type text directly in this box

6. Check the Format Body radio-button. All the fields that can be inserted into 
the format body are now listed in the Field Selection list box

7. Follow the instructions from points3. to 5. above to create the format body. 
The instructions mentioned in the dialog box are an alternative to the pro-
cedure described above

8. Click OK to save the newly created format. The name of the new format is 
now listed on the right in the initially selected dialog box (Import... or 
Export...).
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Uploading Waypoints & Control Points to ProMark3
Any type of point from a GNSS Solutions project can be uploaded to a 
ProMark3 as a waypoint.
Only control, reference and target points from a GNSS Solutions project can 
also be uploaded to ProMark3 as a control point. When you create a control 
point in ProMark3 through this procedure, ProMark3 automatically duplicates 
this point in its memory as a waypoint.
- Select Project>Upload Positions to External Device.
- In the dialog that opens, choose between Points (as wpts & ctrl pts) and 

Points (as wpts only), depending on whether you want the uploaded points to 
be transformed into respectively waypoints only, or both waypoints and 
control points:

- Click OK. A new dialog box opens giving all the instructions to complete 
this upload operation:
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- First choose whether you want to upload all the points from the project or 
only some of them. If you have selected some of them before selecting this 
function, Selected will be the default option, otherwise the All button will 
be checked on. On the screen shown on the right, you can trim your selec-
tion of points to be uploaded by using the None, Selected, Remaining and All 
buttons for each of the allowed point types (i.e. target, reference and con-
trol points).

- Then connect the ProMark3 to the PC using the appropriate cable.
- Turn on the ProMark3 and then launch the Surveying function.
- Back to the above dialog, indicate the port used on the PC to connect the 

receiver
- Choose whether you want to erase the existing waypoints in the receiver or 

not (Check or clear the Erase existing waypoints button)
- Click OK. This uploads the points to the receiver according to your request 

(GNSS Solutions will automatically find the correct baud rate to communi-
cate with the receiver). 
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Chapter 11: RTK Projects

The RTK function allows you to support for real-time surveys as well using 
GNSS Solutions. Once enabled in GNSS Solutions, the RTK function allows 
you to do the following:
- Creating a project for a real-time job. This includes, in addition to setting 

the usual parameters of a GNSS Solutions project:
• Creating a feature code list
• Importing points from files generated by third equipment
• Creating points using the Map toolbar.

- Uploading the real-time job to the rover unit. This procedure is based on 
the use of the SurvCom utility.

- Downloading the real-time results into a project, or combining them with 
those of a post-processing project.

Enabling the RTK Function

- Select Tools>Preferences
- Check the Show RTK functions option
- Click OK to close the Preferences window. This makes the RTK feature 

immediately available for use.
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Creating a real-time (RTK) Project

RTK projects are created exactly in the same way as post-processing projects 
(see Creating a New Project on page 35). The only difference is the presence 
in RTK projects of an additional tab called “Feature Code List” in the project 
settings.
This tab allows you to define a list of feature codes for the project. These fea-
ture codes will be uploaded to the surveying system as part of the job and are 
intended for field operators. The list of feature codes can be saved as a FCL or 
TXT file.

Editing the Feature Code List

With your project open, do the following:
- Select Project>Edit Settings... or, in the Command pane, click on the Project 

topic bar and then on the Project Settings icon. 
- In the Project Settings dialog now open, click on the Feature Code List tab. 

This tab looks like this:
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- Use the following buttons to create or edit feature codes:
- New... button: opens the New Feature Code dialog box from which you 

can define a new feature code. GNSS Solutions will then add the fea-
ture code you define to the list of existing feature codes. (See expla-
nations on the next page.)

- Load... button: allows you to load a *.fcl file containing a list of feature 
codes that you wish to use in the project

- Save... button: allows you to save the list of feature codes currently 
shown in the Feature Code tab as a *.fcl file. Use this button when you 
wish to use this list of feature codes later and you do not want to 
waste your time typing these entries again.

- In addition, you can select a feature code by clicking the correspond-
ing code in the leftmost column. After a right click on this code, you 
can delete this feature code or display its properties.

Adding a new feature code:

- As explained on the previous page, on the Feature Code tab, click the New... 
button. This opens the New Feature Code dialog box.
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The following parameters need to be defined in this dialog box:

Below is an example of a feature code defined as explained above:

- Click OK to create the new feature code and close the dialog box.

Code
An abbreviated code displayed on the display screen of the surveying equip-
ment to help the operator classify the points she/he has to survey in the current 
job (19 characters max.)

Layer Name of the family of elements to which the code presented above refers
Full text A description clearly explaining what’s behind the code presented above

Polyline On

Polyline On =YES means that all the points surveyed successively will by 
default be assigned the above code and so will form a polyline with point Ids 
incremented automatically.
Polyline On =NO means the opposite, namely each new surveyed point should 
be defined manually as to which code should be assigned to it

Polyline is 
3D

Relevant only if Polyline On=YES
Polyline is 3D=YES means that all the surveyed points will be 3D points (hori-
zontal coordinates + vertical coordinate)
Polyline is 3D =NO means that all the surveyed points will be 2D points (hori-
zontal coordinates only)
164



RTK Projects
Uploading a Real-Time Job

R
T
K

 P
ro

je
c
ts
Uploading a Real-Time Job 

The diagram below summarizes the different steps through which GNSS Solu-
tions can provide FAST Survey software, a 6500 or 6000 unit with a job.

(1) ProMark3 RTK or field terminal used with ProMark 500 or Z-Max.Net.
(2) Skip this step with ProMark 500.
(3) ProMark3 RTK, Z-Max.Net.
(4) ProMark 500.

Connect Husky to 
PC via serial cable

On Husky, run 
Hcom by typing “h”

Insert PC Card for 
6000 in office PC 

drive

FAST Survey 6500 6000

Select Project>Upload Positions to External Device...

Select device in which to upload the job:
-FAST Survey data collector
- 6500 data collector
- 5000/6000 PC Card

Click OKClick OK

Specify PC port involved Specify path to PC Card drive

Name the job
Choose & sort the reference & target points that must be part of the job

Click OKClick OK

Click OKClick OK

Job Upload in progress...

Use PC Card in 6000End

Choose port (3) or ActiveSync (4) 
and Automatic or Manual Transfer

Click OK

Click OK

Switch on data collector (1),
Launch FAST Survey.

(2) Run File> 6 Data transfer> Carl-
son SurvCadd/Carslon Survey
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Downloading Field Results

The diagram below summarizes the different steps through which GNSS Solu-
tions can retrieve field data collected by FAST Survey, 6500 or 6000.

(1) ProMark3 RTK. (5) ProMark 500.
(2) ProMark3 RTK or field terminal used 
with ProMark 500 or Z-Max.Net.

(6) O-files contain position data computed from 
the moment the ProMark3 RTK user pressed 
“LOG” on the screen until she/he pressed 
“DONE”.

(3) Skip this step with ProMark 500.
(4) ProMark3 RTK, Z-Max.Net

Connect Husky to 
PC via serial cable

On Husky, run 
Hcom by typing “h”

Insert PC Card for 
6000 in office PC 

drive

FAST Survey 6500 6000

Select Project>Download Positions from External Device...

Select type of data to be downloaded (real-time results) and device from which to download:
-ProMark3 Surveying
-FAST Survey data collector
- 6500 data collector
- 5000/6000 PC Card

Click OKClick OKClick OK

Specify PC port involved Specify path
to PC Card drive

Select the job you want to download

Click OKClick OK

Click OKClick OKClick OK

End

Choose port (4) or Active-
Sync (5) and Automatic or 

Manual Transfer
Click OK

Switch on data collector (2),
Launch FAST Survey.

(3) Run File> 6 Data transfer> Carl-
son SurvCadd/Carslon Survey

Choose coordinate system (if different from the project’s)

Job download in progress...

Click OK

This launches the 
Download Utility...

 -Select O-file(s) (6)
 -Drag O-file(s) to Project Folder
 -Quit Download Utility

This imports O-file(s) 
into the open project...

Connect ProMark3 
to PC, run Survey-
ing (double-click 
Surveying icon)

ProMark3 (1)
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Chapter 12: Advanced Features

GNSS Solutions’ advanced features fall into two categories: Data Management 
and CAD.
- Data Management– This option enables the following functions:

1. Capability to create additional documents in a project (these docu-
ments can be appended to the report you deliver to your customer):

•By giving access to the project database, this option lets you 
choose the data you would like to show in these documents.

•By giving access to user-settable legends, this option allows you to 
customize the presentation of this data in these documents.

•These documents are part of the project and are all saved when 
you save the project

Documents fall into 5 different types: Time documents, Map docu-
ments, Table documents, Report documents, Graph documents
You will notice that the Time View, the Survey View and the Workbook 
window are in fact the default documents of any project you create. 
The Time View is a time document, the Survey View is a map docu-
ment and the Workbook window is a table document. With the Data 
Management option activated, the content and legend of each default 
document can also be re-defined.
Access to the project database collections also allows in-depth analy-
sis of the project data.
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2. Capability to split the data of your jobs into several independent 
projects grouped in the same workspace.
You may need this functionality when for example you have several 
days of data recording for a given job and you wish to keep the data 
for each day independent from each other but you also want to be 
able to combine them in a further step.

- CAD– This option enables the following functions:
1. Automatic creation of the Design View when creating a new project. 

This view only shows points or features –not baselines, vectors or error 
ellipses– and so gives a clear view of the project and its final results. 
A special feature of the Design View is that its legend is automatically 
updated whenever new feature codes are created in the project 
(through the Feature Code List tab of the Project Settings dialog box).
If you also activate the Data Management option, the Design View will 
appear as a map document, like the Survey View, which you will be 
allowed to customize.

2. Capability to manually draw lines and areas on the Survey View or in 
any other map document with the appropriate legend.

3. Capability to individually assign layer names to points and so create 
representations specific to these points based on their layer names

4. Capability to automatically draw lines or areas on the Design View –or 
any other map document with the appropriate legend– based on layer 
names assigned to points.
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Data Management

Activating the Data Management Option
- Select Tools>Preferences
- Check the Data Management option
- Click OK to close the Preferences window. The Data Management features 

are now available for use.

Description of the New Main Window
When you activate the Data Management option, the area in which the Com-
mand pane was previously located is now a 3-tab area. In addition to the Com-
mand tab are the Documents and Collections tabs:
- The Collections tab shows the architecture of the project database. Dou-

ble-clicking any of the listed collections allows you to display the proper-
ties of this collection.
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- The Documents tab shows the list of documents attached to the project. 
Double-clicking any of the listed documents allows you to open this docu-
ment.

This new area, with its three different tabs, is called the “Workspace pane”.
In addition, the area in the main window where all open documents are dis-
played is called the “View Pane”.

Command tab

Collections tab
Documents tab
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Workspaces, Projects, Documents, Databases & Collec-
tions
Every new project that you create with GNSS Solutions relies on the following 
architecture (that you can clearly see when the Data Management option is ac-
tivated):

Workspace

Project #1

Collection #1

Object #1

Object #n

Project #2

Documents

Collections
Project database

Maps
Attribute tables
Reports
Graphs
Time view

Attributes
(text, numeric, geometric)
Attributes
(text, numeric, geometric)

Collection #n

Object #1

Object #n

Attributes
(text, numeric, geometric)
Attributes
(text, numeric, geometric)

etc.
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Workspace: Contains one or more projects (5 max.). Any project created previ-
ously from another workspace can be inserted into the open workspace, for the 
sole purpose of being seen from within this workspace.
Project: A repository for your field data.
Collections: Each collection contains a number of objects like points, files, 
vectors, etc. Each object is defined by a list of attributes, plus a geometric at-
tribute defining the location of the object on the surface of the Earth.
Documents: Five possible types: map, table, time view, report and graph. Doc-
uments are created to show the content of the project database from a partic-
ular angle.

The open workspace and the projects it contains are shown in the Documents 
tab.
Example of workspace:

The project database looks like this:

Workspace name

Projects present in 
the open workspace

Set of collections present 
in the land survey project

Project name
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To know more about the different collections you can find in a project, refer to 
Database Collections on page 203.

Creating a Project with Data Management Enabled
To create a new project in a new workspace, you must first create the new work-
space and then the project in the workspace. Assuming there is no project 
open in GNSS Solutions: 
1. Select File>New. Notice the following two changes in the New dialog box 

compared to the dialog you would obtain without the Data Management 
option activated:
• Presence of a new tab named “Workspaces”
• Presence of workspace-related options on the Projects tab 
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2. Click on the Workspaces tab and then enter the name of your workspace in 
the Workspace name field.

3. Click OK to create the new workspace. Although the main window stays 
blank, the newly created workspace is in fact open in the window.

4. Select File>New again and this time enter the project name in the Project 
name field.

5. Make sure the Add to current workspace option is checked
6. Click OK to create the new project in the current workspace. The project is 

created and displayed with its default documents.
 If you create a new project with the Create new workspace option checked, 

GNSS Solutions will not only create a project with the specified name but also a 
workspace with the same name. The new project will be saved in the new work-
space.

Assuming a project is already open in GNSS Solutions, you can include the 
new project in the currently open workspace by doing the following:
1. Select File>New. Note the presence of a third tab (Documents) in the dialog 

box that opens:
2. Click on the Projects tab and then enter the name of the new project in the 

Project name field 
3. Check Add to current workspace
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4. Click OK to create the new project. The project is created and displayed 
with its default documents.
The new project becomes the active project in the workspace, which 
means you are only allowed to work on the documents and collections of 
this project.

- To switch to another project in the workspace (i.e. make it active), select 
Project>Set Active Project and then the name of the project you wish to make 
active. When you do that, all the default documents from the active project 
are open in the View Pane and all others are closed.
To combine data from different projects grouped in the same workspace, 
refer to Combining Data from Different Projects on page 201.

Map Documents
1. Representing Database Collections in a Map Document

Almost any collection in a project database can be represented on a map. 
GNSS Solutions refers to styles to visualize objects from collections. Styles can 
be user-modified.
A style is defined by the following parameters:
- Name of the attribute chosen to identify the objects in the collection. For 

example, you can use the point name or one of its feature codes to identify 
all points on the map.

- Text color (name)
- Background color (behind name)
- Line or fill style for collections of lines or areas
- Icon assigned to objects (defined as a file stored in .../GNSS Solutions/

Symbols). The user can create new icons if required and store them with 
the existing ones.
175



12 Advanced Features
Data Management
- Icon size
- Name position with respect to the icon.

An example of Style dialog box is shown below. To view this box:
- Right-click anywhere on the Survey View of the open project
- Select Legend
- Select the “Logged points” layer in the list

- Click .

You can decide on which objects from a collection you would like to show on 
the map, thus making the other ones invisible. This choice is made by setting 
a display filter.
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From the previous screen, click on the Data tab to access the filter definition 
parameters:

In this example, the display filter has two criteria:
• Type=10
• Status<>50

These are coded criteria. To know the exact meaning of the first criterion:
- Click on “Type”
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- Click . A dialog box opens showing the definition of the criterion which 
is “Show only points from the Points collection of the “Logged Point” 
type”:

- Click OK to close the dialog.
The second criterion can be read in the same manner:
- Click on “Status”

- Click . The second criterion is: “Show only points from the Points col-
lection that have not been adjusted”.

In fact GNSS Solutions converts any text-string-based filter criterion that you 
choose into a number. The reason is that it is easier for the software to handle 
numbers rather than language-sensitive text strings. This may be confusing 
though. So please, refer to Filter Codes in Legends of Map Documents on 
page 372 to know the correspondence between the criterion you choose and 
the number set by GNSS Solutions to process this criterion.
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Let’s now introduce the following two important terms:
- Layer: visual result on the map of a style and a filter applied to a collection 

of objects
- Legend: the set of layers defined in a map document.

Knowing these definitions helps you understand what a map document really 
is. In fact, when you save a map, you just save its legend.
It is easy to imagine how interesting map documents are. What appears when 
you open the map document depends on the contents of the project database 
that time. The same map can show very different things at different times (for 
example at the beginning and then at the end of a survey).
Finally, once you have defined a map document with a nice legend that you 
would like to re-use in future maps, you can save this map document as a de-
fault map document. All projects created later will then include this default 
document.

For more details, see Adding a New Layer to a Map Document on page 179.

2. Creating a Map Document in an Open Project

- On the GNSS Solutions menu bar, select File>New
- Select “Map” on the Documents tab. Name the new document by typing a 

name in the File Name field.
- Click OK. A new blank map document opens in the View pane.

3. Adding a New Layer to a Map Document

Representing any object from a collection in the project database requires the 
use of a layer. In any project that you create, there is a number of default layers 
created by GNSS Solutions itself. However, you can create as many layers as 
necessary for a given collection.
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For example, with points, you can create as many types of layers as there are 
different types of points.
To add a new layer, you have to:
1. Choose the collection on which the layer will apply to
2. Name the layer
3. Define a filter on the attributes of the source collection. In fact, the defini-

tion of the layer will result from the choices you make in this step
4. Define a style (icon and associated text) specific to the layer. GNSS Solu-

tions will refer to this style to represent each of the objects meeting the 
layer criteria.

In the example below, you will create a new layer called “Control Points” refer-
ring to any object from the Points collection for which Type= Control Points. 
This will be done using one of your projects containing control points. First, 
you will create a new map document as explained in Creating a Map Document 
in an Open Project on page 179. Then:
- On the menu bar, select Map>Legend

- On the Legend tab, click 
- In the new dialog box that opens, select “Points”:
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- Click OK. In the Layer Wizard: Data dialog box that opens, type a name (e.g. 
“Control Points”) for the new layer in the Alias field.

- Then click  on the right. A new dialog box opens.
- In this dialog box, set the attribute filter as shown below:

- Click OK. Your current filter setting appears in a new dialog box:
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- Click Next. The Style dialog box now displays. You can do the following to 
customize the appearance of an object type on the map:

1. Label definition area. If you clear the Text button, there is nothing 
else to be defined in this area. If on the contrary this button is 
checked, you have to define:

•  The attribute used as label
•  The color used for characters
•  Background color (if Back button checked)
•  Location of the label with respect to the icon (9 preset locations)

1.

2.

3. 4.

5.

6.
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2. Icon definition area. If you clear the Symbol button, there is nothing 
else to be defined in this area. If on the contrary this button is 
checked, you have to choose the representation of the object in the 
combo box opposite the button.
Then, depending on the symbol chosen, you have to define additional 
parameters, such as:

•Line color and width
•Fill color and effect 

3. Shows/Hides error ellipse tied to the point. Ellipse centered on the 
point. Vertical precision represented as a vertical segment positioned 
next to the point

4. Check this button to see what the object looks like when selected
5. This area is constantly updated to show the aspect of the object as 

you define the style
6. Use these buttons to adjust the size of the object on the map.

- When you have finished with the style definition, click the Finish button. 
The new layer now appears in the Map Properties dialog box.
As a default setting, the check button located before the layer name has 
been checked so that all the objects meeting the layer criteria be seen on 
the map:
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This dialog box includes a number of buttons that can be used for the fol-
lowing:

-  to modify an existing layer

-  to delete the selected layer from the legend

-  to move the selected layer upward in the list. The layer positioned 
first in the list is brought to the front on the map.

-  to move the selected layer downward in the list. The layer posi-
tioned last in the list is sent to the back on the map.

- Click OK to close the dialog box.
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Table Documents
Table documents may consist of one or more tabs. Each tab contains a table 
that you can customize according to your needs. For instance you can add/de-
lete data columns, place a filter to list only those objects meeting the filter cri-
teria or list the objects in a given order.
Note that the default “workbook.tbl” document is a table document providing 
an exhaustive view of all the data in your project.

1. Creating a Table Document in an Open Project

- Select File>New to open the New dialog box.
- On the Documents tab, select “Table” from the list. Name the new docu-

ment by typing a name in the File Name field. For example, type in 
“Table1”. (Keep the other default choices: Active project prompted in the 
Add to project field; Blank Folder field means that the document will be 
saved in the active project folder.)

- Click OK. A new blank table document opens on the View pane. The table 
consists of a single tab named “sheet 1” (tab located at the bottom of the 
table document).

- To define the content of the document from the menu bar, select 
Table>Tabs. The Table Properties dialog opens.

- Click . This displays the Data tab in the Table Properties dialog box.

- Click  (on the right of the Collections field) to select the collection from 
which you are going to define the content of this tab. For example, choose 
“Points” and click OK.
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- In the As Tab field underneath, type a new name for the tab. For example 
type “Pts”:

- Click . The new dialog box that opens allows you to choose the 
attributes you wish to see in the table document. The default list shown in 
this table provides all the attributes that are not currently present in the 
table document. (You could also list all the possible attributes by checking 
the Show all attributes radio button.)
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- To add a new attribute to the table document as a new column in the “Pts” 
tab, first select it in the list. You can select several attributes at a time by 
holding down the Shift or Ctrl key while clicking on the attributes. Once all 
the desired attributes are highlighted, click Add. The Data tab is now dis-
played listing all the selected attributes:

- If you want to add more attributes to the “Pts” tab, resume the previous 
two steps.
Note that you can change the order in which the attributes are listed on the 
Data tab. To change the position of an attribute in the list:
• Select it

• Click  or  until the attribute is at the desired position. The first 
attribute in this list will appear in the first column and so on.

- When you are done with the attributes of the “Pt” tab, click OK to return to 
the Tab tab in the Table Properties dialog box.
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- To create a new tab, click  and then resume the previous 6 steps.
- Once you have defined all your tabs, click OK to close the Table Properties 

dialog box. Your new table document is then updated to reflect all the 
changes made. Note that GNSS Solutions has automatically filled in the 
tables using the relevant data from the project database.

2. Removing an Attribute from a Table Document

Temporary removal:
- On the menu bar, select Table>Data. This opens the Table Properties dialog 

box.
- In the list of attributes, clear the check button opposite the name of the 

attribute to temporarily remove it from the table
- Click OK. This removes the selected column from the table.

To re-enable this attribute in the table document, re-check this button.

Normal removal:
- On the menu bar, select Table>Data. This opens the Table Properties dialog 

box.
- In the list of attributes, select the attribute you want to remove from the 

table document.

- Click . This deletes the attribute from the list.
- Click OK. This removes the corresponding column from the table.
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3. Setting a Filter on an Attribute

Setting filters on attributes allows you to list only these objects in a table doc-
ument that you are interested in viewing. The result of this operation is that 
the table document will contain fewer objects (fewer rows).
- On the menu bar, select Table>Data. This opens the Table Properties dialog 

box.
- In the list of attributes, select the attribute for which you want to set a fil-

ter. For example, select “Surv_Horz_Conf”.

- Click . In the dialog box that opens, make the following choices:

- Click OK (twice). The table document now only consists of a number of 
rows showing the objects meeting the filter criterion. This criterion is 
recalled in the corresponding cell just under the column header. Inciden-
tally, if you click on this cell, GNSS Solutions will re-open the above dialog 
box.
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4. Sorting Objects in a Table Document

You can sort the objects present in table documents according to your needs. 
This is explained below.
- Open the desired table document in the View pane and then click on the 

desired tab.
- On the menu bar, select Table>Sort. This opens the Table Properties dialog 

box showing the Sort tab.
- In the upper-left field, click on the down-arrow and then select the 

attribute on which object sorting will be based.
Note that the choice of attributes in the drop-down menu attached to this 
field is not restricted to the set of attributes displayed in the table. Indeed, 
you can choose any attribute from the concerned collection.

- Once you have chosen the attribute, select the sorting direction by check-
ing the corresponding button (Ascending or Descending) opposite the field.
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- Through the same above 2 steps, you can define a second, even a third 
sorting attribute, with decreasing priority. They will take effect only if the 
higher-priority attribute fails to sort the objects. For example if the first 
(higher-priority) sorting attribute equals “25” for a number of objects in 
the table, then GNSS Solutions will use the second sorting attribute to sort 
these objects, etc. 

5. Creating a Geocentric System for a Table Document

Geocentric systems are incompatible with maps and so, in GNSS Solutions, 
can only apply to table or graph documents. This is the reason why you cannot 
select a geocentric system at project level. To create a new geocentric system:
- Run the Tools>Coordinate Systems command

- Click , check the Define a NEW GEOCENTRIC system option and click the 
Next button.

- Complete the two screens allowing the definition of a geocentric system. 
Defining a geocentric system is much like defining a geographic system 
(see Creating a Geographic System on page 127) except that you do not 
have to define a vertical datum.
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Time Documents
Time documents are principally used to show observation files versus time. 
They are very useful in post-processing applications. It does not make sense to 
base the definition of a time document on any collection other than the dated 
collections, namely “Points”, “Files”, “Stops” and “vectors”.
Note that the default “Time view” document gives an exhaustive view of your 
observation files.
The first 5 buttons from the map toolbar can be used when a Time document 
is active in the View pane:

1. Creating a Time Document in an Open Project

- Open one of your projects containing field data to create a time document.
- Select File>New to open the New dialog box.
- On the Documents tab, select “Time” from the list. Name the new docu-

ment by typing a name in the File Name field. For example, type in 
“Time1”. (Keep the other default choices: Active project prompted in the 
Add to project field; Blank Folder field means that the document will be 
saved in the active project folder.)

- Click OK. A new “blank” time document opens on the View pane.
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2. Defining the X Axis of a Time Document

- On the menu bar, select Time>Document Settings. This opens the Time View 
Properties dialog box showing the content of the Document Settings tab.
This tab defines the X axis of the time document (date & time at the origin 
+ date & time at the end of the diagram). When you create a time docu-
ment, GNSS Solutions analyzes the observation files present in the project 
and determines the period of time covered by these files. The 4 time 
parameters on the Document Settings tab are then automatically set to 
match this period of time.

You can however edit these 4 parameters, plus the time zone, to meet your 
own needs. To change the start or end date, click on the corresponding 
down-arrow.
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A calendar is then displayed:

• Click on the displayed year and use the up/down arrows next to it to set 
the year

• Click on the right/left arrow to set the month
• Click on the day number to set the day. This closes the calendar.

- When you agree with these parameters, click OK to close the dialog box.

3. Defining the Y Axis of a Time Document

You define the Y axis by adding layers to the legend, in the same way as you 
would in a map document.
- On the menu bar, select Time>Legend. This opens the Time Diagram Proper-

ties dialog box showing the content of the Legend tab.

- Click  to define the first layer. The new dialog box that opens allows 
you to specify the collection from which you want to define the layer.

- Select a dated collection (for example “Points”) and then click OK. This 
opens the Layer Wizard: Data dialog box.

- In the PLOT field, choose the data you want to use as the “graduation” 
along the Y axis. If you choose “Default”, then only the collection name 
will appear along the Y axis. For example, select “Name” in the PLOT field 
and then click Next>. This opens the Layer Wizard: Style dialog box.
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- You can now define the style of the objects that will be plotted in the time 
diagram. For example select “Type” from the drop-down menu associated 
with the Text field. This menu lists all the attributes of the Points collec-
tion you have selected in a previous step.

-  Then freely choose any style that you would like to apply to this object 
(text color, background color, position and symbol).

- Click on the Finish button and then on the OK button. The time document 
is now displayed in the View pane (see example below).

This view shows how and when each point was surveyed. Note that you can 
create several layers and apply filters to your layers, in the same way as you 
would in a map document.
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Graph Documents
You need to have a table document open on the View pane to create a graph in 
a graph document. Open one of your projects including field data and a map 
document.

1. Creating a Graph Document in an Open Project

- On the menu bar, select File>New
- Select “Graph” on the Documents tab. Name the new document by typing a 

name in the File Name field, for example, type “Graph1”.
- Click OK. A new blank graph document opens on the View pane.

2. Defining the X and Y Axes

 Select one or two columns in the workbook that you want to represent on the 
graph. If the second column is not adjacent to the first one, press the Ctrl key 
before clicking on the header of this column. If you select a single column, 
then its content will be used to define the Y-axis and a dimensionless, linear 
scale will be used as default setting on the X-axis.
- In the Workbook document, select the Surv_Horz_Conf column by clicking in 

the column header
- Drag and drop the column header in the Graph document.
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A graph now appears in the graph document, as shown below:

3. Adding a new curve on the same graph

- Right-click anywhere within the graph document and select Legend in the 
pop-up menu. The Graph Properties dialog box opens.

- On the Legend tab, click 
- Select “Surv_Height_Conf” in the PLOT field (located in the Data area at 

the bottom of the dialog box)
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- Click OK. The Graph Properties dialog box now shows two items on the Leg-
end tab:

- Click OK. Two curves are now plotted on the graph with different colors: 
one for the horizontal precision, the other one for the height precision.
Both use the same X axis.

4. Zooming in on a Graph

- Drag horizontally (along the X axis) on the graph. The selection resulting 
from the drag operation appears in black:
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- When you release the mouse button, GNSS Solutions zooms in on the 
selected region in order to show this region using the total width of the 
graph document:

- To come back to normal size, right-click anywhere on the graph document 
and select Zoom Out on the pop-up menu.

- Click OK to close this dialog box and enable the new coordinate system. 
The map is then updated to reflect the change made.

To change the coordinate system used in the active table document:
- Right click anywhere on the table and select Document Settings in the menu 

that pops up. The Document Settings dialog box opens.
- Select the desired system from the list attached to the Spatial Reference 

System field (a combo box). Note that you can also change the time zone.
- Click OK to close this dialog box and enable the new coordinate system. 

The table is then updated to reflect the change made.
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Selecting a Coordinate System in a Table or Map Docu-
ment
You can choose a specific coordinate system for any document, whether a table 
or map document, without affecting the choice you have made for the whole 
project. On the other hand, as long as you do not specify anything else, any 
document that you create in a project will by default use the coordinate system 
chosen for the project.
To change the coordinate system used in the active map document:
- Right click anywhere within the map document and select Document Set-

tings in the menu that pops up. The Document Settings dialog box opens. 
This box shows the coordinates of the central point on the map as well as 
the scale currently used. See example below:

- Select the desired system from the list attached to the Spatial Reference 
System field (a combo box). Note that you can also change the map viewing 
options from this dialog box, as explained in Changing the Viewing Settings 
on page 19.
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Combining Data from Different Projects
When the open workspace contains several projects, you can create a map doc-
ument in one of the projects (the active project) gathering objects from differ-
ent projects in the workspace.
1. Open the workspace
2. Choose a project in the workspace to be the active project by selecting 

Project>Set Active Project>[Project_Name].
3. Using the File>New command, select the Documents tab, choose Map, name 

the new document and click OK to create a new map document. This doc-
ument opens in the main window.

4. Click on  (Collections tab) in the Workspace pane. This tab shows 
the collections of all projects in the workspace pane. Note that the name of 
the active project is shown in bold characters.

5. Drag a collection from one of these projects into the open map document. 
The mouse cursor is changed into a “+” symbol while dragging. Release 
the mouse button when the cursor is inside the document. A new dialog 
opens asking you to apply a filter to the collection. Applying a filter at this 
stage is as explained in Adding a New Layer to a Map Document on 
page 179.

6. Then click Next>. A new dialog opens asking you to define a style to the 
collection. Defining a style at this stage is as explained in Adding a New 
Layer to a Map Document on page 179.

7. Click Finish. All objects from the collection that meet the filter criteria 
appear in the map document and are represented according to the style 
you have defined.

8. Resume Steps 5 to 7 to insert a collection from another project into the 
same map document. As a result the map document shows data from two 
different projects. Note that this map document stays attached to the 
project that was active when you created it.
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Editing the Definition of a Collection
To list the attributes characterizing any of the objects present in a collection, 
do the following:
- Right-click on a collection, select Properties on the popup menu, or double-

click directly on the collection. The two tabs below show the attributes of a 
point object (general case).

The first tab lists all the classic attributes (“one-dimensional” text, 
numeric or Boolean type). The second one shows the geometric attribute 
(“multi-dimensional”).
There are three possible types of geometric attributes:

- Point, defined by a set of coordinates expressed on a specific coordi-
nate system

- Line, defined by two or more sets of coordinates expressed on a spe-
cific coordinate system

- Area, defined by a close line.
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See Database Collections on page 203 where all possible collections in a 
project are reviewed. All attributes pertaining to each of these collections 
are also listed.

Database Collections
Files Collection

Each object in this collection is of the geometric type (3D point expressed in 
a specified coordinate system) and also has the following classic attributes:

Name File name
Full_Path Ashtech file full path name
Source Source file format
Start_Time Time of first record
Time_Span Record duration
Sampling Sampling interval (s)
Epochs Count of records
Size File size (KB)
Meas_Type Measurement type
Antenna_Type Antenna model used for data collection
Antenna_Height Default antenna height
Height_Type Default antenna height type
Site Default site name
Dynamic Indicates whether the receiver has been moved during recording
Receiver_Type Type of used receiver
Receiver_Number Serial number of used receiver
Satellites Available satellites
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Processes Collection

Each object in this collection is of the geometric type (3D line expressed in a 
specified coordinate system) and also has the following classic attributes:

Events Collection

Each object in the collection has the following attributes:

Num Process number in process scenario
Reference Reference site (used to get reference position)
Reference_File Reference file
Rover Rover site (used to store process results)
Rover_File Rover File
Mode Processing mode
Min_Elevation Satellite elevation under which data must be rejected
Deselected Satellites that must be excluded in any case
Forbidden_Reference Satellites that can't be used as reference
Mask Measurements that must be excluded from process
Orbit_Type Orbit type
L1L2 Indicates whether L2 data have to be process or not
Fix_Integers Indicates whether process have to fix integers or not
Done Indicates whether process has been executed or not

Point Associated point name
Description Associated point feature code
Time_Tag Time of event
File Raw data file
Receiver_Type Type of receiver used
Receiver _Number Serial number of receiver used
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Occupations Collection

Each object in the collection has the following attributes:

Areas Collection

Each object in this collection is of the geometric type (3D area expressed in a 
specified coordinate system) and also has the following classic attributes:

Lines Collection

Each object in this collection is of the geometric type (3D line expressed in a 
specified coordinate system) and also has the following classic attributes:

Site Occupied site name
Description Feature code of occupied site
Start_Time Start time of occupation
Time_Span Time span of occupation
File Raw data file
Antenna_Height Antenna height during occupation
Height_Type Antenna height type
Init_On_Bar Kinematic initialization point using initializer bar

Dynamic Indicates whether the receiver moved during 
the occupation

Receiver_Type Type of receiver used
Receiver_Number Serial number of receiver used

Name Area name
Description Feature code
Layer Layer name
Comment Free notes
2D_Length Area 2D-perimeter
3D_Length Area 3D-perimeter
Area Surface area

Name Line name
Description Feature code
Layer Layer name
Comment Free notes
2D_Length Line 2D-length
3D_Length Line 3D-length
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Points Collection

Each object in this collection is of the geometric type (3D point expressed in 
a specified coordinate system) and also has the following attributes:

Name Point name
Type Point type
Description Feature code
Layer Layer name
Comment Free notes
Control Control type 
Status Survey status
Constraints Coordinate constraints
Use Use in calibration
Ctrl_Easting Control easting
Ctrl_Northing Control northing
Ctrl_Latitude Control latitude
Ctrl_Longitude Control longitude
Ctrl_Ellips_Height Control ellipsoid height
Ctrl_Ortho_Height Control orthometric height
Ctrl_Easting_Sd Control easting standard deviation
Ctrl_Northing_Sd Control northing standard deviation
Ctrl_Height_Sd Control height standard deviation
Ctrl_Easting_Conf Control easting confidence (95%)
Ctrl_Northing_Conf Control northing confidence (95%)
Ctrl_Horz_Conf Control horizontal confidence (95%)
Ctrl_Height_Conf Control height confidence (95%)
Ctrl_Easting_Error Control easting error
Ctrl_Northing_Error Control northing error
Ctrl_Horz_Error Control horizontal error
Ctrl_Height_Error Control height error
Ctrl_Total_Error Control error according to control type
Ctrl_QA Control quality assurance test passed
Surv_Time Surveyed position time
Surv_Easting Surveyed easting
Surv_Northing Surveyed northing
Surv_Latitude Surveyed latitude
Surv_Longitude Surveyed longitude
Surv_Ellips_Height Surveyed ellipsoid height
Surv_Ortho_Height Surveyed orthometric height
Surv_Easting_Sd Surveyed easting standard deviation
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Vectors Collection

Each object in this collection is of the geometric type (3D line expressed in a 
specified coordinate system) and also has the following classic attributes:

Surv_Northing_Sd Surveyed northing standard deviation
Surv_Height_Sd Surveyed height standard deviation
Surv_Easting_Conf Surveyed easting confidence (95%)
Surv_Northing_Conf Surveyed northing confidence (95%)
Surv_Horz_Conf Surveyed horizontal confidence (95%)
Surv_Height_Conf Surveyed height confidence (95%)
Surv_EN_Corr Surveyed easting / northing correlation
Surv_EH_Corr Surveyed easting / height correlation
Surv_NH_Corr Surveyed northing / height correlation
Convergence Grid convergence angle for this point
Scale_Factor Grid scale factor for this point
Elevation_Factor Distance reducing factor to the surface of the ellipsoid
P1P Distance between P1 and P
P2P Distance between P2 and P
Side Lateral offset side
Warning Indicates there are warnings (check Message for more info)
Message System message

Reference From point
Rover To point
Start_Time Time of vector (start time of occupation)
Time_Span Time span of occupation
Solution Processed solution type
Proc_QA Quality Assurance test passed for processed solution
Proc_DX Processed ECEF WGS84 DX component
Proc_DY Processed ECEF WGS84 DY component
Proc_DZ Processed ECEF WGS84 DZ component
Proc_Length Processed length
Proc_DX_Sd Processed ECEF WGS84 DX standard deviation
Proc_DY_Sd Processed ECEF WGS84 DY standard deviation
Proc_DZ_Sd Processed ECEF WGS84 DZ standard deviation
Proc_Length_Sd Processed length standard deviation
Proc_DX_Conf Processed ECEF WGS84 DX confidence (95%)
Proc_DY_Conf Processed ECEF WGS84 DY confidence (95%)
Proc_DZ_Conf Processed ECEF WGS84 DZ confidence (95%)
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Proc_Length_Conf Processed length confidence (95%)
Proc_DXY_Corr Processed ECEF WGS84 DX / DY correlation
Proc_DXZ_Corr Processed ECEF WGS84 DX / DZ correlation
Proc_DYZ_Corr Processed ECEF WGS84 DY / DZ correlation
Dynamic Indicates whether vector has been processed in dynamic mode
SVs Count of satellites during process
PDOP PDOP during process
Meas_Type Measurement type
Epochs Count of records used
Enabled Indicates whether solution is to be kept for adjusment
Adjusted Indicates whether this vector has been adjusted
Adj_QA Quality Assurance test passed for adjusted solution
Adj_DX Adjusted ECEF WGS84 DX component
Adj_DY Adjusted ECEF WGS84 DY component
Adj_DZ Adjusted ECEF WGS84 DZ component
Adj_Length Adjusted length
Adj_DX_Sd Adjusted ECEF WGS84 DX standard deviation
Adj_DY_Sd Adjusted ECEF WGS84 DY standard deviation
Adj_DZ_Sd Adjusted ECEF WGS84 DZ standard deviation
Adj_Length_Sd Adjusted length standard deviation
Adj_DX_Conf Adjusted ECEF WGS84 DX confidence (95%)
Adj_DY_Conf Adjusted ECEF WGS84 DY confidence (95%)
Adj_DZ_Conf Adjusted ECEF WGS84 DZ confidence (95%)
Adj_Length_Conf Adjusted length confidence (95%)
Adj_DXY_Corr Adjusted ECEF WGS84 DX / DY correlation
Adj_DXZ_Corr Adjusted ECEF WGS84 DX / DZ correlation
Adj_DYZ_Corr Adjusted ECEF WGS84 DY / DZ correlation
DX_Residual ECEF WGS84 DX component residual
DY_Residual ECEF WGS84 DY component residual
DZ_Residual ECEF WGS84 DZ component residual
Length_Residual Total residual on vector length
Tau_Test Tau test passed
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Repeat Vectors Collection

Loop Collection

From From point
To To point
Observation1 Time of first vector (start time of occupation)
Observation2 Time of second vector (start time of occupation)
QA Vector quality assurance test passed
Length Processed length
Diff_X DX component gap
Diff_Y DY component gap
Diff_Z DZ component gap
Diff_Length Length gap
Diff_X_PPM DX component gap in ppm
Diff_Y_PPM DY component gap in ppm
Diff_Z_PPM DZ component gap in ppm
Diff_Length_PPM Length gap in ppm
Diff_X_Ratio DX component gap ratio
Diff_Y_Ratio DY component gap ratio
Diff_Z_Ratio DZ component gap ratio
Diff_Length_Ratio Length gap ratio

Loop Loop number
Loop_Length Total loop length
X_Miscl DX component misclosure
Y_Miscl DY component misclosure
Z_Miscl DZ component misclosure
Length_Miscl Total misclosure
X_Miscl_PPM DX component misclosure in PPM
Y_Miscl_PPM DY component misclosure in PPM
Z_Miscl_PPM DZ component misclosure in PPM
Length_Miscl_PPM Total misclosure in PPM
X_Miscl_Ratio DX component misclosure ratio
Y_Miscl_Ratio DY component misclosure ratio
Z_Miscl_Ratio DZ component misclosure ratio
Length_Miscl_Ratio Total misclosure ratio
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CAD Function

See Introductory Notes at the beginning of chapter Advanced Features on 
page 167.

Enabling the CAD Function
- Select Tools>Preferences
- Check the Show CAD functions option
- Click OK to close the Preferences window. This makes the CAD feature now 

available for use.

Creating a Project With the CAD Option Enabled
CAD projects are created exactly in the same way as post-processing projects 
(see Creating a New Project on page 35). The only difference is the presence 
in CAD projects of an additional tab named “Feature Code List” in the project 
settings, as is also the case in RTK projects (see Creating a real-time (RTK) 
Project on page 162)
This tab allows you to define a list of feature codes for the project. Feature 
codes give information on the geometry of features. For example a point will 
be defined as being part of a line if the feature code assigned to it refers to a 
line.
If you edit the points in your project and assign a feature code to each of them, 
GNSS Solutions will be able to draw automatically lines or areas connecting 
the points having the same feature code.
Any list of feature codes can be saved as an FCL or TXT file.
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Manually Drawing Lines and Areas
Lines:

On the map toolbar:
- Select <Project_Name> \ Lines in the combo box

- Click 
- Start drawing the line on the map by clicking on the start point, then at the 

end of each new segment forming the line
- To end the line, double-click the last point.
- In the dialog box that opens, complete the fields defining the line (on the 

Line tab) and then click OK to close the dialog box. The new line then 
appears on the map. Its representation relies on the definition of the layer 
this line belongs to.

Areas:

On the map toolbar:
- Select <Project_Name> \ Areas in the combo box

- Click 
- Start drawing the limits of the area by clicking on the start point, then at 

the end of each new segment forming the area.
- Double-click on the map to close the area. If you double-click on a point 

other than the area’s start point, GNSS Solutions will automatically create 
the missing segment allowing it to close the geometric figure.

- In the dialog box that opens, complete the fields defining the area (on the 
Line tab) and then click OK to close the dialog box. The new area then 
appears on the map. Its representation relies on the definition of the layer 
this area belongs to.
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Assigning Layer Names To Points (Setting Feature Codes)
Use the Design View to see the changes you make when assigning feature 
codes to your points. The reason is that the legend of this default document is 
automatically completed every time you add a new feature code to the project. 
For example, if you add a new feature code named “fence”, then GNSS Solu-
tions will create new layers in the Design View’s legend named “fence_Points”, 
“fence_Lines” and “fence_Areas”.
You can assign a feature code to one or more points by doing the following:
- Select the desired points on the Design View map document or in any other 

open document
- Click on the CAD topic bar in the workspace pane, and then on the Set Fea-

ture Codes icon. A dialog then prompts you to assign one of the feature 
codes defined in the project to the selected points (see example below):
212



Advanced Features
CAD Function

A
d
va

n
c
e
d

F
e
a
tu

re
s

- Select the desired feature code, click OK and then select:
• To Apply if you simply want to assign the feature code to the selected 

points. This feature code will then appear as the Description parameter 
in the properties of each of these points (see Point Properties on 
page 77)

• To Apply and Process if you also want GNSS Solutions to re-process the 
feature codes to build objects (lines or areas).

 The Description field is intentionally named “Description” not “Code” because 
this field can freely be assigned any value other than one of the codes from the Fea-
ture Code List tab.

Processing Feature Codes
This function allows GNSS Solutions to draw lines and create areas between 
the different points to which you have previously assigned feature codes.
You do not need to select anything in your project. GNSS Solutions will analyze 
all the feature codes assigned to your points and will automatically draw lines/
areas between the different points.
- To run this function, click on the CAD topic bar and then on the Process 

Feature Codes icon. For a given set of points defined with the same “line” 
feature code, GNSS Solutions will always draw lines from the oldest to the 
newest point (and so the program will ignore the order in which you may 
have selected these points before running the function).
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Ending a line

To end a line at a given point:
- Select this point in the Design View, right-click and select Properties (in the 

pop-up menu)
- In the dialog box that opens, type in “END”, in the Description field, after 

the already present string (see example below; don’t forget the space 
before “END”) and then click OK.

- Click on the Process Feature Codes icon in the Workspace pane to re-run the 
Process Feature Code function. The polyline will now end at the specified 
point, as shown in the Design View.

Creating an area

To create an area from a polyline:
- Select the end point of the polyline, right-click and select Properties (in the 

pop-up menu)
- In the dialog box that opens, overwrite “END” with “CLO” in the Descrip-

tion field and then click OK.
- Click on the Process Feature Codes icon in the Workspace pane to re-run the 

Process Feature Code function. The polyline will now be changed into an 
area, as shown in the Design View.
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Editing a Line

The properties of a line (i.e. a trajectory or polyline) are presented on a 4-tab 
dialog box (see above). To open this box, double-click a line displayed in the 
active map document. The Line tab contains the following information:
- Name and description of the line, name of the layer the line belongs to + 

comment
- A graphic view of the line showing its geometry and the location of the 

point currently selected on the Point tab
- The total length of the line, measured in two dimensions (projected onto 

horizontal plane) and in three dimensions (i.e. taking into account the 
individual height of each of the points making up the line).
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The Point tab shows the properties of each of the points making up the line. 
Use the vertical scroll bar to browse through the list of points.
The Offset tab shows the pivot points when the point selected on the Point tab 
was surveyed through an offset method (6000 & 6500 only).
The Vector tab shows the properties of all the vectors from which the survey of 
the line proceeds. Use the vertical scroll bar to browse through the vectors list. 
Each vector connects the reference point to each of the points forming the line.

Editing an Area
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The properties of an area are presented on a four-tab dialog box (see above). 
To open this box, double-click an area displayed in the active map document.
The Line tab contains the following information:
- Name and description of the area, name of the layer the area belongs to + 

comment
- A graphic view of the area showing its geometry and the location of the 

point currently selected on the Point tab
- The perimeter of the area, in the selected unit, measured on the horizontal 

plane (2D) and in three dimensions (3D) + area, in the selected unit, pro-
jected onto horizontal plane (2D)

The Point tab shows the properties of each point making up the area. Use the 
vertical scroll bar to browse through the list of points.
The Offset tab shows the pivot points when the point selected on the Point tab 
was surveyed through an offset method (6000 & 6500 only).
The Vector tab shows the properties of all the vectors from which the survey of 
the area proceeds. Use the vertical scroll bar to browse through the vectors list. 
Each vector connects the reference point to each of the points forming the ar-
ea.

 Use the Project>Group Points function to create an area from existing points. 
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Chapter 13:Corrections Providers & 
Reference Stations

Introduction

For every project created in GNSS Solutions, the Survey View will show the lo-
cations of reference stations present around your working area so you can use 
them at your convenience when post-processing your field data.
Reference stations are represented on the Survey View as blue and yellow tri-
angles (see below) with the first four characters of the station name displayed 
nearby.

When a project is still empty, you will notice that the Survey View does not 
show any reference station. This is because the default zoom setting in this 
case does not allow it. But if you zoom out repeatedly on this view, you will 
progressively see more and more stations.
As can be seen on the Survey View when completely zoomed out, reference sta-
tions can be found everywhere on all continents, with more or less dense net-
works depending on countries.
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Editing the Properties of a Reference Station

- In the map toolbar, click on 
- Double-click on any of the reference station icons shown in the Survey 

View. This opens a dialog box showing the properties of the station. The 
following information is provided: Station name, provider, antenna 
model,reference coordinates (on ITRF), local coordinates in the open 
project’s coordinate system, etc. None of these parameters is editable.

The meaning of each of the parameters shown in this dialog is provided in 
Adding New Reference Stations on page 224.
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Adding a New Provider

You can add providers to GNSS Solutions using the procedure described below. 
New providers will add up to the list of default providers.
Defining a provider is a three-step operation:
- First you will name the provider and optionally specify additional informa-

tion (comment, web site).
- Secondly, you will define the type, or types, of data offered by this pro-

vider.
- Finally, you will define one or more reference stations through which the 

provider makes its services available. The parameters of a reference station 
can be defined:
• Either by entering each of these parameters in the dedicated dialog box
• Or, more easily, by importing a file containing all these pararameters. 

Identifying the New Provider
- From the menu bar, select Tools>Station Reference Network. This opens a 

new dialog box showing the default providers.

- Click on  in the upper-right corner of the Reference Station Network 
window. This opens a three-tab Properties dialog box.

- Click on the Description tab and then enter the following parameters:
• Name: Provider name (mandatory)
• Comment: More information about the provider (optional)
• Info: Web site giving more information on this provider (optional)
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Defining the Provider Services

- Click on the Services tab and then click  in the upper-right corner of 
the window to enter a new service. Note that the dialog box then appearing 
(see below) will be slightly different depending on whether you want the 
new service to provide raw or precise orbit data, precise clock data or pre-
cise iono data, and the access to the web site is public or restricted.

This dialog box is organized, and should therefore be used, as follows:
• Name: Enter the service name or any other information relevant to the 

desired service. For example enter “Raw Data”
• Host: Enter the web address from which to download
• Data Type: Choose the type of data delivered by this service (standard 

RINEX raw data, compact RINEX raw data or precise orbit data, precise 
clock data or precise iono data).
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• Time Span: GNSS Solutions needs to know the period of time covered by 
any of the files delivered by this service. Enter this time in minutes. 
Ask your provider or consult its website if you do not know this value.

• OBS Files: GNSS Solutions needs to know where the files are stored on 
the provider’s website and how they are named. You should then enter 
the path to files (example: /pub/gps/rawdata) followed by the syntax 
used in the filenames. The “+” button located on the right of this field 
allows you enter this syntax in a more friendly way. Ask your provider or 
consult its website if you do not know the path and the syntax of filena-
mes.

• NAV files: Same as OBS files field above. You will not have to complete 
this field if the selected data type is “Precise Orbit Files”.
NOTE: If the provider delivers its observation and navigation data in the 
same zip file, then the same path should be specified in the “OBS 
Files” and “NAV Files” fields.

• Comment: Enter your personal notes regarding the service (optional)
• More Info: For example, use this field to enter the address of a particular 

page on the provider’s web site.
• Public/Restricted Access radio buttons: Choose the appropriate option. If 

you check Restricted Access, then you will have to enter a username and 
a password in the next two fields.

• Log in: If you have checked Restricted Access, enter the username nor-
mally supplied by the provider to access the specified website

• Password: If you have checked Restricted Access, enter the password 
normally supplied by the provider to access the specified website.

- Click OK to save the service you have just defined. This closes the dialog 
box and takes you back to the previous dialog box where you can see the 
list of existing services defined for this provider.

- To create a new service, click   again and resume the above instruc-
tions.
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Adding New Reference Stations
- Click on the Stations tab. You can define a new reference station either by 

entering each of its parameters or by importing a file containing the com-
plete description of the station.

Manual Entry:

- Click on  in the upper-right corner of the dialog box and then enter the 
station parameters in the Reference Station dialog box.

Station pane:
• Name: Enter the name of the reference station.
• Comment: Enter any useful information relevant to the station (country, 

town where it’s located).
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• Log File: Use the Browse button next to the field to find the log file cor-
responding to the station you are defining. This implies that the log file 
should have been saved somewhere on your computer beforehand. Log 
files are usually available from  provider web sites. See Linking a Refer-
ence Station’s Log File to its Properties Dialog Box on page 228 for 
more information. Once you have chosen the log file, you will be able to 
open it directly from this dialog by simply clicking on the blue file 
name mentioned in this field. If you wish to remove the link to the 
specified file, just click the Clear button next to the field.

Antenna pane:
• Antenna Model: Select the antenna model used at the station from the 

drop-down list.
• Height to ARP: Height, in meters, from the ground to the Antenna Refer-

ence Point (ARP).

Reference Coordinates pane:
• Reference Frame and Epoch: The position of the reference station should 

be expressed in a given ITRF (ITRF=International Terrestrial Reference 
Frame).
All existing ITRF’s are geocentric systems, the center of mass being 
defined for the whole Earth, including oceans and atmosphere.
ITRFs evolve in time because they take into account the tectonic 
motions of the Earth. This is the reason why, when selecting an ITRF, 
you also have to indicate the time when the position of the reference 
station was determined on that ITRF. You have to enter this time in the 
Epoch field, just underneath. Basically, you have to enter the year of 
measurement (e.g. “2000”), but you may also be more accurate on the 
measurement time by entering a decimal figure (e.g. if you enter 
“2000.5”, this means the station position was determined in June 
2000).
The following IRTFs are available in GNSS Solutions: ITRF00, ITRF92, 
ITRF93, RGF93, ITRF94, ITRF96, ITRF97 and NAD83 (CORS96). 
New models can be created in relation to ITRF00 (see Adding a New 
Terrestrial Reference Frame on page 229).
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• Coordinates and Velocity: Use these fields to enter the accurate position 
of the station, as defined on the chosen reference frame. Velocity fields 
are all “0.0” by default.

Local Coordinates (..) pane:

• System Name and Epoch: Non editable fields; show respectively the cur-
rently selected coordinate system in the open project and the current 
year.

• Coordinates: These fields, which also provide the 3-D coordinates of the 
reference station, result from the transformation of the coordinates 
entered in the Reference Coordinates pane into the coordinate system 
used in the project.

- Click OK. The name of the station is now listed in the Stations tab.
- Click OK to complete the “Add Provider” procedure. The new provider is 

now listed in the Reference Station Network window.

- Click to close this window.

By importing a File:

It is assumed that a text file containing all the station parameters is available 
for use and you know how the parameters are arranged in the file (i.e. you know 
which data format is used in the file).

- On the Stations tab, click  in the upper-right corner of the dialog box.
- Choose the data format that the file to import complies with. The default 

formats are those of the default providers, namely IGS, NGS and RGP. If 
none of these formats is suitable, create a new one.

To create a new format, click . For more information on how to create 
a custom format, refer to Creating Custom Formats on page 154.
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- Click OK and then browse your computer to find and select the file to 
import. See example below where the new provider name is “PGCD”.

- Select the terrestrial reference and the default epoch corresponding to the 
station coordinates provided in the file (see definitions on page 225).
The time you enter as “Default Epoch” will be used only if the imported 
file does not contain this information. If the file includes the Epoch infor-
mation, this information will be used in priority and the one you entered 
will be discarded.

- Click the Open button. GNSS Solutions imports the file and then analyzes 
its content. When the file analysis is complete and successful, the name of 
the station appears in the Stations tab.

- Click OK to complete the “Add Provider” procedure. The new provider is 
now listed in the Reference Station Network window.

- Click to close this window.
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Linking a Reference Station’s Log File to its 

Properties Dialog Box

Providers usually post station description files (*.log files) on their web sites 
so you can download them if necessary. Log files provide a large amount of in-
formation about the station (provider, detailed inventory of equipment used 
and their specifications, contact information, etc.).
GNSS Solutions lets you create a link, from the properties dialog box of each 
station, to the corresponding log file saved on the hard disk. By doing this, you 
can easily view the file from the station’s properties dialog box without having 
to remember where you put the file on your computer.
After you have created the link, you can open the log file by simply clicking on 
the log file name in the reference station properties dialog box.

An example of what a log file looks like, when opened from the Properties di-
alog box, is presented below.
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Adding a New Terrestrial Reference Frame

1. From the GNSS Solutions menu bar, select Tools>Terrestrial Reference 
Frames..

2. Click  in the upper right corner of the Terrestrial Reference Frames win-
dow.

3. Enter the following parameters to define a new terrestrial reference frame:
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4. Click OK to create the new TRF.

NOTE: To edit an existing TRF model, click  after highlighting the 
model name in the list.
For more information about the TRF models, go to http://www.iers.org/
MainDisp.csl?pid=42-17 or http://itrf.ensg.ign.fr/ITRF_solutions/
index.php.

Parameter Definition
Name TRF name
Epoch Reference epoch

Parameter Value Variation
T1 Delta x, in millimeters (mm) in mm/year
T2 Delta y, in millimeters (mm) in mm/year
T3 Delta z, in millimeters (mm) in mm/year

D Scale factor deviation, in ppb (in parts per 
billion) in parts per billion/year

R1 Delta x rotation, in milliarcseconds (mas) in milliarcseconds/year
R2 Delta y rotation, in milliarcseconds (mas) in milliarcseconds/year
R3 Delta z rotation, in milliarcseconds (mas) in milliarcseconds/year
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Chapter 14: VRS Data Processing

This chapter is a supplement to Chapter 4: Adding Data Files to a Project on 
page 49 and Chapter 5: Data Processing on page 65.

Introduction to VRS

The VRS processing is more particularly intended for single-frequency 
receivers, such as the Magellan ProMark3, when operated at a fairly long-
distance from the network of closest reference stations. In this case, the VRS 
processing will allow GNSS Solutions to deliver a fixed solution more easily and 
with less observation data than would be obtained through conventional post-
processing using the closest base station.
In GNSS Solutions, VRS (for Virtual Reference Station) is a process used to 
generate a base raw data file, called “VRS” raw data file, for a particular 
control point or observation file in your project.
When you ask GNSS Solutions to compute a VRS raw data file, it’s as if you 
were creating a virtual reference station at the chosen location.
The VRS raw data file is derived from sets of raw data files collected 
simultaneously by different reference stations present around the working 
area. A minimum of three stations is required to run a VRS computation. There 
is no limit to the number of usable stations and you may freely reject those you 
do not want to use.
Stations should not be further than 70 kilometers (44 miles) from the chosen 
location, but by default, GNSS Solutions will pre-select the closest three 
stations, irrespective of whether they meet this requirement.
But if the number of available stations is insufficient, you will have to select 
more stations. For this reason, GNSS Solutions will also list (-but not pre-
select) additional stations that comply with the VRS Max. Range criterion 
(default setting: 200 km, See Creating a New Project on page 35). It will 
therefore be your responsibility to select one or more of these stations to make 
the VRS processing executable.
The process of creating a VRS raw data file always includes the creation of a 
control point associated with this file. This point represents the location of the 
virtual reference station.
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By default, the VRS raw data file will be generated to cover the total duration 
of all the observations present in the project if you selected a control point at 
the beginning of the process, or for the duration of the observation if you 
selected an observation file.

With a “virtual station” located on the survey site, you could instinctively 
deduce that the resulting baseline is always short, not to say “zero” in the case 
of static surveys and so the occupation times may be reduced accordingly. 
Unfortunately this is a wrong statement.
In the VRS processing, the baseline length is in fact tied to the geometry of the 
station network used. That is why the term “Equivalent Baseline Length” is 
used in this case, rather than “Baseline Length”. The equivalent baseline 
length is usually slightly less than the baseline length to the closest reference 
station you involve in the process.
To assess the occupation times required in your post-processing survey, you 
should know the value of equivalent baseline length before going to the field. 
This can be done using GNSS Solutions, which will take into account the 
location of the working area and the number of usable stations as well as their 
geometrical configuration. With this parameter value in mind, you will be able 
to determine when enough data has been collected in your survey.

70 km
VRS M

ax. Range
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Reading Equivalent Baseline Length Before 

Going to the Field

If you intend to use the VRS function during the post-processing phase of your 
survey, it is essential that you be aware of the equivalent baseline length before 
going to the field. By doing this, you will know when to stop collecting data by 
simply monitoring the right indicator on your surveying equipment.
Follow the instructions below to read the equivalent baseline length for a given 
site:
- Create a GNSS Solutions project
- On the Survey view, create a control point located approximately at the 

center of your working area.
- Select the control point
- Select Project>Compute VRS. A window opens showing the network of 

usable stations in your working area. Note that the three closest stations 
have been pre-selected.

- Review the list of selected stations, looking at the distance that separates 
each of them from the control point, and modify the list if needed by clear-
ing or checking on the corresponding button.

- When you agree with the list, read the value of the equivalent baseline 
length located just underneath the station network diagram.

- Write down this value, which you will have to remember when performing 
your survey.
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Generating a VRS Raw Data File

Back in the office with several observation files collected in the field, do the 
following to compute a VRS raw data file:
- Download the observation files to your project.
- Select one of the observation file icons on the Survey view.
- Select Project>Compute VRS. the Create VRS window looks like this:
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- Choose the closest reference stations (see table above).
- Click on the Download All Raw Data Files button (see table above) to gather 

all the raw data needed to compute a VRS raw data file.

Field Definition
Name that will be given to the control point associated with the VRS raw data 
file once created (user-settable)
Name that will be given to the VRS raw data file once created (software-set).
NOTE: VRS raw data files use naming conventions similar to those of usual 
raw data files (B-files). The only difference is the presence, just after the letter 
“B”, of the term “VRS” followed by an index number, in lieu of the 4-character 
receiver ID.

East, North, 
Ellips Height Autonomous GPS position solution attached to the observation file

Start Date Date when observation file was created
Start Time Time when observation started
Duration Duration of observation

Antenna Type of antenna used by the virtual station. <NONE> is the correct option for 
this parameter.

Equivalent 
Baseline

Gives the length of the equivalent baseline for the VRS raw data file, taking into 
account the current selection of reference stations.

“From 
Reference 

Stations” List

Lists all the reference stations around the location of the observation file. Only 
the closest three ones are preset. Other listed stations are within the distance 
criterion given by the VRS Max. Range parameter.
For each station, the following information is provided:
• Station name
• Distance from selected observation file
• Name of raw data provider

Download All 
Raw Data Files 

button

Once you have defined the list of reference stations, click this button to start 
downloading raw data from each of these stations.
For each selected station, the following messages are returned as the down-
loading is in progress: Searching, downloading, uncompressing, merging, con-
verting, importing, etc.
The File and Antenna type columns are completed following import. A warn-
ing message will appear if the parameters of the detected antenna type are all 
“0”. In this case you will have to define these parameters by clicking in the cell 
to the far right.
235



14 VRS Data Processing
Generating a VRS Raw Data File
Below is an example of what the VRS window might look like at the end of 
the download step:

- Click OK to start computing the VRS raw data file.
At the end of this processing step, a greyed diskette icon appears on the 
Survey view, representing the VRS raw data file, as well as the associated 
control point.

Note that during this step, a “VRS..” folder was created in the project 
folder to save all the data files from the different stations involved in the 
VRS computation.
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Processing Field Data with a VRS Raw Data File

After the VRS raw data has been created, GNSS Solutions automatically 
updates the processing scenarios, adding the new baseline(s) resulting from 
the new observation file and control point.
- Select Project>Process Options.
- In the Process Options window, read the new baseline(s) resulting from the 

new observation file and control point.
- Highlight a new baseline you would like to process by clicking in the corre-

sponding cell on the far left. For example, select the baseline that con-
nects the VRS raw data file to the observation file for which it was 
generated.

- Click OK>To Save and Process selected Baselines. GNSS Solutions computes 
the vector.

- Go to the workbook and read the results of the processing.
In the Vectors tab, you will see the components of the computed vector. In 
our example, the computed baseline length should be about a few meters, 
reflecting the uncertainty on all positions computed in autonomous GPS 
mode.
In the Points tabs, you will see the accurate coordinates of the point 
attached to your observation file.
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Appendix A: Mission Planning Utility

Introduction

Mission Planning allows you to know which GPS satellites should be visible from 
a given observation point on the surface of the Earth, and for a given period of 
time (max. 24 hours). The World Map editor (see below) allows you to quickly 
define an observation point.

Mission Planning uses almanac data sent by GPS satellites to perform a predic-
tion. Each set of almanac data provides the orbital parameters for the whole 
GPS constellation. Almanacs are assumed to be valid for a period of time cen-
tered around a reference time called TOA (Time Of Almanac). The closer to the 
time of prediction the TOA of the chosen almanacs, the more reliable the pre-
diction.
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Introduction
Mission Planning allows you to import new sets of almanac data saved in Magel-
lan proprietary formats (SFIX, SVAR or SBIN), or of the following type: 
SEM<Week No.>.TXT (almanac files downloaded from the US coastguards site: 
www.navcen.uscg.gov).
 Mission Planning can also display the set of almanacs used (see below).
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Mission Planning produces the following views to help you analyze the results of 
the prediction:

At Time Schedule Range

Doppler Elevation Azimuth

Polar GDOP
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Almanacs used in the prediction
Mission Planning also allows you to edit curtains and to apply them to the ob-
servation point (see below and Curtain editor on page 267). A curtain is a pat-
tern representative of the obstructions around the observation point and liable 
to disturb the reception of GPS signals at this point.

Almanacs used in the prediction

Opening a set of almanacs
When launching Mission Planning, the set of almanacs last loaded is used. To 
open a new set of almanacs:

- Click on , or in the menu bar, select File>Open. A dialog box opens 
showing the list of some of the almanac files stored in the Raw directory.

- In the lower part of this box, specify the format of the almanac file you 
would like to open. The possible choices are:

- ASCII (*.raw)
- Binary (*.bin or *.dXX)
- Ashtech almanac files (a*.*)
- SEM almanacs from the US coast gards (Sem*.txt)

- Choose the desired set of almanacs from the files list, then click Open to 
load it.
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Importing a new set of SEM-type almanacs
Using this function requires that your PC can be connected to the Internet.
- In the menu bar, select Help>Get Almanacs. A new dialog box opens asking 

you to confirm the address of the US coast guards site (currently 
www.navcen.uscg.gov) with direct access to the almanac page /ftp/GPS/alma-
nacs/ sem/

- Click OK to launch your Internet browser, which then automatically con-
nects to the requested site

- Choose the desired set of almanacs from the list and then display it on the 
screen

- Save this set of almanacs as a TXT file in your local Raw directory then 
leave the site.

To use this new set of almanacs, open it in Mission Planning as explained pre-
viously.
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Viewing the set of almanacs used
- On the menu bar, select View>Almanac. The main window then shows the 

set of almanacs currently used in the form of numerical data. Click on Page 
Up or Page Down, or on the corresponding keys on the keyboard, to view the 
almanac for the next or previous satellite (each screen provides the orbital 
parameters for a single satellite).

Example of almanac for satellite No.1 at the specified date and time:
 

Defining the observation point

When launching Mission Planning, a prediction for the last selected observation 
point is run.
You can preset the observation point from the GNSS Solutions window by doing 
the following:
- Select the desired observation point in any of the open documents (table, 

map, etc.)
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- Press F2. This automatically launches Mission Planning. The selected 
point in GNSS Solutions then becomes the observation point in Mission 
Planning.

The parameters defining an observation point are its name, its WGS84 coordi-
nates (Lat/Lon/Alt), and the curtain placed on this point.
The definition of an observation point can be saved to be used at a later date.
To define the observation point:

- Click on , or on the menu bar, select Edit>Site and complete the follow-
ing fields:
Site: Give a name to the observation point
Lat, Long: Enter its latitude and longitude:

- By completing manually the Lat and Long fields 
- Or by using the World Map Editor located on the right. This tool allows 

you to complete automatically the previous two fields by selecting the 
point graphically on the surface of the globe (see World Map editor on 
page 264)

- Alt: Define the point’s altitude by completing manually this field
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Local Obstructions button: This button provides access to the Curtain Editor, 
which you can use if you wish to define a curtain around the observation 
point. A default curtain exists which consists of all the space between 0° 
elevation and the minimum elevation angle above which satellites are 
used. See Curtain editor on page 267.
Load... button: Allows you to select an observation point saved earlier as a 
Pos file in order to use it as the current observation point
Save... button: Allows you to save the current observation point as a *.Pos 
file (stored in Pos directory) for further use.
Dialog box allowing you to define an observation point:

Use of Curtain Editor: see Curtain editor on page 267
Use of World Map Editor: see World Map editor on page 264

Curtain Editor World Map Editor
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Defining the date & time of prediction

When launching Mission Planning, a prediction for the current date & time is 
automatically computed.
The parameters defining a time of prediction are the date (month, year, day) 
and the start & end times (max. observation time span: 24 hours).
To define a new date & time of prediction:

- Click on , or on the menu bar, select Edit>Epoch and select the follow-
ing in the dialog box that opens:
Date: Select month, year and date of prediction
From: Enter start time of prediction
To: Enter end time

- Click OK to complete the definition.

Dialog box allowing you to define the date & time of prediction:
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Defining a moment within the prediction

You can define a particular moment within the prediction time span:

- Click on  or on the menu bar, select Edit>Cur. Time
- In the lower-right corner, specify the interesting moment (in hours, min-

utes, seconds)
- Click OK to complete the definition.

Dialog box allowing you to define a particular moment within the predic-
tion:

 This particular moment in the prediction can be shifted graphically on any pre-
diction view. See Redefining a specific moment in the prediction on 
page 260.
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Defining the local/ UTC time deviation

This deviation identifies the time zone in which the observation point is locat-
ed.
To change this deviation:
- On the menu bar, select Edit>Time Zone
- Select the working area in the Zone field

You can also enter a deviation expressed in hours, minutes and seconds by 
selecting the “UTC+HH:MM:SS” option in the Zone field, and then by 
entering the value of time deviation in the HH:MM:SS field shown just below

- Click OK to complete the definition.

Dialog box allowing you to define the local/UTC time deviation:
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Prediction results

Prediction results are provided in the form of graphs called “views”. Apart from 
the At Time and Polar views, all the views use an axis system with the prediction 
time span represented along the X axis (a linear scale is used and each gradu-
ation represents 1/10th of the total prediction time span). Along the Y axis are 
represented the possible values of the displayed parameter which may be one 
of the following:
- On Schedule View: SV No. (1 to 32) AND No. of visible satellites
- On Range View: distance from 20 000 to 26 000 km
- On Doppler View: Doppler from -1000 to +1000 m/s
- On Elevation View: Elevation angle from 0 to 90°
- On Azimuth View: azimuth angle from 0 to 360°
- On DOP View: DOP from 0.1 to 100 (logarithmic scale)

The Polar view uses polar coordinates as suggested by its name. The At Time 
view provides numerical data for one given moment chosen in the prediction.
To select a view:
- Select View>[View Name] or, after placing the mouse cursor anywhere within 

the display zone, choose it from the menu displayed after a right click on 
the mouse.

The following information is provided in each view subtitle:
- Label & XYZ coordinates of the observation point (1st line)
- Prediction start & end times (2nd line) 
- Validity date of the almanac data used in the prediction, minimum eleva-

tion angle and presence or absence of a curtain (3rd line).
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“At Time” view
The “At Time” view lists the positions of the visible satellites from the obser-
vation point, for the moment chosen in the prediction.

Example of “At Time” view:
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“Schedule” view
This view shows the times when each satellite is visible, as well as the total 
number of visible satellites at any given time within the prediction.
The period of time during which a satellite is visible is represented as a bold 
horizontal line. The red multi-line is representative of the total number of vis-
ible satellites at any time during the prediction. Grey lines, if any, indicate un-
healthy satellites.

Example of “Schedule” view:
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“Range” view
This view shows the variations of distance between each of the visible satellites 
and the observation point.

Example of “Range” view:
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“Doppler” view
This view shows the variations of speed for each of the visible satellites with 
respect to the observation point.

Example of “Doppler” view:
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“Elevation” view
This view shows the variations of elevation for each of the visible satellites dur-
ing the prediction.

Example of “Elevation” view:
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Prediction results
“Azimuth” view
This view shows the variations of azimuth for each of the visible satellites dur-
ing the prediction.

Example of “Azimuth” view:
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“Polar” view
This view shows the orbit of each of the visible satellites above the observation 
point, for the whole prediction time, as well as the planned position of each of 
these satellites for the chosen moment. The view uses polar coordinates:
- Center of concentric circles: location of observation point
- From center to larger circle: elevation angle, from 90° to 0° respectively 

(each new circle represents 10° in elevation)
- The angular space between any two adjacent lines represents 30° in azi-

muth; graduated clockwise from 0 to 360°.

Example of “Polar” view [Azimuth=f(elevation)]:
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“GDOP” view
This view shows the variations of the selected DOP as a function of the fix com-
putation envisaged on the observation point:
To select which DOP parameter to plot:
- Select Options>DOP... >[Parameter Name] The possible choices are:

- GDOP: Geometric Dilution Of Precision
- PDOP: Position Dilution Of Precision
- HDOP: Horizontal Dilution Of Precision
- VDOP: Vertical Dilution Of Precision
- TDOP: Time Dilution Of Precision

Define the type of fix computation envisaged at the observation point so that 
Mission Planning can determine the corresponding DOP values:
- Select Options>3D+T or Options>2D+T

2D+T should be chosen if the altitude is known and constant throughout 
the working area around the observation point, otherwise choose 3D+T. In 
2D+T only 2 position unknowns, instead of 3, are involved in the GDOP 
computation. This naturally results in better (lower) GDOP figures.

Example of “GDOP” view:
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Displaying 4 or 2 different views at the same time 
- Select View>Split and then click in the middle of the window with the left-

mouse button. The window is split into 4 areas, each of them showing a 
different view of the prediction.

Example of a screen showing 4 different views at the same time:

- To choose a different view in an area, position the mouse cursor anywhere 
within the area and then select the desired view from the menu displayed 
after a right click

- Switching to two views and then back to a single view are simply obtained 
by dragging the concerned border out of the window or by double-clicking 
on it.
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Copying or printing the active view

- Click on  or select Edit>Copy to copy the active view to the clipboard so 
you can paste it in a document created with another program. In the case 
of several views displayed concurrently, the active view is merely the one in 
which you have last clicked.

- Click on  or select File>Print Preview to preview the active view

- Click on  or select File>Print to print the active view.

Redefining a specific moment in the prediction
For all views on which the X axis represents the total duration of prediction, 
the specific moment (see Defining a moment within the prediction on 
page 248) is denoted by a marker (a down-arrow):

This marker may be shifted towards the beginning or the end of the prediction 
using one of the following methods. Whatever the method you use, the Current 
Time dialog bow will always be updated following this operation.
1. By directly clicking inside the graph where you would like the marker to be 

located
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2. Using the following buttons on the toolbar:

- Click on  to move the marker one step forward
or

- Click on  to move the marker one step backward.

3. Using the following buttons on the keyboard:
- A short press on the "+" key (numeric keypad) will move the marker 

one step forward. A long press will cause the marker to move forward 
until you release the key.

- A short press on the "-" key (numeric keypad) will move the marker 
one step backward. A long press will cause the marker to move back-
ward until you release the key.

The specific moment in the prediction can also be changed on the At Time or 
Polar views using the 2nd or 3rd method described above.

Changing the prediction options

Deselecting satellites

- Click on  or, on the menu bar, select Options>Svs... A dialog box opens 
allowing you to modify the set of satellites involved in the prediction.
The first time you display this box for any given prediction, all visible satel-
lites have been selected to be used in the prediction. Satellite numbers 
(PRN) shown in black letters stand for the visible satellites whereas those 
in white stand for the non-visible ones. All buttons are in the “OFF” posi-
tion (i.e. released). The changes you can make are the following:

- Deselecting a satellite: depress the corresponding button
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- Deselecting all satellites: click on the All button
- Re-selecting a satellite (that you have previously deselected): click on 

the corresponding button (which then comes back to the “OFF” posi-
tion)

- Re-selecting the complete set of visible satellites: click on the None 
button.

Example of settings on the SVs Deselection box:

In this example, satellites No. 12, 16 and 32 are not visible, satellite No. 22 is vis-
ible but deselected, satellite No. 32 is not visible and furthermore is deselected. All 
other satellites are visible and used.

Changing the minimum elevation

- Click on  or, on the menu bar, select Options>Elev Min... A dialog box 
opens allowing you to change the value of the minimum elevation angle 
under which any satellite should be seen from the observation point for it 
to be used in the prediction.
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Minimum Elevation dialog box:

Applying / removing the curtain

- Click on  or, on the menu bar, select Options>Use curtain. A dialog box 
opens in which you can apply (button depressed) or remove (button 
released) the curtain defined on the observation point.
The curtain, which is part of the observation point definition (see Defining 
the observation point on page 244), describes an angular area seen from 
the point. All GPS signals received from that area will NOT be used.
The presence of the curtain (size and shape shown on the Polar view, 
impacts most of the other views in the prediction.
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World Map editor

The World Map editor shows the planet Earth. From this view, you can select 
any point on the surface of the Earth where you would like to run a prediction. 
The World Map editor is equipped with a number of functions allowing you to 
access this point.

Example of a view obtained with the World Map editor:

Rotating the Earth
If the visible part of the World Map editor does not show the desired observa-
tion point, do the following:
- Position the mouse cursor anywhere on the globe
- Right-click on the mouse and select Grabber.

The mouse pointer now looks like this:
- Hold down the mouse left button and drag in the direction that would bring 

the desired point on the visible part of the globe. When you release the 
mouse button, this will cause the globe to rotate around its axis by an 
angle proportional to the distance traveled by the mouse pointer while 
dragging.
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Zooming in
- Position the mouse pointer anywhere on the globe
- Right-click on the mouse and choose Zoom in.

The mouse pointer now looks like this:
- Position the mouse pointer on the globe where you would like to zoom in, 

and then click on the left button. This causes the region to be magnified. 
The center point of the magnified view is in fact the point where you have 
just clicked
You can repeat this operation several times (as long as the mouse pointer is 
a “+” magnifying glass). From the initial view showing all the globe, up to 
6 successive zoom-in operations can be performed.

Zooming out
- Position the mouse pointer anywhere on the globe
- Right-click on the mouse and choose Zoom out.

The mouse pointer now looks like this:
- Position the mouse pointer on the globe where you would like to zoom out, 

and then click on the left button. This causes the region to be reduced in 
size. The center point of the reduced view is in fact the point where you 
have just clicked.
You can repeat this operation several times until the entire globe can be 
seen on the screen.

Selecting a point
Once the globe is large enough to make a visual estimate of the desired obser-
vation point on the globe’s surface, do the following:
- Position the mouse pointer anywhere on the globe
- Right-click on the mouse and choose Draw.

The mouse pointer now looks like this:
- Position the mouse pointer very accurately on the desired point, then click 

on the left mouse button to define this point.
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The Lat & Long fields in the dialog box are then updated to reflect the exact 
coordinates of the point you have just selected. Note that the Alt field is 
left unchanged. This parameter should be defined manually by typing its 
value directly in the field.
On the globe, the selected point is shown as a red dot whose size is inde-
pendent of the zoom setting.

Globe Viewing Options
- Position the mouse pointer anywhere on the globe
- Right-click on the mouse and choose Options. A dialog box opens in which 

you can change the globe viewing options. The defaults for these options 
are the following:

The available 4 resolutions are:
- low
- medium
- high
- very high
The higher the resolution, the more accurate the details on the globe surface.
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Curtain editor

What is a curtain?
Seen from the observation point, some directions in space may exist in which 
GPS reception for some reason is bad. The concept of curtain is introduced 
specifically to describe these particular directions so that the signals received 
from this region of space can be curtained if necessary.
For a given observation point, the curtain consists of one or more obstruction 
zones seen from this point. Each obstruction zone is defined in relation to Az-
imuth (Az) and Elevation (Ev).
A curtain may be drawn on a polar view centered on the observation point, or 
on linear view showing elevation vs. azimuth. Once the curtain is drawn on a 
view, it is also visible on the other.
A curtain may also be defined by specifying each of the points making it up. 
As a result, the curtain also appears on the two views as if it had been drawn.
On the chart, the area located between Elevation Angle 0° and the user-set Min 
Elev angle (see bottom of the tab) is considered as part of the curtain (also 
shown in blue).
When you enable the curtain in a prediction computation, you allow the appli-
cation to behave as if there were no GPS signals received in the curtain's di-
rection.

Accessing the curtain editor for a given observation point

- Click on , or in the menu bar, select Edit>Site
- Define the observation point, or load it if it has already been defined and 

saved
- Click on the Local Obstructions... button.
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Changing the curtain view 
- Position the mouse pointer anywhere on the curtain editor
- Right-click on the mouse and select the linear or polar view.

Drawing a curtain
- Position the mouse pointer anywhere on the chart and click with the right 

mouse button
- In the shortcut menu that pops up, select the Draw command.

The mouse pointer then changes to 
- Position the mouse pointer on the desired location, referring to the Az and 

Ev indications, and click with the mouse to begin drawing the curtain.
- Move the mouse pointer to reach the next point. Note the curve that results 

from the pointer displacement (a straight line on the Linear view, an arc on 
the Polar view). Once you have reached the next point, click with the 
mouse again, etc.

- If you need to go through the 0/360° or 360/0° limits while you draw an 
obstruction zone, move the pointer outside the chart. This causes the hori-
zontal scale to move accordingly so long as you keep the pointer outside 
the chart.

- To complete the curtain definition, double-click on the last point. As a 
result, the curtain appears in blue as a closed shape, even if the last point 
is not superimposed on the first one. On the Linear view, the curtain is 
always a polygon, on the Polar view it is a close shape composed of several 
arcs.

- After completing the definition of the obstruction zone and if you want to 
restore a 0/360° normal non-shifted scale (if appropriate), choose the 
Select command from the pop-up menu and then simply double-click 
inside the chart area with the left-hand mouse button.
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Editing a curtain manually
After accessing the curtain editor chart:
- Position the mouse pointer anywhere on the graph and click with the right 

mouse button.
- In the shortcut menu that pops up, select the Edit Curtain command.
- In the dialog box that appears, specify the points delimiting the obstruc-

tion zone(s).

Curtain pane:
- List box: Shows the number of obstruction zones defined to form the cur-

tain for the concerned site. Obstruction zones are numbered from 1 to n. 
The definition of the selected obstruction is shown in the right-hand part 
of the box

- Add button: Press this button to add a new obstruction zone in the above 
list box 

- Delete button: Press this button to delete the obstruction zone selected in 
the above list box.
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Point {x/x} pane:
- Azimuth: Azimuth angle for the displayed point
- Elevation: Elevation angle for the displayed point
- Right from previous point: Check this button if you want the position you are 

defining to be somewhere on the right of the previous point (this choice 
will force the extension of the obstruction zone to the right of the previous 
point even if the azimuth angle of the new point is less than that of the 
previous one; this allows you to go through the 360/0° singular value).

- Align with previous point: Check this button if you want the position you are 
defining to be aligned with the previous point (i.e. same azimuth)

- Left from previous point: Check this button if you want the position you are 
defining to be somewhere on the left of the previous point (this choice will 
force the extension of the obstruction zone to the left of the previous point 
even if the azimuth angle of the new point is greater than that of the previ-
ous one; this allows you to go through the 0/360° singular value)

- Add button: Click this button to add a point to the definition of the 
obstruction zone. As a result, the total number of points (see top of dialog 
box) is incremented by one 

- Insert button: Click this button to add a point to the definition of the 
obstruction zone. The new point is inserted into the list of points just 

before the displayed point. As a result, the total number of points (see top 
of dialog box) is incremented by one

- Delete button: Click this button to delete the point displayed above
- OK button: Click this button to validate the entire box content
- Cancel button: Click this button to cancel all the changes you have made to 

the box since you opened it.
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Moving, re-shaping or deleting a curtain
- Position the mouse pointer anywhere on the graph and click with the right 

mouse button
- In the shortcut menu that pops up, choose the Select command
- Select the curtain by clicking the mouse pointer inside the drawing object 

(a selected curtain displays handles) then:
- Drag this object to move the curtain
- Or drag each of its handles successively to re-shape it
- Or press the Del key to delete it. 
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Appendix B: WinComm Utility

Introduction

WinComm allows you to communicate with GPS receivers by offering the follow-
ing functions:
- Automatic search for baud rate to be used (on operator's request, only with 

Magellan receivers)
- Identification of the connected GPS receiver (on operator's request, only 

with Magellan receivers)
- Viewing the data stream on the serial port
- Sending commands to the GPS receiver
- Manual request for recording data from the GPS receiver
- Programmable requests for recording data from the GPS receiver.

WinComm main window:
273



B WinComm Utility
Enabling communications with a GPS receiver
Enabling communications with a GPS receiver

After you start WinComm or click the Settings button in the WinComm main win-
dow, the Communication Settings dialog box shows up. This dialog box allows you 
to view and change the serial port parameters of your computer and enable 
communications with the GPS receiver connected to it.

Communication Settings Dialog Box:

You can save your customary communications settings to a configuration file 
(using the Save Settings button) and specify the configuration file name in the 
command line of any shortcut created to start WinComm. As a result the con-
figuration file will automatically be loaded and enabled when you double-click 
the WinComm icon to start WinComm (in that case the Communication Settings 
dialog box will not be prompted).
Use the combo boxes to set the communication parameters. The parameters 
are preset to default values. Select the desired port (Comm parameter), that is 
the computer port connected to the desired GPS receiver and the appropriate 
serial communication parameters (baud rate, etc.) to match those of the re-
ceiver.
With Magellan receivers, the baud rate will be adjusted automatically if you use 
the Auto Configure button.
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OK button
Clicking the OK button activates the current serial port parameter settings and 
closes the Communication Settings dialog box. This enables communications be-
tween the computer and the GPS receiver, unless the serial port parameter set-
tings do not match those of the receiver connected.

Cancel button
Clicking the Cancel button closes the Communication Settings dialog box. Any 
changes you made in this dialog box are ignored.

Auto Configure button
Auto Configure initiates an automatic search for the baud rate and receiver type. 
Use this button if you are not sure about the baud rate or if you wish to view 
the type of the receiver connected.
An automatic search for the baud rate and receiver type is only allowed with 
Magellan receivers as this requires that the receiver be capable of returning a 
consistent reply to a "TEST 1" or "IDENT" command.
After choosing Auto Configure you are allowed to:
- Disable the communication by clicking Cancel
- Or, if the identification is successful, close the Communication Setting dialog 

box, by clicking OK. This enables communications between the computer 
and the GPS receiver and allows you to use any of the WinComm functions.
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Receiver Type 
After communication is successfully established (e. g. using the Auto Configure 
button), the identification of the connected receiver appears in this box.
The example below results from a communication established with a Magellan 
receiver.

After the Communication Settings dialog box is closed, you can ask for the re-
ceiver type by sending the TEST 1 or IDENT command to the connected re-
ceiver, using the Command pane.

Load settings button
Load settings opens a dialog box that allows you to select any serial port config-
uration file saved earlier using the Save Settings button.
Click the desired file name in the list box, to select it (typically in the 'set' di-
rectory), and click Open. As a result the serial port parameters in the Commu-
nication Settings dialog box are automatically set as specified in the file you 
selected.
(Clicking Cancel would take you back to the Communication Settings dialog box).
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Save settings button
Save settings opens a dialog box that allows you to save the serial port configu-
ration currently enabled so that you can quickly retrieve it at a later date using 
the Load Settings button. It can be loaded automatically if you specify its name 
in the command line of any shortcut icon created to start Wincomm.
In the File Name text box, enter a name (e.g. the type of the receiver connected) 
for the file to which the serial port configuration should be saved (typically with 
'.set' as the extension name and saved to the 'set' directory).
Clicking the Save button saves the following communication parameters: 
- Serial port No.
- Baud rate
- Number of bits per character
- Parity check option
- Number of stop bits

(Clicking Cancel would take you back to the Communication Settings dialog box 
without saving any settings).

System Menu

- In the left corner of the WinComm window's title bar, click on the connector 
icon. The system menu appears from which you can define the options 
below.

- All Commands Uppercase: Unless you are satisfied with the current set-
ting, select this command to toggle the setting.
Checked: lower-case characters in the command are changed to 
upper-case characters before being sent to the receiver
Cleared: characters, whether lower-case or upper-case, are sent 
unchanged.
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- No Internal Memory: Command not used with the new range of receiv-
ers. Unless you are satisfied with the current setting, select this com-
mand to toggle the setting.
Checked: there is no internal memory in the attached receiver (Internal 
Memory Reader option disappears from the Win Comm window). Always 
make this choice with the current range of receivers.
Cleared: there is an internal memory in the attached receiver (Internal 
Memory Reader option available in the Win Comm window).
278



WinComm Utility
Display area

W
in

C
o
m

m

Display area

After communication is enabled between the computer and a GPS receiver the 
Display pane allows you to view the data stream on the receiver port, including 
data output in response to any command generated by Wincomm.
If you wish to enlarge the Display pane, click  in this pane (top right). This 
causes the pane to be transformed into a separate window which you can move/
re-size using the usual commands assigned to windows in the Windows envi-
ronment.
To restore the Display pane at the initial location, click  or  (top right).

Display area defined as a separate window:

As the data may be refreshed every 0.1 seconds, it is not possible to log all 
that flows through the port so that it can be displayed at a later date, or this 
would require a huge memory size. For that reason, only the latest 100 data 
lines are stored and can be viewed using the vertical scroll bar available.
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Each data line ends with <CR><LF> characters and/or when it reaches the 
maximum length (80 characters).

Clear View: Clicking this button deletes any data displayed in the Display 
pane / window.
Print View: Clicking this button opens a Print dialog box that allows you to 
print any data displayed in the Display pane/window.
Pause: Freezes the Display pane/window and changes the label of the but-
ton to Resume.
Pressing the Pause button does not suspend the data flow on the receiver 
port or the recording in progress.
Pressing this button again (now changed to a Resume button) will re-acti-
vate the Display pane/window.

Sending a Command to the GPS receiver

After communication is established between the computer and the GPS receiv-
er, the Command pane can be used to send commands to the receiver (label of 
selected command group recalled in the command pane, see example below).

To send a command, do the following:
- Type the command in the Command combo box or select it from the Com-

mand or Label combo box.
- Click the Send button.
The list of commands prompted in the Label combo box can be changed using 
the Advanced... button.

Command box Label box
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Commands editor dialog box
This dialog box (appearing after you click the Advanced button) allows you to 
set up a group of commands interpretable by the connected receiver. The com-
mands you select in this dialog box will be prompted in the main window. As 
a result, you will only need to choose the desired command from the list in the 
main window and click to send the command to the receiver.
After you install WinComm, a number of default command groups are available 
on your computer. Each command group is contained in a file whose name is 
the Group Label (see this parameter in the next page), with .cmd as extension.
The buttons in the Commands Editor dialog box allow you to load any command-
group file available, make any change to the group and save your own com-
mand groups.
The selected command group will be available in the main window after you 
close the Commands Editor dialog box (by clicking in the upper-right corner).

Group Label: Used to enter and/or view the name given to a command 
group. For example, this name can suggest the type of receiver connected 
when this command group should be used

Click here to close the Com-
mands Editor dialog box. This 
loads the selected command 
group to the main window.
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Command: Used to enter and/or view each command script. Use the associ-
ated scrollbar to browse through the list of available commands
Label: Used to enter and/or view a plain label for each command script. 
Use the associated scrollbar to browse through the list of available com-
mands
Add command: Adds the command viewed in the text box to the list of avail-
able commands.
Delete command: Removes the command viewed in the text box from the list 
of available commands.
Load commands: Opens a dialog box that allows you to choose the appropri-
ate command group file for the connected receiver. The command group 
becomes available in the main window after you close the Commands Editor 
dialog box.
Save commands: Opens a dialog box that allows you to save your own com-
mand group (as viewed in the Commands Editor dialog box).
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Simple GPS recorder

All data output from the receiver's port is viewed in the main window's Display 
pane/window. The data can be recorded to the file specified in the File Name 
and Directory text boxes.
When the Simple GPS Recorder option is activated, you start and stop the record-
ing manually, by simply clicking the Start/Stop Recording button.

File Name: Used to specify the name of the file to which you wish to record 
the data from the receiver.
Unless a maximum size is selected for the file, you are also allowed to 
enter an extension into the associated box.
File Max Size: Used to specify whether a single file should be created on the 
disk (No Limits option) or the file should be split into 0.7 MB or 1.4 MB 
segments with an option to store it on floppy disks.
If you elect to split the file into segments, then the system will automati-
cally add “001” as extension to the name of the first segment. This will 
automatically be incremented for each file segment generated, if the file 
exceeds the selected File Max Size.
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Start Recording: Clicking this button opens a new dialog box in which you 
can specify which type of raw data you would like to record, if any, before 
you effectively enable data recording.

Then click on the OK button to start the data recording.
The data recording will take place until you click on the Stop Recording but-
ton (this button is in fact the Start Recording button which is renamed once 
data recording is in progress).

(DSNP receivers only) Choose the type of raw data that you would 
like to insert into the record file(s). Choose also the format for the se-

lected data as well as the port on which the data will be available.

The resulting command ($PDAS or other) is automatically formatted 
in this area according to your choices

If necessary, edit other commands that you would like the recorder to run after the above one. 
This requires good knowledge of the different commands possible as well as their syntax. You 
can save your lists of commands as a BAT file (using the Save button) and load them quickly 

later on, using the Load button.
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Programmable GPS recorder

The Programmable GPS Recorder option allows you to prepare one or more re-
quests for recording the data output on the connected receiver port, by speci-
fying a start date, time and duration for each planned recording session, and 
also a disk file name, directory and maximum size.
You can save the recording session requests you prepare (using the Save but-
ton) so that you can load them back at a later date (using the Load button).

Directory: Used to specify the directory to which you wish to record the data 
from the receiver. Clicking the button to the right opens a dialog box that 
allows you to navigate through the directory tree on your hard disk or a 
floppy disk, and select the desired destination directory.
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File Name: Used to specify the name of the file to which you wish to record 
the data from the receiver.

- If you choose the Automatic File Name option (i. e. if the option box is 
checked), then the File Name text box is dimmed and the name is 
automatically assigned by the system, based on the date (month, day 
number) and time (hour, minute) of the recording session. Example: 
12240929 for a file recorded on December 24 at 9:29 a.m

- If you do not select the Automatic File Name option, then you can enter 
a name of your own. Unless a maximum size is selected for the file, 
you are also allowed to enter an extension into the associated box.

   
File Max Size: Used to specify whether a single file should be created on the 
disk (No Limits option) or the file should be split into 0.7 MB or 1.4 MB 
segments (with an option to store it on floppy disks)
If you elect to split the file into segments, then the system will automati-
cally add “001” as extension to the name of the first segment. This will 
automatically be incremented for each file segment generated, if the file 
exceeds the File Max Size selected
Start Date: Used to specify the day on which the recording session should 
begin. The current date is prompted by default 
Start Time: Used to specify the time when the recording session should 
begin. The current time is prompted by default
Duration: Used to specify the planned duration of the recording session
Automatic File Name: If you choose the Automatic File Name option (i. e. if the 
option box is checked), then the File Name text box is dimmed and the 
name is automatically assigned by the system, based on the date (month, 
day number) and time (hour, minute) of the recording session. Example: 
12240929 for a file recorded on December 24 at 9:29 a.m
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If you do not select the Automatic File Name option, then you can enter a 
name of your own. Unless a maximum size is selected for the file, you are 
also allowed to enter an extension.
Add Request: This button saves the recording session description currently 
displayed and increments the number of programmed sessions that 
appears at the bottom of the scrollbar. (This automatically selects the Auto-
matic File Name option and prompts the next possible session, considering 
the specified duration).
Delete Request: This button deletes the recording session description cur-
rently displayed and decrements the number of programmed sessions that 
appears at the bottom of the scrollbar.
Run Program: This button activates the Programmable GPS Recorder mode. 
First, a new dialog box appears in which you can specify which type of raw 
data you would like to record, if any, before you effectively enable data 
recording.
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(DSNP receivers only) Choose the type of raw data that you would 
like to insert into the record file(s). Choose also the format for the se-

lected data as well as the port on which the data will be available.

The resulting command ($PDAS or other) is automatically formatted 
in this area according to your choices

If necessary, edit other commands that you would like the recorder to run after the above one. 
This requires good knowledge of the different commands possible as well as their syntax. You 
can save your lists of commands as a BAT file (using the Save button) and load them quickly 

later on, using the Load button.
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Then click on the OK button. This causes WinComm to wait for the next 
scheduled recording session and perform recording as planned. The label 
of the button changes from Run Program to Stop Program. Until the planned 
recording is complete or you click Stop Program, all other buttons in the 
Programmable GPS Recorder pane are inactive and you cannot change to 
another Mode.
Load Program: This button opens a dialog box that allows you to select a file 
(typically a .pgm file) containing descriptions of planned recording ses-
sions (saved earlier using the Save Program button). Select the desired file 
name and click Open.
Save Program: This button opens a dialog box that allows you to save 
descriptions of planned recording sessions so that they can be used at a 
later date (using the Load Program button). Enter a name into the File Name 
text box and click Save.
Print Program: This button opens a Print dialog box that allows you to print 
the descriptions of planned recording sessions currently loaded.
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WinComm shortcut

You can save your customary communications settings to a configuration file 
and specify the configuration file name in the command line of any shortcut 
created to start WinComm. As a result the configuration file will automatically 
be loaded and enabled when you double-click the WinComm icon to start Win-
Comm (in that case the Communication Settings dialog box will not be prompted).
To create a WinComm shortcut icon that will automatically load one of your cus-
tomary communications configuration files, do the following:
- With the mouse right button, click outside any window in the workspace. 

From the menu that pops up, select New then Shortcut. This opens the Cre-
ate Shortcut dialog box.

- Click the Browse button. This opens a dialog box that prompts all the direc-
tories existing on your disk. Open (by double-clicking) the directory con-
taining WinComm.

- Click WinComm.exe and click the Open button (or simply double-click Win-
Comm.exe). This closes the Browse dialog box and automatically enters Win-
Comm.exe (with its path) into the Command line text box in the Create 
Shortcut dialog box.

- In the Command line text box, enter the name of your configuration file after 
WinComm.exe, with a space between WinComm.exe and the file name.

- Click the Next button. Enter a name for your shortcut icon. Click the Finish 
button. This closes the Create Shortcut dialog box.

As a result, a new WinComm icon appears in the workspace, with the name you 
specified. 
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Appendix C: Geoids Utility

Introduction

Geoids allows the following:
- Importing new geoid models
- Extracting data from a geoid model in order to create a smaller file just 

describing the specified region
- Loading a geoid model, either partially or completely, into a Magellan 

receiver. Extracting and loading geoid data can be performed in a single 
operation.

- Reading the geoid currently used in a receiver (for former “DSNP-type” 
receivers only).

The following formats exist in Geoids:
- EGM96
- GEOIDYY
- GGF97
- GGR99
- GRD
- GSD95
- RAF
- AU5 (Australia)
- HBG03 (Belgium), etc.

Opening a Geoid Model

- Select File>Open. A dialog box opens in which you can choose a geoid 
model among those available.

- Choose a model and then click OK. A new window appears showing the 
main characteristics of the chosen geoid (name, date of creation, file size, 
comment, geographical limits, grid step and number of points).
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Example of geoid model open in Geoids (EGM96):

Extracting a Region from a Geoid Model

1. Select File>Open and choose the geoid model from the displayed list. 
Geoids will extract the data for your region from this model. Then click OK. 
The selected model appears in Geoids.

2. Select File>Extract As…. A new dialog box is displayed in which you can 
define the geographical area you are interested in.

Definition box for data extraction from a geoid model:
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3. Define the following parameters:
- File name (8 characters max.) (Default: <Geoid model name>~#)
- Comment (25 characters max.). It will appear in the 3rd line when 

you open the geoid model.
- Geographical limits of the considered region, necessarily a rectangu-

lar area defined by a North-West point (NW) and a South-East point 
(SE).

Define the NW & SE points manually, by entering their latitudes & 
longitudes in the corresponding fields, or graphically using the World 
Map editor. If you enter the coordinates manually, then go directly to 
point 4. below.

- To use the World Map editor rather than enter the coordinates manu-
ally, click on the World Map button.
The World Map editor shows the planet Earth. From this view, you can 
select any region on the surface of the Earth for which you would like 
to extract geoid data. The World Map editor is equipped with a 
number of functions allowing you to access this region:

Globe Viewing Options:

• Position the mouse pointer anywhere on the globe
• Right-click on the mouse and choose Options. A dialog box opens in 

which you can change the globe viewing options.
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Rotating the Earth:

If the visible part of the World Map editor does not show the desired 
region, do the following:
• Position the mouse cursor anywhere on the globe
• Right-click on the mouse and select Grabber.

The mouse pointer now looks like this:
• Hold down the mouse left button and drag in the direction that 

would bring the desired region on the visible part of the globe. 
When you release the mouse button, this will cause the globe to 
rotate around its axis by an angle proportional to the distance 
traveled by the mouse pointer while dragging.

Zooming in:

• Position the mouse pointer anywhere on the globe
• Right-click on the mouse and choose Zoom in.

• The mouse pointer now looks like this:
• Position the mouse pointer on the globe where you would like to 

zoom in, and then click on the left button. This causes the region to 
be magnified. The center point of the magnified view is in fact the 
point where you have just clicked
You can repeat this operation several times (as long as the mouse 
pointer is a “+” magnifying glass). From the initial view showing all 
the globe, up to 6 successive zoom-in operations can be performed.

Zooming out:

• Position the mouse pointer anywhere on the globe
• Right-click on the mouse and choose Zoom out.

The mouse pointer now looks like this:
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• Position the mouse pointer on the globe where you would like to 
zoom out, and then click on the left button. This causes the region 
to be reduced in size. The center point of the reduced view is in 
fact the point where you have just clicked.
You can repeat this operation several times until the entire globe 
can be seen on the screen.

Selecting a region:

Once the globe is large enough to make a visual estimate of the 
desired region on the globe’s surface, do the following:
• Position the mouse pointer anywhere on the globe
• Right-click on the mouse and choose Draw.

The mouse pointer now looks like this:
• Position the mouse pointer on the upper-left point of the desired 

region, drag the mouse down to the lower-right point of the region 
and then release the mouse. You can now see the desired region 
inside a rectangle.

• Click OK. This closes the World Map window and, in the Extract 
region from... dialog,  you can now see the coordinates of the two 
points defining the region.

4. Click on the Extract button to extract the data from the geoid model for the 
concerned region. The resulting file is automatically opened in the Geoids 
window once it has been created.
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Example of data extraction using the World Map editor:

Uploading a Geoid Model into a System

- Open the desired geoid model in Geoids
- Select Transfer>Write. A dialog box appears asking you to specify the type of 

system attached to the PC and possibly to extract geoid data from the open 
geoid model:

Geographi-
cal area cov-
ered by initial 

model

Selected 
region

Fields automatically 
filled after making a 

selection on the World 
Map editor

Resulting geoid model 
for the selected region
296



Geoids Utility
Uploading a Geoid Model into a System

G
e
o
id

s

- Choose the option corresponding to the system you are using. If you are 
using a Z-Max, a ProMark3 or ProMark 500, select FAST Survey data collec-
tor. If you are using a system from the 6000 or 6500 series, select DSNP 
Receiver. Then, if necessary, extract the data from the open geoid model 
that matches the geographical area you are working in. Use the World Map 
button, as explained on the previous page, to define this area. For your 
information, the amount of data resulting from the extraction is displayed 
in the dialog box.

- Click OK to upload the geoid data to the system. Depending on which sys-
tem you are using, the following then occurs:
• If you are using a Z-Max or ProMark 500, the following dialog box 

opens:

Make sure the data collector is connected to your office computer via 
a serial line. On the data collector side, run FAST Survey. On the File 
tab, select the Data Transfer function and then run SurvCADD/Carlson 
Survey Transfer. The data collector should now display “...Awaiting 
Connection”. On the PC side, select the port used in the combo box 
and keep the Automatic Transfer box checked. Then click OK to start 
the data transfer.
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 Should the Geoids module fail to connect to the field terminal, please 
resume the above procedure in Manual Mode, i.e. clear the Automatic transfer 
check box when Geoids displays the above dialog box. This will open the Surv-
Com window. From this window, you will be able to check the PC port settings 
(cf. Options button), try again to connect to the field terminal (cf. Connect 
button) and then, if the connection is successful, resume data transfer (cf. 
Transfer button). In that case, the file that you would have to select in the left-
hand pane before clicking the Transfer button would be in the form 
“<Geoid>.gsf” where <Geoid> is the name of the open geoid model (This file 
contains the geoid data). The left-hand pane would be automatically posi-
tioned on the Temp folder where this file would have temporarily been stored.

In case of communication failure (and before you acknowledge the error mes-
sage), the required GSF file is available in your Windows Temp folder and can 
be copied into an SD card using Windows Explorer.

• If you are using a Magellan receiver from the 6000, 6500 or Aquarius 
series, the following dialog box opens:

First make sure the 6000, 6500 or Aquarius receiver is connected to 
the office PC via one of its serial port. After setting the PC port 
involved in the data transfer in the above dialog box, click OK to 
upload the geoid data to the receiver.
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Importing a New Geoid Model

This function allows you to update any geoid model whose data format is 
known. Geoids will convert any type of file you import into a binary file with 
GEO extension.
- Select File>Import. A dialog box opens allowing you to specify the location 

of the original file containing the new geoid, its format, the name of the 
GEO file that will result from the import operation, and a comment associ-
ated with the imported geoid model.

- Click on the Import button to import the selected geoid model.
Example of Import dialog box:
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Displaying the Versions of the Available Geoid 

Formats

- Select Help>About Geoids... A dialog box opens listing the versions of the 
DLL files corresponding to the available geoid models.

Dialog box showing the available geoid models:

Deleting a geoid model

- Select File>Open. A dialog box opens allowing you to specify which geoid 
model should be deleted (a complete or partial one)

- Click Delete. The geoid file is deleted after user confirmation. 
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Appendix D: Rinex Converter

Introduction

Rinex (Receiver INdependent EXchange) is a standard format for GPS, 
GLONASS and SBAS data supported throughout the industry.
The Rinex Converter utility provides a means to translate single or multiple 
Rinex-formatted data files from any receiver to Ashtech- or Atom-formatted 
files, and, alternatively, convert Ashtech or Atom data files to Rinex format. 
Rinex Converter supports Rinex format versions 2.11 and 3.00 and compact 
Rinex format version 2.00.

Starting Rinex Converter
- From the Windows task bar, select successively Start>Programs>GNSS Solu-

tions>Tools>RINEX Converter or click on RINEX Converter in the Utilities topic. 
The Rinex Converter dialog box opens (see figure below).
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Choosing a Conversion Pair
- Click on the Select Mode button at the bottom of the window and select the 

type of format conversion you wish to run. There are three possible 
choices, each corresponding to a specific conversion pair:
• Rinex <---> Ashtech
• Rinex <---> Atom
• Atom <---> Ashtech

Overwrite Options
Whatever the conversion mode used, overwrite options are available to let 
Rinex Converter automatically delete files from the output directory according 
to your choices. In the Rinex Converter window, use the Overwrite files option to 
set your choice before every conversion. The table below summarizes the 
possible choices.

Option Definition
Always over-
write This option always writes over existing files with a new file.

Prompt for over-
write

(Default setting). If Rinex Converter detects that a converted file has the same name 
as an existing file, meaning the new file will overwrite the existing file, a dialog box 
asks if you wish to overwrite the existing file. If you click NO, Rinex Converter skips 
the file, and continues to the next file.

Never overwrite This option does not overwrite data for a given file if a file with the same name 
already exists.
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Conversion Status Dialog Box
Whatever the conversion mode used, a conversion status dialog box opens 
whenever you start a new conversion.

The Conversion status dialog box shows the status of each file as it is 
converted. Upon completion, the display indicates 100% for each file (see 
screen example above), or 0 if a file was not converted for lack of data. During 
conversion, you can:
- Click Cancel to cancel the conversion to the current file type and proceed 

to the next file type
- Click Cancel All to cancel the entire conversion.

Once conversion is complete (if you let Rinex converter complete the work), 
click OK to close the Conversion status dialog box.
A “*.log” file is created in the directory containing all conversion activity. 
When restarted, Rinex converter overwrites the existing log file. To save the old 
log file, rename or move the file before restarting Rinex Converter.
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Rinex Format
• The table below summarizes the different types of existing files in the 

Rinex format.

• When a Rinex file is selected at the input of the Rinex converter, Rinex 
Converter analyzes the other files in the input directory and lists all the 
files that should logically be converted at the same time. The file analysis 
is based on file names.
In the screen example below, Rinex Converter is asked to list all the “*.*O” 
files present in the input directory. In the resulting left-hand list, the first 
*.*O file is highlighted to be converted. As a result, in the right-hand part 
of the screen, Rinex Converter lists all the files that should normally be 
converted, i.e. the selected Obs file (ncli3081.05O) plus the correspond-
ing Nav file (ncli3081.05N).

In case Rinex Converter makes a wrong association, you can still change a 
selected file by clicking on the corresponding button, before the filename, 
and selecting the right file from the input directory.

Item Description
Obs Observation data file
Nav Navigation data file
Nav g GLONASS navigation data file
Nav h Ephemeris data file (geostationary satellites)
SBAS SBAS data file
Met Meteorological data file
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• Conversely, when Rinex is the output format, Rinex Converter will suggest 
that the same types of files be created, depending on the content of the 
input data set and your current settings in the Use and Create subsets. 
Rinex Converter will prompt default names for these files, which we recom-
mend not to change. Below is an example of Rinex files Rinex Converter 
can generate.

Ashtech Format
• The table below summarizes the different types of existing files in the 

Ashtech format.

• When an Ashtech file is selected at the input of the Rinex converter, Rinex 
Converter analyzes the other files in the input directory and lists all the 
files that should logically be converted at the same time. The file analysis 
is based on file names.

Item Description
B-File Raw data file
E-File Ephemeris data file
S-File Site information file
Ion-file Ionospheric data file
D-file Event data file
W-file SBAS data file
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In the screen example below, Rinex Converter is asked to list all the “E*.*” 
files present in the input directory. In the resulting left-hand list, the first 
E*.* file is highlighted to be converted. As a result, in the right-hand part 
of the screen, Rinex Converter lists all the files that should normally be 
converted, i.e. the selected E-file (Enclia05.308) plus the corresponding 
B-file (bnclia05.308), S file (Snclia05.308), Ion-file (ION05.308) and D-
file (Dnclia05.308).

In case the converter makes a wrong association, you can still change a 
selected file by clicking on the corresponding button before the filename 
and selecting the right file from the input directory.

• Conversely, when Ashtech is the output format, Rinex Converter will sug-
gest that the same types of files be created, depending on the content of 
the input data set and your current settings in the Use and Create subsets. 
Rinex Converter will prompt default names for these files, which we recom-
mend not to change. Below is an example of Ashtech files Rinex Converter 
can generate.
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Atom Format
The Atom format only uses a single file type, as shown in the table below.

Compared with the Rinex or Ashtech format, the Atom format is easier to 
handle. As there cannot be a “companion” file to an Atom file, Rinex Converter 
will operate as follows with this format:
• When Atom is the chosen input format, no file other than the selected one 

needs to be converted.
• When Atom is the chosen output format, Rinex Converter can only generate 

a single “G*.*” file.

Setting the Input and Output Directories
For each conversion pair you will be using, it is a good idea to set the 
directories Rinex Converter will use as input and output directories.
The input directory is where the files to be converted are stored. The output 
directory is where Rinex Converter will store the converted files. Each data 
format should have its specific input and output directories.
First of all you should create input and output directories for each format. For 
example you could name these directories as follows:
• Ashin for all input files in Ashtech format
• Ashout for all files converted to Ashtech format
• Atomin for all input files in Atom format
• Atomout for all files converted to Atom format
• Rinexin for all input files in Rinex format
• Rinexout for all files converted to Rinex format.

Item Description
G-File Compiled data file
307



D Rinex Converter
Introduction
Then, to set the input directory for each conversion pair:
1. Click Input dir to open the Set input directory dialog box.
2. Navigate to the directory where the input files are located.
3. Click Save. This closes the Set input directory dialog box. In its left-hand 

part, the Rinex Converter window now lists the files from the selected 
directory as welI as the path to this directory. If the source format is Rinex 
or Ashtech formats, the names of the “companion” files relevant to the file 
selected by default will also be displayed.

 If you are converting Rinex files translated from a Rinex converter that does not 
use the standard Rinex naming format, the observation files may not have the for-
mat *.*O. If the files are not listed in the Available Files list, change the File Types 
to All files on the Rinex to Ashtech or Rinex to Atom tab and ALL files in the Set 
input directory dialog box.

To set the output directory for each conversion pair:
1. Click Output dir to open the Set output directory dialog box:
2. Navigate to the directory where you want to store the converted files.
3. Click Save. This closes the Set Output directory dialog box. In its right-hand 

part, the Rinex Converter window now prompts names for the files that will 
result from the conversion of the selected input file and its possible com-
panion files.

Batch Processing
To convert more than one file at a time:
- If the input files are contiguous, hold down the Shift key, select files with 

the cursor, and click each file.
- If the input files are scattered throughout the directory, hold down the Ctrl 

key, select files with the cursor, and click each file.

Warning! With several files selected the names of the companion files and 
those suggested for the converted files apply to the last input file selected.
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Rinex-Ashtech Conversions

Converting Rinex to Ashtech Format
1. In the Rinex Converter dialog box, click on the Select Mode button and 

select Rinex <---> Ashtech.
2. Unless already done, set the input and output directories (see Setting the 

Input and Output Directories on page 307).
3. In the left-hand part of the window, select the file you want to convert. For 

more information on the data displayed in the Rinex subset, refer to Rinex 
Format on page 304.

4. Click the arrow to the right of the Overwrite files list, and select an option 
from the list (see Overwrite Options on page 302 for more information).

5. Using the check boxes in the Use and Create subsets, choose the data you 
want to convert to Ashtech format. In its right-hand part, the Rinex Con-
verter window then prompts names for the files that will result from the 
conversion, taking into account your “Use” and “Create” settings. See 
example below.
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6. Click BEGIN to convert the selected Rinex files to Ashtech format. The Con-
version status dialog box opens.

7. When the conversion is complete, close the Conversion status dialog box.

Converting Ashtech to Rinex Format
1. In the Rinex Converter dialog box, click on the Select Mode button and 

select Rinex <---> Ashtech.
2. Click the Ashtech to Rinex tab to switch to this tab.
3. Unless already done, set the input and output directories (see Setting the 

Input and Output Directories on page 307).
4. Click the arrow to the right of the Overwrite files list, and select an option 

from the list (see Overwrite Options on page 302 for more information).
5. In the left-hand part of the window, select the file you want to convert. For 

more information on the data displayed in the Ashtech subset, refer to 
Ashtech Format on page 305.

4. Using the check boxes in the Use and Create subsets, choose the data from 
the selected file(s) you want to convert to Rinex format. In its right-hand 
part, the Rinex Converter window then prompts names for the files that will 
result from the conversion, taking into account your “Use” and “Create” 
settings. See example below.
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6. Click BEGIN to convert the selected Ashtech files to Rinex format. The Con-
version status dialog box opens.

7. When the conversion is complete, close the Conversion status dialog box.

Additional Info button: See Entering Additional Information Before Converting 
to Rinex on page 316.

Rinex-Atom Conversions

Converting Rinex to Atom Format
1. In the Rinex Converter dialog box, click on the Select Mode button and 

select Rinex <---> Atom.
2. Unless already done, set the input and output directories (see Setting the 

Input and Output Directories on page 307).
3. In the left-hand part of the window, select the file you want to convert. For 

more information on the data displayed in the Rinex subset, refer to Rinex 
Format on page 304. In its right-hand part, the Rinex Converter window 
then prompts the name for the file that will result from the conversion. See 
example below.
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4. Click the arrow to the right of the Overwrite files list, and select an option 
from the list (see Overwrite Options on page 302 for more information).

5. Click BEGIN to convert the selected Rinex files to Atom format. The Conver-
sion status dialog box opens.

6. When the conversion is complete, close the Conversion status dialog box.

Converting Atom to Rinex Format
1. In the Rinex Converter dialog box, click on the Select Mode button and 

select Rinex <---> Atom.
2. Click the Atom to Rinex tab to switch to this tab.
3. Unless already done, set the input and output directories (see Setting the 

Input and Output Directories on page 307).
4. In the left-hand part of the window, select the file you want to convert. For 

more information on the data displayed in the Atom subset, refer to Atom 
Format on page 307.

5. Click the arrow to the right of the Overwrite files list, and select an option 
from the list (see Overwrite Options on page 302 for more information).

6. Using the check boxes in the Create subset, choose the data from the 
selected file(s) you want to convert to Rinex format. See example below.
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In its right-hand part, the Rinex Converter window then prompts names for 
the files that will result from the conversion, taking into account your “Cre-
ate” settings.

7. Click BEGIN to convert the selected Atom file to Rinex format. The Conver-
sion status dialog box opens.

8. When the conversion is complete, close the Conversion status dialog box.

Additional Info button: See Entering Additional Information Before Converting 
to Rinex on page 316.

Ashtech-Atom Conversions

Converting Atom to Ashtech Format
1. In the Rinex Converter dialog box, click on the Select Mode button and 

select Atom <---> Ashtech.
2. Unless already done, set the input and output directories (see Setting the 

Input and Output Directories on page 307).
3. In the left-hand part of the window, select the file you want to convert. For 

more information on the data displayed in the Atom subset, refer to Atom 
Format on page 307.

4. Click the arrow to the right of the Overwrite files list, and select an option 
from the list (see Overwrite Options on page 302 for more information).

5. Using the check boxes in the Use and Create subsets, choose the data from 
the selected file you want to convert to Ashtech format. In its right-hand 
part, the Rinex Converter window then prompts names for the files that will 
result from the conversion, taking into account your “Use” and “Create” 
settings. See example below.
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6. Click BEGIN to convert the selected Atom file to Ashtech format. The Con-
version status dialog box opens.

7. When the conversion is complete, close the Conversion status dialog box.

Converting Ashtech to Atom Format
1. In the Rinex Converter dialog box, click on the Select Mode button and 

select Atom <---> Ashtech.
2. Click the Ashtech to Atom tab to switch to this tab.
3. Unless already done, set the input and output directories (see Setting the 

Input and Output Directories on page 307).
4. In the left-hand part of the window, select the file you want to convert. For 

more information on the data displayed in the Ashtech subset, refer to 
Ashtech Format on page 305.

5. Click the arrow to the right of the Overwrite files list, and select an option 
from the list (see Overwrite Options on page 302 for more information).
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6. Using the check boxes in the Use subset, choose the data from the 
selected file(s) you want to convert to Atom format. In its right-hand part, 
the Rinex Converter window then prompts names for the files that will 
result from the conversion, taking into account your “Use” settings. See 
example below.

7. Click BEGIN to convert the selected Ashtech file to Atom format. The Con-
version status dialog box opens.

8. When the conversion is complete, close the Conversion status dialog box.
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Entering Additional Information Before 

Converting to Rinex

Before starting a conversion to Rinex, you may set additional information 
usually present in the Rinex format. Because the Ashtech and Atom formats 
do not initially contain this information, you may add it manually using the 
procedure below, provided this information is available:
1. Click Additional Info and select the Obs tab:

2. Complete the fields in the Obs tab. The information entered in the Obs dia-
log box is stored in the observation data file. The table below describes 
each field.

Field Description
STATION INFORMATION

Station Name Name of the survey point or station where data was collected.
Station Number Number of the survey point or station where data was collected.

Observer Name or code of the surveyor who collected the data.
AGENCY (Observing) Name of the company or agency who collected the data.
AGENCY (Creating 

Current File) Name of the company or agency who converted the data to Rinex.

Comments Any comments pertaining to the station, data quality, cover, GPS/GLONASS, 
etc. 50-character length limit.

RECEIVER INFORMATION
Receiver Serial # Serial number of the receiver that collected the data.
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3. Click Apply to save the changes made to the Obs tab, and click Nav to 
switch to the Nav tab (see figure below).

 You can enter information for all three tabs and save all the data using the Save 
button. The best practice, however, is to save the data using the Apply button for 
each tab immediately after entering the data in case of a computer or power failure.

 The Save button saves the data entered on the active tab only, and closes the 
Additional info for Selected Files dialog box.

4. Complete the fields in the Nav dialog box. The information entered in the 
Nav dialog box is stored in the navigation data file. The table below 
describes each field.

All Optional Headers Check this box if you want all non-mandatory fields to be filled in the Rinex 
file header.

ANTENNA INFORMATION

Offsets north (m) Horizontal distance, in meters, that the antenna is offset from the marker in 
the north/south direction. + is north, - is south.

Offsets East (m) Horizontal distance, in meters, that the antenna is offset from the marker in 
the east/west direction. + is east, - is west.

Delta Vertical (m) True vertical distance, in meters, between the bottom of antenna and the 
marker.

Radius (m) Radius of the antenna in meters.

Slant Distance (m) Measured distance, in meters, from the edge of the antenna to the marker. If 
a value for an antenna are entered, it over writes the values in the S-file.

Type Type of antenna used in data collection.
Serial # Serial number of antenna used for data collection.
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5. Click Apply to save the changes made to the Nav dialog box, and click on 
the Met tab to switch to this tab:

6. Complete the fields in the Met dialog box. The information entered in the 
Met dialog box is stored in the meteorological data file. The table below 
describes each field.

7. Click Edit to open the Edit dialog box and inspect or change the meteorolog-
ical data:

Field Description
Agency (Creating 

Current File) Name of the company or agency who converted the data to Rinex.

Comments Any comments pertaining to the station, data quality, cover, GPS/GLO-
NASS, etc. 50-characters maximum.

Field Description
Station Name Name of the survey point or station where data was collected.

Agency (Creating 
Current File) Name of the company or agency that converted the data to Rinex.

Comments Any comments pertaining to the station, data quality, cover, GPS/GLONASS, 
etc. 50-character limit.

Meteorological Data 
List

Date and time atmospheric data was collected (atmospheric pressure, tem-
perature, relative humidity, and ZWET (Zenith Wet Tropospheric Delay).

Edit Click this button to open the Edit dialog box and edit the selected meteoro-
logical data line.
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8. Enter the meteorological data, the date and the UTC time that the data 
was taken, and click OK. The table below describes the fields in the Edit 
dialog box.

9. Click OK to accept the meteorological data and close the Edit dialog box.
10.Click Save to save the changes made to the Met tab and close the Additional 

info for selected files dialog box. 
- The Apply button saves any changes made to the active tab, and does 

not close the Additional info for selected files dialog box.
- The Save button saves any changes made any tab, and closes the 

Additional info for selected files dialog box. 

Field Description

Date The year, month, and date that the data was recorded. D is the day of 
the month (not Julian day) the data was recorded.

Time

The time the data was recorded. H is the hour of the day the data was 
recorded in UTC time (24 hour time scale) M is the minute of the hour 
the data was recorded in UTC time. S is the second of the minute the 
data was recorded in UTC time

Pressure (mbs) The recorded barometric pressure of the atmosphere in millibars.

Dry Temp (C) The recorded temperature of the air not corrected for humidity, in 
degrees Celsius.

Rel. Hum (%) The recorded relative humidity of the air in percent. 
ZWET (mm) Zenith Wet Tropospheric Delay—in millimeters (default = 0)
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Appendix E: DTR Utility

Introduction

DTR is used to convert DSNP-formatted raw data files into Observation + Nav-
igation files in RINEX format.

Input files
Input files should be DSNP raw data files containing binary or ASCII data.

Time labeling
Format conversion involves changing the time-labeling of the raw data. This 
operation is required as the DSNP format is based on satellite time whereas 
the RINEX format uses receiver time.
Time-labeling is changed through extrapolation.
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Naming the output files
The output files can be named freely, or using the conventions defined in the 
RINEX format, namely: 
<site_name><log_day><file_index>.<log_year><type_code>
where:

<site_name>: the first 4 characters from the name of the site where raw 
data was logged
<log_day>: log day in 3 figures (1 to 365)
<file_index>: a figure from 0 to 9 allowing you to create up to 10 differ-
ent files for the same log date and the same site
<log_year>: log year in 2 figures (example: 2001→ 01; 1998→ 98)
<type_code>: letter “0” for Observation file, or “N” for Navigation file.
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Using DTR

Description of the main window

Check this button to name output files according to RINEX conventions. Then choose 
manually the file index (from 0 to 9) in the combo box which then appears on the right

Enter the path & name of the file to be con-
verted in this field.

Use the button on the right of this field to 
find the file on the computer disk

These 3 fields are pre-
set automatically upon 
selection of the file to be 

converted

Optional parameters that are normally present in the header of a RINEX file. As they are not present 
in the Magellan format, if you define them now in these fields, they will be inserted into the RINEX 
file when converting the file.
When you are ready, click on the Go... button to convert the input file
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Advanced options
This window is displayed after clicking on the Advanced button in the main win-
dow. It is used to define precisely in which way time-labeling is changed from 
satellite to receiver time.

For a standard conversion, use instantaneous dopplers and Tx=0.
To optimize further processing of files in RINEX format originating exclusively 
from DSNP log files, use Tx=75 ms preferably. In addition, to optimize static 
processing, choose filtered dopplers preferably.

 75 ms stands for the average propagation time of GPS signals between any satel-
lite and any receiver on Earth. It is therefore the best value a priori to use in the con-
version. 
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Appendix F: Download Utility

Introduction

This module is used to download data from the data memory card installed in 
the receiver, or from the data card inserted in the local card reader, or directly 
from a receiver or the PC hard disk. The data card contains data logged during 
your field surveys.
Download should not be confused with the Import Raw Data from Files or ProMark 
500 command from the Project menu in GNSS Solutions. This last command 
can only import pre-converted data files, ready for processing, whereas the 
Download module is used to download AND convert the raw data files that 
come direct from the field and that need to be split up into several files before 
GNSS Solutions can process them.
You can download data files to a project only after opening this project, which 
means you must create the project first. As explained above, data files are lo-
cated either on a data card still present in the receiver or a data card inserted 
in the local card reader, or on your PC hard disk (if previously downloaded from 
the receiver).
To add data files to the project, from the land survey project open in GNSS So-
lutions, use the Download Raw Data from Z-Max or ProMark3 command from the 
Project menu. This will open the Download window from which you will be able 
to download data.
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During a data recording session, all the data for that session is stored on the 
data card as a U-file. The U-file is a compressed file that contains the data that 
is converted to individual files during the download process. These files in-
clude: the raw data file (B-file) that stores all carrier and code phase data, the 
ephemeris file (E-file) that stores satellite position and timing information, the 
site position information file (C-file), the session information file (S-file), the 
satellite almanach data file (ALM-file), the ionospheric data file (ION-file) and 
the epoch solution & vector solution information file (T-file). The B-, E-, S- and 
ALM files are standard files that are recorded during data collection. If the re-
ceiver is an RTK rover, the receiver creates and stores a specific file of the T-
file type containing CBEN records (RTK epoch solutions) and OBEN records 
(RTK vector solutions). Lastly, the receiver creates an event file (D-file) if the 
receiver is collecting attribute or event-driven data.
The table below summarizes the file types, including file names, a description 
of the information contained in the files, and the file format.

File Type Description Format
B-file Raw code and carrier phase data, range data, clock data Binary

E-file Satellite ephemeris and timing data Binary

S-file Session information data ASCII

ALM file Satellite almanac data Binary

D-file Event time tags and data ASCII

ION-file Ionospheric data Binary

T-file RTK epoch solutions and vectors Binary

C-file Site position information ASCII
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Downloading Data From a Z-Max or ProMark3

Downloading and adding raw data from a GPS receiver to a project can be 
made directly in one, easy step by selecting Download Raw Data from Z-Max or 
ProMark3 in the Project menu of GNSS Solutions. Use this option to insert data 
directly from the data card residing in a receiver, or the data card removed from 
the receiver and inserted in the local card reader, or from the hard disk.

 If you have the option of removing the data card from the receiver to download 
the files using a card reader, you must still use Download to convert the files. If you 
only copy the data from the data card without converting them, GNSS Solutions will 
not be able to read and import them

 If you connect the PC to a receiver via USB, before starting Download, make sure 
the receiver is turned on, and connected to the PC. Otherwise the Connect via USB 
button is grayed out.

1. Connect the receiver to the PC. There are two possible methods to down-
load data: either you connect the receiver via serial port or via USB port. 
Using USB is recommended as data transmission is much faster in this 
case. Verify that the power is on.

2. Select Download Raw Data from Z-Max or ProMark3 from the Project menu of 
GNSS Solutions.
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The Download main window appears: 

The Download main window consists of two panes. The right pane (the PC 
(Personal Computer pane) lists the files, if any, in the project directory of 
the PC. The left pane (currently blank) will list the files on the data card 
once you have selected the right folder on your PC (case where the data 
card is inserted in the card reader, or the data file -micro_z.bin for Z-Max-  
from the data card has already been copied unchanged to the PC hard 
disk) or once the connection to the receiver is established (case where the 
data card stays in the receiver).
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The table below describes the toolbar buttons:

Button Description
Connect via Cable button -  Click this button to open the Connect via Cable dialog 
and connect to the receiver via serial line

Connect via USB button - Click this button to open the Connect via USB dialog and 
connect to the receiver via USB line

Connect via IR button -

Switch Data Source button - Click this button to open the Switch Data Source dia-
log and connect to another receiver.

Switch Pane button - Click this button to change the active pane.

Session Info button - Click this button to Open the Session Information dialog and 
set session parameters for the data file.

Select Files button - Click this button to select files based on a file mask. The Select 
Files dialog opens to enter a file mask for file selection.

Copy To button - Click this button to copy the selected file(s) to the current directory 
on the PC.

Move To button - Click this button to move the selected file(s) to the current directory 
on the PC. 

Delete button - Click this button to delete the selected file(s). 

Create New Directory button - Click this button to create a new directory in the cur-
rent PC directory.

Free Space button - Click this button to check the available disk space for the current 
drive or receiver.

Brief File Info button - Click this button to display only the names of the files. 

Detailed File Info button - Click this button to display the name, size, date, and time 
of last modification for each file and directory in the current directory.

Help button - Click this button to access the help system.

What’s This Help button - Click this button and anywhere else in the window or 
menu system for quick help on the feature.
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3. Select Connect from the File menu.
If you are downloading data from a data card inserted in the card reader of 
your computer, select PC Drive and skip step 4.
If you are downloading data from a receiver, select Receiver and then select 
Connect via USB to connect to the receiver via USB, or Connect via Cable to 
connect to the receiver via an RS232 line.
a) If you choose Connect via USB, the Connect via USB dialog box opens. If 
only the Z-Max is connected to the PC via USB, then this dialog box looks 
like this (and only the option below, “Z-Max USB device1”, is prompted):
330



Download Utility
Downloading Data From a Receiver

D
o
w

n
lo

a
d

b) If you choose Connect via Cable, the Connect via Cable dialog box opens. 
Select the serial port corresponding to your case of use and then choose 
the right communication parameters on the Settings tab:

4. Click OK. Download makes the connection to display the content of the 
data card. Before that, and the first time you connect to a data card, 
Download spends some time mounting the data card file system, as indi-
cated in the lower part of the left pane (this operation may take a while):
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After system mounting, the left pane lists the files contained in the data 
card. Note that the listed  U-file names comply with the file naming con-
ventions defined for files present in the data card, except for the leading 
“U” letter which is replaced here with a globe icon (with a “G” for “Geo-
detic” inside the globe).

5.  Verify that the destination directory in the PC pane is the project directory 
or the directory where you want the data files to be stored. 

6. If you want to create a new directory, click anywhere on the PC pane, then 
click the New Directory button and type a name for the directory. Be sure to 
use logical and consistent path and file naming conventions that are easy 
to remember. Usually it is most convenient to put the data files in the 
project directory.

7. Select the data file(s) that you want to download and drag them to the PC 
pane. To select a group of contiguous files, hold the Shift key while select-
ing files. To select particular files in the list, hold down the Ctrl key while 
selecting files.

8. Download copies the files to the PC. A progress dialog box indicates the 
status of the download:
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You have now reached the end of the downloading procedure. Although the 
data files have been downloaded from the receiver, they have not been deleted 
from the receiver’s data card. To delete receiver data files, select the desired 
files and click the Delete button on the toolbar. The Move function copies and 
then deletes the files.
It is good practice to delete the data files in the data card after verifying that 
the files have downloaded properly. Otherwise, the memory may fill up during 
the next data collection session, resulting in the inability to complete the sur-
vey. 
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Appendix G: Internet Download

Introduction

This utility program allows you to download RINEX raw data or orbit data from 
a provider, via the web.
You can use Internet Download in standalone or when importing files to the ac-
tive project. In the latter case, Internet Download will automatically set the 
Start date, Start time and Duration fields to fit the observations files you have se-
lected for import. This means Internet Download will by default ask the data 
provider to send data for the same period of time as the observation files.
To run Internet Download in standalone, just select Start>Programs>GNSS Solu-
tions>Tools>Internet Download or click on the Internet Download icon in the Utili-
ties topic.
To run Internet Download from the Importing GPS Data window, click on the Add 
Raw Data button and then select Downloaded from Internet.
You can also run Internet Download by clicking on the Internet Download icon in 
the Import topic. In this case, Internet Download will automatically set the Start 
date, Start time and Duration fields to fit the observations files present in the 
open project.
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The Internet Download window looks like this:

Using Internet Download

The Internet Download window is organized and should be used as follows:
- Provider: Select the name of the provider from which you want to download 

raw data.
After making this choice, Internet Download updates the lists of available 
services and stations attached to respectively the Service and Station fields 
underneath.
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Also, when you select a provider, the corresponding web address is dis-
played in the lower part of the window (in underlined blue characters) after 
the “Provider Infos:” text string. Clicking on this address would launch 
your Internet explorer to connect to this website.

- Service: Choose the type of data you want to download from the selected 
provider. The list of service names attached to this field is tied to the pro-
vider you have selected

- Station: Choose the name of the station for which you want to download 
data. The list of station names attached to this field is tied to the provider 
you have selected.

- Time Zone: Select the option that fits your working area.
- Start Date, Start Time, Duration: These fields allow you to define the period of 

time for which you want data from your provider. The End date and End time 
fields are software set for your information, after you have set these 3 
fields.
To change the Start date, click on the corresponding down-arrow. A calen-
dar is then displayed:
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• Click on the displayed year and use the up/down arrows next to it to 
set the year

• Click on the right/left arrow to set the month
• Click on the day number to set the day. This closes the calendar.

- Target Path: This field allows you to define the folder where you want Inter-
net Download to store the downloaded files.

To do this, click on , browse your disk until you can select the desired 
folder name and then click OK. The selected folder and its path will then 
appear in the Target Path field.

- Download button: Click on this button when you agree with all the settings 
in the window and you want to start downloading data. Below is an exam-
ple of the message lines that appear in the Output pane –located in the 
lower part of the window– as raw data downloading takes place:

Connecting to Host "cddisa.gsfc.nasa.gov"... Ok
Searching for file "/pub/gps/gpsdata/04013/04d/brst0130.04d.Z" ... Ok
Searching for file "/pub/gps/gpsdata/brdc/2004/brdc0130.04n.Z" ... Ok
Downloading File "/pub/gps/gpsdata/04013/04d/brst0130.04d.Z"... Ok
Downloading File "/pub/gps/gpsdata/brdc/2004/brdc0130.04n.Z"... Ok
Disconnecting... Ok
Uncompressing Observation file(s)... Ok
Merging Observation data to "brst0131.04o"... Ok
Uncompressing Navigation file(s)... Ok
Merging Navigation data to "brst0131.04n"... Ok

Note the different operations performed during this phase:
• Internet Download connects to the Provider’s web address
• Provider then searches for and then download the corresponding files 

to the specified folder
• Disconnection from Provider’s web address
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• Internet Download locally uncompresses and merges the observation 
files

• Internet Download then locally uncompresses and merges the naviga-
tion files.

Below is another example of messages read in the Output pane when 
downloading orbit data:

Connecting to Host "cddisa.gsfc.nasa.gov"... Ok
Searching for file "/pub/gps/products/1253/igr12532.sp3.Z" ... Ok
Downloading File "/pub/gps/products/1253/igr12532.sp3.Z"... Ok
Disconnecting... Ok

- Close button: Click on this button to quit Internet Download.

Adding new Providers to the Existing List of Pro-

viders

From version 2.5, this task is supported by GNSS Solutions itself, and no long-
er by Internet Download, now in version 2.10 (see Adding a New Provider on 
page 221)
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Appendix H: SurvCom Utility

Launching SurvCom

SurvCom allows you to exchange data between the office PC and the data col-
lector.
Note that the RTK feature should logically be active in GNSS Solutions when 
using SurvCom. To activate the RTK feature, select Tools>Preferences in GNSS 
Solutions and check the Show RTK functions button.
Before running SurvCom, make sure FAST Survey’s Data Transfer menu is open 
on the data collector.
The SurvCom utility is available from the GNSS Solutions tools list. It will also 
be automatically launched from within GNSS Solutions when you select one of 
the following commands:
- Upload Positions to External Device (provided you then select data collector as 

the external device connected to the  PC)
- Download Positions from External Device (provided you then choose “real-time 

results” as the data to be downloaded and you select data collector as the 
external device connected to the PC).

If the communications parameters are set correctly, a connection will be made 
and the directory listing from the receiver will be retrieved:
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If on the contrary, the parameters are incorrect, the following two dialog boxes 
will appear, one after the other:

If a connection is not made, the SurvCom window will open anyway, but the 
program will only be able to display the list on the left showing files and direc-
tories from the PC. Click the Options button and adjust the COM port and/or 
baud rate settings to match those of the data collector and press the Connect 
button to try again.
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SurvCom Main Window

The SurvCom window looks like this after a connection to an external device is 
made correctly:

To access a parent directory, double-click the [Up One Level] string. To open a 
folder appearing in any of the panes, double-click it.
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Commands Available

: Connect button
- When launching SurvCom, this button is automatically actuated to try to 

connect to the external device. As explained earlier, if the connection to 
this external device fails, click this button to try the connection again. You 
can change the connection parameters by clicking the Options button.

: Transfer button
- This command is used to transfer files.

The list on the left shows files on the PC. The list on the right shows files 
on the data collector.

- To move files from one to another, highlight the files and press the Transfer 
button.

: Set Path button
- This command allows you to set the path on either the local PC or the 

remote data collector.
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- Type in the path you wish to change to, choose Local PC or Remote 
Machine and then press OK.
You may also change the path by navigating the directory structure shown 
in the main window of the SurvCom program.

: Make Dir button
- This command allows you to create a directory on either the Local PC or 

the Remote Machine.

- Type in a directory name you want to create, choose Local PC or Remote 
Machine and then press OK.
If you enter an invalid directory name, it will not be created. Invalid direc-
tory names are determined by the operating system.

: Delete button
- This command allows you to delete files and empty directories. Click this 

button after selecting the item(s) you want to delete. Depending on the 
Confirm Delete option chosen with the Options button, a message will 
appear, or not, asking you to confirm deleting these items.

: Rename button
- This command allows you to rename files or directories. Click this button 

after selecting the item you want to rename.
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: Options button
- This command allows you to set various options. When you click the 

Options button, the following dialog box opens on the screen:

- Com Port: You must select which COM port on the PC to use.
- File Mask: You must select a file filtering syntax. *.* will show all files.
- Directory Sort: You must select how to sort the list of files (by name, 

date or size, or no sorting).
- Display Special Files: Toggle whether or not you should see special files.
- Confirm Overwrite: Toggle whether or not you want SurvCom to have 

you confirm overwriting of files.
- Confirm Delete: Toggle whether or not you want SurvCom to have you 

confirm deleting of files and directories.
- Baud Rate: You must choose the baud rate for transferring data (4800, 

9600, 19200, 38400, 57600 or 115200).
- Protect Remote Files: Toggle whether or not you want to protect files on 

the mobile device.
- Archive RW5 files: Toggle whether or not you want to save the RW5 files
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: Set Geoid button

- Not used in Magellan applications..

: F2F Conv button
- This command will copy a field to finish file (.FLD) to the data collector 

and convert it to the (.FCL) format used by the FAST Survey field software.

: Send Pnts button
- Not used in Magellan applications.

: Exit button
- This command will exit SurvCom. 
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Project Management provides an easy way to handle your projects. Because it 
will always operate on ALL the files and folders pertaining to a project, Project 
Management gives you the assurance that not a single file will be forgotten. 
With Project Management, you can:
• Back up a project or workspace
• Restore a project or workspace
• Delete a project or workspace
This appendix describes how to use Project Management. For your information, 
the last section in this appendix tells you what a project is made up of in terms 
of files and folders and so identifies the items handled by Project Management 
when you use it.

Main Window

You cannot run Project Management unless GNSS Solutions is inactive. Con-
versely, you cannot launch GNSS Solutions if Project Management is still run-
ning. To run Project Management:
- From the Windows task bar, select Start>Programs>GNSS Solu-

tions>>Tools>Project Management. The Project Management main window 
looks like this:
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About Projects and Workspaces

The right part of the window lists all the projects saved in the MyProjects 
folder (or in whatever folder you chose at software installation to save your 
projects).
The left part of the window lists all the workspaces saved in your project 
folder:
• If you are using GNSS Solutions with the default installation, the 

notions of workspace and project are merged into a single notion. When 
in this case of use you create a new project, GNSS Solutions not only 
creates a project but also a workspace whose name is the same as that 
of your project. This is the reason why, in this case, the two lists in the 
Project Management window are alike.

• But if you are using GNSS Solutions with the “Data Management” 
option running and you have used the notion of workspace to group sev-
eral projects, then the two lists will be different. If you move the mouse 
cursor over the list of workspaces, a tip box will appear for each work-
space indicating the number of projects grouped in the workspace. Con-
versely, the tip boxes attached to the list of projects will tell you, for 
each project, the number of workspaces in which the project is involved.
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Setting the Project Folder

- Select Tools>Project Folder. In the Browse for Folder window, select the 
folder containing all your GNSS Solutions projects

- Click OK to enable your selection and close the dialog. This updates the 
Project Management main window to reflect the content of the newly 
selected folder. Obviously if you selected the wrong folder, no workspace or 
project will be listed.

Backing up a Project or Workspace

Project Management can save any project or workspace as a single file (SAR 
file). Generating SAR backup files is the best way to archive your projects. If 
you back up a workspace, then the SAR file will include all the projects 
grouped in that workspace.
- Click on the item you want to back up
- Right-click and select Backup
- Enter a name for the SAR file (default: project or workspace name) and 

choose the folder where to save that file
- Click Save to create the SAR file and save it to the specified folder.
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Restoring a Project or Workspace

You can restore an archived project using Project Management. Once restored, 
the project appears in the project folder with all its files and folders.
- Select Tools>Restore
- Browse your disk to find the folder containing the SAR file you want to 

restore
- Once you have found it, select the SAR file name and click Open. As a 

result, the Project Management main window is updated to reflect the 
Restore operation you have just performed. The restored item will appear 
either in the right or left part of the window depending on whether it’s a 
project or a workspace respectively.

 If you restore a project on another PC that uses different user language settings, 
the Project Settings dialog will first open asking you to set the time zone and also to 
confirm the coordinate system used in the project. A “~1” suffix will appear in the 
system name but you can safely reselect the standard system name, i.e the name 
without the “~1”.

Deleting a Project or Workspace

- Click on the item you want to delete
- Right-click and select Delete
- In the warning dialog that shows up, click Yes to confirm the deletion. All 

the files and folders pertaining to this project or workspace are tehn 
removed from the project folder.

 When there is only one project in a workspace, deleting either the workspace or 
the project will cause both the workspace and the project to be deleted.
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When  creating a project, a new folder named <project_name> as well as two 
files are created in the MyProjects folder. A number of files are created in the 
new folder that correspond to the Time View, the Survey View, the Design View 
and the project database. (The Design view is visible in the open project only 
after the CAD function has been enabled in GNSS Solutions.) The two files cre-
ated in the MyProjects folder define the workspace including the project.
Below is an example of what a project (in a new workspace) looks like just after 
creating it:

The following files will be added into the <project_name> folder as you work 
on your projects:
- Survey reports (RTF files)
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And if you ask for a copy of these into the project folder when importing them 
into the project:
- Raw data files (d*.*, b*.*, e*.* files) 
- Vector or/and raster maps (SHP, MIF DXF, TIF, JPG, etc.)

According to the terminology introduced in the Advanced functions of GNSS 
Solutions, when the Data Management function is valid, the types of files 
stored in the project folder are the following, depending on their extensions:
- *.map: map documents
- *.tvw: time view documents
- *.LSP: Land survey project database
- *.tbl: table documents
- *.rtf: RTF file containing the text displayed in the Output pane for the 

project (messages, processing reports, etc.)
- *.sws: file containing the current settings of GNSS Solutions main window 

for this workspace
+

- *.gph: graph documents. 
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Appendix J: Post-Adjustment Analysis

General

A least-squares adjustment of survey observations is one of the most important 
steps in a GPS survey. Properly used, a least-squares adjustment helps isolate 
blunders in the observations being adjusted and improves the accuracy and re-
liability of the point positions being determined. The mathematics and statis-
tics involved in performing and analyzing a least-squares adjustment is 
somewhat complex but the basic concepts of the task accomplished by an ad-
justment are straight forward.
The primary components of a least-squares adjustment are the survey observa-
tions (angles, distances, elevation differences, and, in this case, GNSS vec-
tors) and the uncertainties (confidence) associated with these observations. 
Due to measurement limitations of the surveying instruments and the influ-
ence of the instrument operators, these observations include some level of er-
ror. These errors cause loops not to close perfectly and result in the ability to 
compute different positions for the same point in the network based on which 
observations were used to compute the position. 
The ultimate goal of a least-squares adjustment is to produce a set of observa-
tions where all loops close perfectly and only one position can be computed for 
any point in the network. In order to accomplish this task, the observations go-
ing into the adjustment must be changed slightly, i.e. adjusted. Of course, you 
do not want the observations to be changed much since this is what was phys-
ically observed in the field, but the observations do contain some level of error. 
Any error associated with an observation is predictable because of the mea-
surement accuracy of the survey instruments used. So, do not be concerned 
that the observations are adjusted as long as the amount of adjustment to any 
given observation is not significantly greater than the expected error in the ob-
servation.
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These are the fundamental guidelines to a least-squares adjustment. A suc-
cessful adjustment is one where observations are changed as little as possible, 
and the amount of change (adjustment) to any observation is within expected 
levels, i.e. about the same magnitude as the uncertainty in the observation.
Unfortunately, there are a number of obstacles that can stand in the way of pro-
ducing a successful adjustment. Primary on this list are blunders, errors in the 
observations due to equipment malfunction or operator error. Examples are an 
incorrectly measured instrument height, an instrument not properly centered 
over the survey mark, insufficient data to produce a high quality GPS vector, 
assigning the wrong Site ID to a point, etc. The list is long. Fortunately, tools 
exist to assist in overcoming these obstacles. These adjustment analysis tools 
have been incorporated into the adjustment module of GNSS Solutions.
After discussion of the available analysis tools, there is a section describing the 
process of analyzing an adjustment. From start to finish, each step of the anal-
ysis process is listed showing the sequence of when and how to use the anal-
ysis tools.
Before proceeding, there are few things you must remember when analyzing an 
adjustment with this tool set:
1. Many of the analysis tools are statistically based. These statistically based 

tools utilize the vector uncertainties (error estimates) as the basis for their 
testing. It is critical the observation uncertainties are realistic for the sta-
tistically based tools to function properly. Unrealistic uncertainties will 
cause the analysis tools to function unpredictably and, in the worst case, 
may make a bad adjustment look good.
The vector-processing module is responsible for assigning uncertainties to 
the processed GPS vectors. A great deal of effort has gone into insuring 
that realistic uncertainties are determined. Unfortunately, this is not 
always an easy task and at times, the uncertainties may be a little optimis-
tic (too small) or pessimistic (too large).
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Recognizing this, methods were developed to help identify when uncertain-
ties are unrealistic and to help rectify this situation. These methods are 
explained in detail below.

2. Adjustment analysis tools cannot function properly without redundancy in 
the adjusted observations. It is impossible to detect a blunder in an obser-
vation establishing the position of a point if there is only one observation at 
this point. When designing a survey network, be sure to include sufficient 
redundancy in the observations. The best case would be to include more 
than one observation of each point being established. Unfortunately, this is 
not practical and really not necessary. Select a certain percentage of points 
to receive multiple observations. Thirty to fifty percent is recommended. 
This redundancy will significantly increase the likelihood that observation 
blunders will be detected by the adjustment.
In the discussion of the analysis tools below, it is assumed that sufficient 
redundancy exists in the adjusted observations.

3. It is also important to remember that no analysis tool gives a definitive 
indication of the existence of blunders or the quality of an adjustment. No 
one tool should ever be solely relied upon. All tools must be used together 
for an effective analysis of an adjustment.

4. Blunder detection should always be performed on minimally constrained 
adjustments. Attempting to detect blunders in a constrained adjustment is 
very difficult since a detected problem can either be caused by a blunder 
or a error in the control position fixed in the adjustment. The first step in 
the adjustment process should always be a minimally constrained adjust-
ment. Use this adjustment to detect and eliminate blunders from the data 
set, and determine the internal quality of the survey data. After the data 
set is clean of blunders and it is determined that the survey meets the rel-
ative accuracy specification, a constrained adjustment can be performed.
In the discussion of blunder detection tools below, it is assumed that the 
tools are being used on a minimally constrained adjustment.
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Blunder Detection Tools

The blunder detection tools are designed to assist you in detecting problems 
with an adjustment. The tools assist in determining if blunders exist in any of 
the observations used in the adjustment, or if any problems exist in the network 
construction that would hamper the ability for an adjustment to be performed. 
Each tool is presented in detail below.

Network Connectivity Test
In order to properly adjust an entire data set of observations, there must be 
connectivity between all sections of the data set. For example, look at a survey 
of a pipeline that will require multiple days of work to complete. Two survey 
crews begin work on the project, one on the north end and one on the south 
end. At the end of day 1, each crew will have surveyed a number of points at 
each end of the project. The two data sets have no observations between them 
yet. These two data sets cannot be adjusted together because they are not con-
nected. 
The network connectivity test examines the data set prior to adjustment to de-
termine if there are subsets of the data set that are not connected by observa-
tions.

Variance of Unit Weight/Standard Error of Unit Weight
The Variance of Unit Weight and the Standard Error of Unit Weight (the square-
root of the Variance of Unit Weight) monitor the relationship between the un-
certainties assigned with the observations and the magnitude of the change re-
quired to each observation (residuals) in the adjustment.
Changes to the observations should be small and should not be significantly 
greater than the uncertainties associated with the observations. 
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The Variance of Unit Weight and Standard Error of Unit Weight gauge the mag-
nitude of the observation changes (residuals) compared to the observation un-
certainties for the entire network.
Analysis of the magnitude of the computed Variance of Unit Weight and Stan-
dard Error of Unit Weight reveals one of the following three conditions regard-
ing the quality of the adjustment:
1. A computed value close to 1 is an indication that the changes to the obser-

vations (residuals) are within expected levels, i.e. within the uncertainties 
associated with the observations. Since this is the desired outcome, a 
value close to 1 is normally an indication of a good adjustment.

2. A computed value significantly smaller than 1 indicates an imbalance 
between the observation residuals (changes) and observation uncertainties. 
Specifically, the observation uncertainties are too pessimistic (too large). 

3. A computed value significantly larger than 1 is also an indication of an 
imbalance between the observation residuals (changes) and observation 
uncertainties. Specifically, one or two problems exist with the adjustment. 
Either one or more blunders exist in the observations causing the observa-
tion residuals to be much larger than the observation uncertainties, or the 
observation uncertainties are too optimistic (too small).

To fully comprehend the significance of a Standard Error of Unit Weight being 
significantly smaller or larger than 1, it is first imperative that any observation 
blunders that may exist in the observations be removed from the adjustment.
Later in this chapter you will find additional tools that are specifically designed 
to isolate blunders. With the absence of blunders in the network observations, 
the magnitude of the Standard Error of Unit Weight can be examined to deter-
mine its significance.
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In a blunder-free adjustment, the magnitude of the Standard Error of Unit 
Weight, the magnitude of the disagreement between the uncertainties associ-
ated with the observations and what the adjustment determines should be the 
observation uncertainties.
For example, if the Standard Error of Unit Weight is computed to be 2 and the 
adjustment is blunder-free, the adjustment had determined, based on the size 
of the observation residuals, that the observation uncertainties should be 2 
times larger than they are currently stated to be. If the computed Standard Er-
ror of Unit Weight is 0.5, then the observation uncertainties should be 2 times 
smaller than they are currently stated to be. Why is this important? For two rea-
sons:
1. Many of the tools used to analyze the quality of the adjustment are statisti-

cally based. For them to work properly, the observation uncertainties going 
into the adjustment must be realistic, i.e. close to the real uncertainties. 
The Standard Error of Unit Weight computed from a blunder free adjust-
ment gives an indication of the quality of the observation uncertainties. If 
the Standard Error of Unit Weight is much greater than or smaller than 1, 
this is an indication that the observation uncertainties are not realistic. 
Fortunately, GNSS Solutions automatically compensates for this problem. 
All post-adjustment statistics used to measure the quality of the adjust-
ment utilize the computed value for the Standard Error of Unit Weight to 
automatically compensate for unrealistic uncertainties. No action on the 
part of the user is required.

2. A great deal of effort went into ensuring that the vector processing of 
GNSS Solutions assigned realistic uncertainties to the processed vectors. 
But since this is not yet an exact science, there are conditions that may 
cause the computed uncertainties to be too small or too large. In most 
cases, you should find that the computed Standard Error of Unit Weight 
falls between 1 and 3. In addition, you should find that this value is rela-
tively consistent for similar types of surveys.
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If you find that for most of your surveys, the Standard Error of Unit Weight 
for a blunder-free adjustment is 1.5 and today you are working on an 
adjustment with a Standard Error of Unit Weight of 6, there probably is 
something wrong with the adjustment.

Chi-Square Test
The Chi-Square test is a statistical test evaluating the computed value for the 
Variance of Unit Weight. Its purpose is to determine if the computed value for 
the Variance of Unit Weight is statistically equivalent to 1. As stated earlier, a 
Variance of Unit Weight equal to 1 indicates a balance between observation 
residuals and observation uncertainties. It is very seldom that the computed 
value for the Variance of Unit Weight will exactly equal 1. But an exact value 
of 1 is not required. The Chi-Square test examines the computed value to de-
termine if it is statistically equivalent to 1. If the test passes, the computed 
value is considered equivalent to 1. 
Due to the difficulties in computing observation uncertainties due to the many 
variables involved, in many cases the Variance of Unit Weight will be larger or 
smaller than 1. This causes the Chi-Square test to fail. GNSS Solutions auto-
matically compensates for observation uncertainties being too large or too 
small, therefore the passing or failure of the Chi-Square test has no true bear-
ing on the quality of the adjustment.
If, by using the other blunder detection tools available, you are confident that 
all blunders have been removed from the adjustment and you are happy with 
the relative size of the observation residuals, then a failure of the Chi-Square 
test should not be a concern. The Chi-Square test can be made to pass, if de-
sired, by scaling the observation uncertainties using the Confidence scaling fac-
tor found in the Miscellaneous tab of the Project Settings dialog. Scale the vector 
uncertainties by the computed Standard Error of Unit Weight.
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Observation Residuals
In a least-squares adjustment, small corrections are applied to the observa-
tions to obtain the best fit of all observations producing one solution for all 
points. The best fit is the solution that produces the least amount of correc-
tions to the observations. These small corrections are termed residuals. Each 
observation will have one or more residuals. Observations have three residuals, 
one for each component of the vector (X,Y,Z). 
The reason why observations have to be corrected at all in order to produce a 
good fit is due to errors in the observations. If observations contained no errors, 
then an adjustment would not be needed. All observations would fit together 
perfectly.
Two types of errors can be found in survey observations, random errors and 
blunders. Random errors will cause small corrections to be needed in observa-
tions in order to make them fit together properly. If only random errors exist in 
the data set, all residuals will likely be small. On the other hand, if large blun-
ders exist in the data set, large residuals will likely be produced.
Examining the size of observation residuals can help in identifying blunders in 
the observations used in the adjustment. GNSS Solutions will display and out-
put the residuals for all observations. These residuals should be examined in 
an attempt to identify blunders. If blunders are identified, they must be re-
moved from the data set, and the adjustment rerun. If the observation contain-
ing the blunder is a critical observation of the data set, it should be examined 
to determine the cause of the blunder. Once repaired, the observation can be 
returned to the adjustment. If the observation is critical to the strength of the 
network and cannot be repaired, the data will need to be re-observed.
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There are two main difficulties in using residuals to identify blunders in a data 
set.
1. Blunders, if large enough, will produce large residuals for the observation 

containing the blunder. But large residuals do not always indicate a blun-
der, in an observation. It is possible for a good observation to have large 
residuals. This obviously complicates the use of residuals to find blunders 
but this obstacle can be overcome with the understanding of why a good 
observation will produce large residuals. A least-squares adjustment tends 
to distribute the effects of blunders throughout the entire network. In other 
words, a blunder in one observation usually affects the residuals in other 
observations.
The effect is greater on observations closer to the blunder and diminishes 
further out. The trick is to find the observation with the blunder among all 
the observations containing large residuals due to the blunder. In most 
cases, the observation with the largest residuals is the observation contain-
ing the blunder. Remove this observation and rerun the adjustment. If all 
residuals look good at this point, the blunder was identified and removed. 
If large residuals still exist, again remove the observation with the largest 
residuals and rerun the adjustment. Do this until the adjustment looks 
good. It is possible that some of the observations removed do not contain 
blunders. At this time, each observation removed should be added back to 
the adjustment one at a time, rerunning the adjustment each time an 
observation is added. If the adjustment looks good, that particular observa-
tion did not contain a blunder. If the adjustment looks bad after adding 
back one of the observations, the chances are very good that the observa-
tion contains a blunder. This process can be complicated even further if 
multiple blunders exist in the data set. But systematic removal and 
replacement of observations will result in identifying the blunders.
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2. Throughout this section, we have talked about large residuals and their roll 
in identifying blunders. A natural question is 'What is a large residual?'. 
Unfortunately, there is no easy answer to this question. For GPS vectors, 
random errors in the observations increase as the length of the vector 
increases. Therefore, residuals will increase with baseline length. A resid-
ual of 0.10 meters on a 20-kilometer line may solely be due to random 
errors but the same residual on a 2-kilometer line almost surely indicates a 
blunder. So, a residual being large or small is dependent on the GPS vector 
length. There are a few guidelines that can be used to help examine resid-
uals.
First, all vectors of similar length should have similar residuals. Second, 
residuals should not be much greater than the measurement accuracy of 
the equipment. For example, if the equipment being used is capable of 
making observations at an accuracy level of 0.01m + 2ppm, the residuals 
for an observations should not be much greater than this capability. An 
accuracy specification of 0.01m + 2ppm allows for an error of 0.03m on a 
10 kilometer baseline. A residual 2-3 times larger than this allowable error 
is suspect and should be examined closely for the possible presence of a 
blunder.
Sometimes the size of a residual will be border line as to whether or not a 
blunder exists. If this is the case, the observation should be inspected 
closely to see if the cause of the blunder can be determined. If not, it is a 
judgement call as to whether or not the observation should be removed. If 
the observation is not critical to the strength of the network, it can be 
removed without impact. If the observation is needed but does not seem to 
have an adverse affect on the accuracy of the adjusted points, it can be 
left in.
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Tau Test
Examining residuals is a good indicator of the quality of individual observa-
tions. As stated earlier, the expected value of residuals are predictable since 
they are expected to follow a normal distribution.
The Tau test utilizes this predictability to automatically test the residuals of an 
observation to determine if the residuals could represent an observation con-
taining a blunder. The Tau test utilizes the normalized residuals for an obser-
vation to determine if statistically the residual is within expected limits. A 
threshold value is computed to test each normalized residual against. Each 
normalized residual is tested with two possible outcomes:
• The Tau test passes indicating that the magnitude of the normalized resid-

ual is not greater than the expected limit for the residual. This is usually a 
good indication that the observation is free of blunders.

• The Tau test fails indicating that the magnitude of the normalized residual 
is greater than expected. The observation failing the test should be 
checked for blunders.

The tau test is automatically performed by the adjustment module of GNSS So-
lutions. Each residual is tested and the outcome of the test is presented in a 
check button along with the residuals for each observation.
It is important to understand, that if a residual does not pass a statistical test, 
it does not mean that there is a blunder in that observation. The observation is 
merely flagged so that it can be examined and a decision about its retention or 
rejection can be made. Blind rejection is never recommended. A blunder in 
one observation usually affects the residuals in other observations. Therefore, 
the tests will often flag other observations in addition to the ones containing 
blunders. If one or more observations are flagged, the search begins to deter-
mine if there is a blunder.
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In summary, the Tau test examines observation residuals in an attempt to lo-
cate observations that may contain blunders. Each residual is tested to deter-
mine if it passes or fails the test.
• If a residual passes the Tau test, this is a good indicator that the observa-

tion does not contain blunders.
• If the residual fails the Tau test, the observation should be closely exam-

ined to determine if it contains a blunder.
• Remember that if a residual fails the Tau test, this is not a certain indica-

tor that a blunder exists. Simply removing observations that have failed the 
Tau test is not recommended. These observations must be examined care-
fully to determine if a blunder exists.

Loop Closure Analysis
In a well designed survey network, a number of closed loops, generated by GPS 
vectors, will exist. If all observations contained zero error, performing loop clo-
sures with various vectors throughout the network would result in loops with 
zero misclosure. Since in the real world, absolutely perfect survey observations 
are impossible, loops will generate some level of misclosure. Misclosures due 
to random errors in the observations should be of predictable magnitude, i.e. 
a magnitude similar to the measurement accuracy of the instrument used.
Misclosures due to blunders are unpredictable in magnitude, ranging in size 
based on the size of the blunder. Due to this, loop closures can be an effective 
method to isolate blunders in the data set.
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When a large blunder or multiple blunders exist in a data set, it is sometimes 
difficult to find the blunder(s) from analysis of the adjustment output. This is 
due to the tendency of least-squares adjustments to distribute the error from 
these blunders throughout the survey network. In such cases, loop closures can 
be an effective tool to assist in isolating the blunders. By performing multiple 
loop closures in the area where a blunder(s) is suspected to exist, the vector(s) 
causing the blunder(s) can normally be isolated. Once the problem vector(s) is 
isolated, it can be examined and repaired or removed.
GNSS Solutions supplies the tools for you to perform a loop closure analysis of 
the survey network to assist in isolating blunders. By selecting vectors, you can 
create multiple loops throughout the network. The results of each loop closure 
are presented for analysis.

Repeat Vector Analysis
When performing a GPS survey, it is recommended that a certain percentage 
of observed vectors be repeated, i.e. observed more than once. These repeat 
vectors can be used to analyze the repeatability of the observations, giving a 
clue to the overall quality of the final survey. In addition, repeat observations 
can be useful in identifying blunders if a problem arises with one of the repeat-
ed observations.
GNSS Solutions automatically performs an analysis of all repeat vectors in the 
network. All repeat vectors are compared to each other and differences in the 
observations are presented for analysis. In addition, the resulting differences 
between repeat observations are compared to the user-defined accuracy spec-
ification.
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• If the difference between the repeat observations of a vector is smaller 
than the allowable error computed from the accuracy specification, the 
repeat vectors pass the QA test. This is normally a good indication that no 
blunder exists in the vectors, and that the vectors are of sufficient quality 
to produce a network that will meet the desired accuracy.

• If the difference between the repeat observations of a vector is larger than 
the allowable error computed from the accuracy specification, the repeat 
vectors are flagged as having failed the QA analysis test. Any repeat obser-
vations that fail the test should be examined closely to determine if a blun-
der exists.

Control Tie Analysis
For many surveys, there is a requirement to tie the survey into a local, regional, 
or national control network. Many times, the exact control points to be used for 
this purpose will be specified. To meet this requirement, these control points 
will need to be held fixed in the final constrained adjustment, therefore com-
puting positions for the new survey points in relation to the specified control 
points.
In addition to the requirement for tying into a control network, most surveys 
will also have an accuracy specification that must be met.
The control tie analysis feature automatically computes the accuracy for each 
control point. This is accomplished by holding one of the control points fixed 
in the minimally constrained adjustment and comparing the adjusted position 
to the known control position. The difference between the positions is comput-
ed and presented. A test then compares the user-entered accuracy specifica-
tion to the computed accuracy for each control point (Maximum acceptable 
control error parameter in Project Settings>Miscellaneous tab.
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• If the QA test passes, the computed accuracy of the tested control point 
meets the accuracy specification. This is an indication that the control 
point can be fixed in the over-constrained adjustment.

• If QA test fails, the computed accuracy does not meet the accuracy speci-
fication. Holding this control point fixed in an adjustment will cause a deg-
radation of the network accuracy below the required accuracy 
specification. In such a case, the control point should be examined in 
detail to determine if a blunder occurred during entry of the control values. 
If no blunder is found, a decision must be made to determine if this point 
should be held fixed in the final constrained adjustment, i.e., do not hold 
the problem control point fixed in the final adjustment, or hold it fixed 
despite its accuracy. This is normally a decision made by the final recipi-
ent of the adjusted network, i.e. the client. 
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Appendix K: Miscellaneous

List of Shortcuts

Function Key
or Key Combination Action

F1 Opens User’s Guide

F2 Launches Mission Planning utility

F3 Downloads raw data from receiver or data card

F4 Imports raw data from files on disk

F5 Processes all baselines

F6 Processes unprocessed baselines

F7 Adjusts network

F8 Exports geo data to file

F9 Generates report

Alt+F5 Refreshes view (time, map, graph, collections, documents)

Ctrl+F6 Switches view

Ctrl+F4 Closes view

Alt+F4 Quits application

Mouse wheel Pans/Scrolls vertically (map view, workbook)

Shift+Mouse wheel Pans/Scrolls horizontally (map view, time view, workbook)

Ctrl+Mouse wheel Zooms in/out (map view, time view)

Ctrl+P Prints active view

Ctrl+N Creates new project

Ctrl+A Selects All (text, points, etc.)

Ctrl+C or Ctrl+Ins Copies text, map view, etc.

Ctrl+X or Shift+Del Cuts text (reports)

Ctrl+V or Shift+Ins Pastes text, map view, etc.

Crtl+Z or Alt+Backspace Undoes text (report)

Ctrl+N Creates a new project or document
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(Reminder: Data Management feature must be active in Tools>Preferences)
The table below summarizes all the filter codes GNSS Solutions can display on 
the Data tab of any Layer Properties dialog box after you have created a filter 
for the layer, based on a text string (Example: Filter on the “Control” parameter 
which should be equal to “Vertical Control (1D)”).

Ctrl+P Prints document

Ctrl+S Saves report

+ Zooms in x2 (map view, time view)

- Zooms out /2 (map view, time view)

Alt+0 Shows/hides Command pane/workspace

Alt+1 Shows/hides output pane

Filter on: Code Meaning

Type

0 Control Point
5 Reference Point
10 Logged Point
15 Target Point
20 Intermediate Point

Control

0 No Control
1 Vertical Control (1D)
2 Horizontal Control (2D)
3 Horizontal & Vertical Control (3D)

Function Key
or Key Combination Action
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Status

0 Unsurveyed
10 Estimated
20 Offset (Linear) (6502)
21 Offset (Lateral) (6502)
22 Offset (Intersection) (6502)
23 Offset
30 RTK (dynamic)
31 RTK (static)
40 Processed (dynamic)
41 Processed (static)
50 Adjusted
60 Imported

Constraints

0 No constraints
1 Vertical Fixed (1D)
2 Horizontal Fixed (2D)
3 Horizontal & Vertical Fixed (3D)

Use

0 Not used
1 Vertical System (1D)
2 Horizontal System (2D)
3 Horizontal & Vertical System (3D)

Si
de

255 Left of P2P1
0 N/A
1 Right of P2P1

So
ur

ce 0 Ashtech
1 DSNP
2 RINEX

Me
as

_T
yp

e 10 L1 GPS
11 L1 GPS/GLONASS 
20 L1/L2 GPS
21 L1/L2 GPS/GLONASS

He
ig

ht
_T

yp
e 0 Slant

1 Vertical

2 True

Mo
de

0 Static
1 Dynamic
2 Stop & Go

Or
bi

t T
yp

e 0 Broadcast
1 Precise SP3
2 Precise EF18
373



K Miscellaneous
Other Utilities
Other Utilities

The following utilities can be found in the Tools Menu:
Leap Seconds...: Allows manual entries of days when leap seconds occurred 
or will occur (you must also indicate the amount of leap seconds). GNSS 
Solutions will take into account these leap seconds in the processing of 
data collected during any of these days.
Test Time...: Opens the Test Time dialog box in which you can convert any 
GPS-formatted time (i.e. week, seconds) into local time (day, hours, min-
utes, seconds), taking into account the specified local time zone
GNSS antenna: Provides access to the library of GNSS antennas. In this 
library, you can add, edit, delete antennas. Each antenna definition 
includes a name, a description and the locations of its center phases with 
respect to features easy to locate on the antenna itself. The type of GNSS 
antenna used in the field is one of the properties of  the observation files. 
With GNSS Solutions, you can change the antenna type in the observation 
files you import into a project. See also Creating a New Antenna Type on 
page 88. 

So
lu

tio
ns 10 Float

20 Partial
30 Fixed
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3D: Three dimensional

A
Acquisition: The process a GPS receiver goes through 
to find and lock onto a GPS satellite. Once a GPS re-
ceiver has acquired 4 or more satellites, it can begin 
to compute positions.
Adjusted position: The final position of a survey point 
derived from a least squares adjustment of the mea-
surements used to derive the position.
Adjustment: The adjustment of survey observations is 
the process of correcting observations to produce the 
best final values for the unknowns. An adjustment 
cannot be performed unless the set of observations be-
ing adjusted contains redundancy. The adjustment 
process also assists in finding and eliminating blun-
ders in observations, and produces statistical uncer-
tainties that can be used to estimate the final 
precision of the survey performed.
Almanac: Data transmitted by a GPS satellite which 
includes orbit information on all the satellites, clock 
correction, and atmospheric delay parameters. These 
data are used to facilitate rapid satellite acquisition. 
The orbit information is a subset of the ephemeris data 
with reduced accuracy.
Ambiguity: The unknown integer number of cycles of 
the reconstructed carrier phase contained in an unbro-
ken set of data from a single satellite collected by a 
single receiver. Also known as integer ambiguity and 
integer bias.
ARP: Antenna Reference Point (GNSS antenna speci-
fication
ASCII: American Standard Code for Information Inter-
change. A set of characters (letters, numbers, sym-
bols) used to display and transfer digital data in 
standard English format.
Autonomous position: Also known as a point, position 
or raw position. The position derived from a single re-
ceiver without using any differential correction. This is 
the least accurate method of positioning.

B
Baseline: The three-dimensional vector distance be-
tween a pair of stations for which simultaneous GPS 
data has been collected and processed with differen-
tial techniques. The most accurate GPS result.
Base Station: In differential positioning, the end of the 
baseline that is assumed known and its position fixed. 
Used as the basis for differential correction of un-
known points.
Blunder: A mistake or error caused by confusion, care-
lessness, or ignorance, including, but not limited to: 
transposing numbers when writing down the HI or 
reading the HI incorrectly, occupying the wrong point.
Blunder detection: A method, or series of methods, 
which automatically detect blunders.

C
C/A code: The Coarse/Acquisition (or Clear/Acquisi-
tion) code modulated onto the GPS Ll signal. This 
code is a sequence of 1023 pseudorandom binary bi-

phase modulations on the GPS carrier at a chipping 
rate of 1.023 MHz, thus having a code repetition pe-
riod of one millisecond. This code was selected to pro-
vide good acquisition properties.
Carrier frequency: The hardware in a receiver that al-
lows the receiver to detect, lock-on, and continuously 
track the signal from a single satellite. The more re-
ceiver channels available, the greater number of satel-
lite signals a receiver can simultaneously lock-on and 
track.
Carrier phase: The phase of either the L1 or L2 carrier 
of a GPS signal, measured by a receiver while locked-
onto the signal (also known as integrated Doppler).
Cartesian coordinates: Values representing the loca-
tion of a point in a plane in relation to three mutually 
perpendicular coordinate axes which intersect at a 
common point or origin. The point is located by mea-
suring its distance from each axis along a plane paral-
lel to the axis. 
Centroid: The point whose coordinates are the average 
values of the coordinate of all points in the area of in-
terest. Commonly used in transformations between 
two coordinate systems. Rather than computing trans-
formation parameters around the origin of the base co-
ordinate system, parameters are computed around a 
centroid. The coordinates of points can be large num-
bers and the mathematics involved in transformations 
can cause numbers to reach the limit of a computer's 
ability to properly store them. By using a centroid, 
point coordinates are reduced to a manageable size, 
avoiding this problem.
Channel: The hardware in a receiver that allows the re-
ceiver to detect, lock-on and continuously track the 
signal from a single satellite. The more receiver chan-
nels available, the greater number of satellite signals 
a receiver can simultaneously lock-on and track.
Code phase: Term used in reference to C/A or P-code 
data.
Confidence level: The goal of any measurement is to 
find the true value. Since all measurements contain 
error, the true value is never observed. In order to qual-
ify measurements, an error estimate is statistically de-
rived for each measurement. An error estimate has a 
confidence level associated with it which gives the 
probability that the true value of a measurement falls 
within the range generated by subtracting and adding 
the error estimate to the measured value. For example, 
if a measurement of 50.5 meters has an error estimate 
of 0.1 meters at the 95% confidence level, then there 
is a 95% probability that the true value is between 
50.4 – 50.6 meters. 
Connectivity: A test performed during a network ad-
justment to see if all the points in the active project 
are linked together by measurements. If that is the 
case, the project passes the connectivity test. Other-
wise the test fails, which means that the project con-
tains two or more independent point networks instead 
of a single one.
Constellation: The collection of orbiting GPS satel-
lites. The GPS constellation consists of 24 satellites in 
12-hour circular orbits at an altitude of 20,200 kilo-
meters. In the nominal constellation, four satellites 
are spaced in each of six orbital planes. The constella-
tion design was selected to provoke a very high proba-
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bility of satellite coverage even in the event of satellite 
outages.
Constraints: A limitation placed on a position in an ad-
justment. An unknown may have a constraint that does 
not allow its value to be adjusted. If one of the survey 
points contained in the data is a control point, it’s co-
ordinates should not be adjusted since they are al-
ready known. In order to stop the adjustment from 
computing new coordinates for this control point, the 
coordinates are constrained or fixed to their known val-
ues. 
Control tie: When performing a survey where the newly 
established network of points must be tied to a local, 
regional, or national network, control points from this 
network must be incorporated into the survey. The goal 
is to constrain the known coordinates of these control 
points in the adjustment in order to determine the po-
sition of the new points in reference to the control net-
work. If for some reason the coordinates for one of the 
control points is incorrect (blunder in entry or dis-
turbed monument), the adjustment will be distorted by 
constraining this point. To avoid this, the relative ac-
curacy of control points should be checked prior to 
constraining them in the adjustment. A control tie is 
the process used to check the relative accuracy of con-
trol points.
Cycle slip: A loss of count of carrier cycles as they are 
being measured by a GPS receiver. Loss of signal, ion-
ospheric interference, obstructions, and other forms of 
interference cause cycle slips to occur (see carrier 
phase). To properly compute a vector between data 
collected from two GPS receivers, all cycle slips must 
be corrected. This task is normally performed automat-
ically by the software.

D
Datum: See Geodetic datum
Datum bias parameters: The relationship between two 
datums is defined by a set of 7 transformation param-
eters. These parameters define how the coordinates of 
a point in one datum change to the coordinates of the 
same point in another datum. When performing a 
least-squares adjustment, these parameters can be es-
timated as part of the adjustment process. This comes 
into play if the control points held fixed in the adjust-
ment are on a different datum than the observations 
being adjusted. Datum bias parameters is the term 
usually used to refer to transformation parameters es-
timated through a least-squares process.
Differential GPS (DGPS): A technique whereby data 
from a receiver at a known location is used to correct 
the data from a receiver at an unknown location. Dif-
ferential corrections can be applied in real-time or by 
post-processing. Since most of the errors in GPS are 
common to users in a wide area, the DGPS-corrected 
solution is significantly more accurate than a normal 
autonomous solution.
Differential positioning: Determination of relative co-
ordinates of two or more receivers which are simulta-
neously tracking the same satellites. Dynamic 
differential positioning is a real-time calibration tech-
nique achieved by sending corrections to the roving re-
ceiver from one or more reference stations. Static 
differential GPS involves determining baseline vectors 
between pairs of receivers.

Differential processing: GPS measurements can be 
differenced between receivers, satellites, and epochs. 
Although many combinations are possible, the present 
convention for differential processing of GPS phase 
measurements is to subtract differences between re-
ceivers (single difference), then between satellites 
(double difference), then between measurement ep-
ochs (triple difference).
A single-difference measurement between receivers is 
the instantaneous difference in phase of the signal 
from the same satellite, measured by two receivers si-
multaneously.
A double-difference measurement is obtained by dif-
ferencing the single difference for one satellite with re-
spect to the corresponding single difference for a 
chosen reference satellite.
A triple-difference measurement is the difference be-
tween a double difference at one epoch of time and 
the same double difference at the previous epoch of 
time.
Dilution of Precision (DOP): The geometry of the visi-
ble satellites is an important factor in achieving high 
quality results. The geometry changes with time due to 
the relative motion of the satellites. A measure for the 
geometry is the Dilution of Precision (DOP) factor. 
DOP is a description of the effect of satellite geometry 
on position and time computations. Values considered 
'good' are less than three. Values greater than seven 
are considered poor. Thus, small DOP is associated 
with widely separated satellites

E
Earth-Centered Earth-Fixed (ECEF): Right-handed car-
tesian coordinate system where the X-axis passes 
through the intersection of the prime meridian (Green-
wich) with the equator, the Z-axis is coincident with 
the mean position of the earth's rotational axis, and 
the Y-axis is orthogonal to both the X and Z-axes.
Easting: The distance eastward from the north-south 
grid line that passes through the origin of a grid sys-
tem.
Eccentricity: The ratio of the distance from the center 
of an ellipse to its focus to the semi-major axis.
EGM96: The EGM96 geoid model is a global model on 
a 0.25 x 0.25 degree grid. It was created from the 
EGM96 spherical harmonic model completed to de-
gree and order 360. 
Elevation: Height above a reference datum. The refer-
ence datum may be an ellipsoid (ellipsoidal elevation), 
a geoid (orthometric elevation), above mean-sea-level, 
or above a locally defined reference plane.
Elevation factor (sea-level factor): Elevation factor is a 
scale adjustment applied to distance measurements in 
order to reduce the distances to the ellipsoid surface. 
This is the first step to converting measured distances 
to grid distances. After the measured distance is re-
duced to an ellipsoidal distance, it is scaled again by 
the grid factor to produce a grid distance.
Elevation Mask Angle or Minimum Elevation (Angle): 
An adjustable feature of GPS receivers that specifies 
that a satellite must be at least a specified number of 
degrees above the horizon before the signals from the 
satellite are to be used. Satellites at low elevation an-
gles (five degrees or less) have lower signal strengths 
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and are more prone to loss of lock thus causing noisy 
solutions.
Ellipsoid: In geodesy, unless otherwise specified, a 
mathematical figure formed by revolving an ellipse 
about its minor axis. It is often used interchangeably 
with spheroid. Two quantities define an ellipsoid; 
these are usually given as the length of the semi-major 
axis, a, and the flattening, f = (a - b)/a, where b is the 
length of the semi-minor axis. Prolate and triaxial el-
lipsoids are invariably described as such.
Ellipsoid Height (Elevation): The vertical distance 
above a reference ellipsoid for a specific point. GPS re-
ceivers compute ellipsoid heights above the WGS-84 
reference ellipsoid.
Ephemeris: A list of (accurate) positions or locations of 
a celestial object as a function of time. Available as 
"broadcast ephemeris" or as post-processed "precise 
ephemeris"
Epoch: Time stamp for a measurement interval or data 
frequency, e.g., 15 seconds, 30 seconds. 
Equatorial Mercator: Map projection in which meridi-
ans appear as equally spaced vertical lines, and paral-
lels as horizontal lines drawn farther apart as latitude 
increases, such that the correct relationship between 
latitude and longitude scales at any point is main-
tained. The Mercator map is widely used in navigation 
since directions can be easily measured.
Error ellipse: All measurements contain error. The 
computed position of a point is never the true position 
because the measurements used to determine the po-
sition contain error. An error ellipse is a statistical es-
timate of the precision of a point position. More 
specifically, it is an elliptical shaped region around a 
point representing the area within which there is a cer-
tain probability that the true position of the point is lo-
cated. 
Error of closure (misclosure): Whenever closing a 
traverse or level loop onto the starting point, error in 
the observations will always produce two different po-
sitions for that point: the original position and the po-
sition computed using the measurements from the 
survey. For example, if the elevation of the starting 
point for a level run is 100.000 meters, the end eleva-
tion of the loop should be 100.000 meters if the loop 
ends on the starting point. But due to measurement er-
ror, the final elevation may be 100.060 meters. The 
difference between the two elevations is the error of 
closure. This error is also often referred to a misclosure

F
Firmware: The electronic heart of a receiver, where 
coded instructions relating to receiver function, and 
(sometimes) data processing algorithms, are embed-
ded as integral portions of the internal circuitry.
Fixed solution: Processing of GPS vectors produces 
many solutions for the vector at different stages of the 
processing. One of the parameters being solved for 
during the processing is the integer ambiguity. A fixed 
solution is a vector solution where the integer ambigu-
ities have been correctly determined and held fix. The 
fixed solution for a vector is most often the best solu-
tion. If for some reason the ambiguities could not be 
solved, the final solution for the vector will be a float 
solution.

Flattening: The ratio of the difference in lengths of the 
major and minor axes, respectively, of an ellipse, to the 
length of the major axis of the ellipse.
f = (a- b)/a = 1 -(1 - e2)1/2

a = Semi-major axis
b = Semi-minor axis
e = Eccentricity

Float solution: Processing of GPS vectors produces 
many solutions for the vector at different stages of the 
processing. One of the parameters being solved for 
during the processing is the integer ambiguities. A 
float solution is a vector solution where the integer val-
ues for the ambiguities could not be determined, 
therefore they are not fixed to a specific integer value 
(left to float as a real number.
Fully constrained adjustment: An adjustment is fully 
constrained when sufficient control has been con-
strained to allow the solving of all unknown parame-
ters. If all seven datum bias parameters are being 
solved, 2 horizontal control points and 3 vertical con-
trol points are sufficient to produce a fully constrained 
adjustment.

G
Geocentric cartesian coordinates: x, y, and z coordi-
nates that define the position of a point with respect 
to the center of the earth.
Geodetic coordinates: A coordinate system where the 
position of a point is defined using the components of 
latitude, longitude and geodetic height. 
Geodetic datum: Any numerical or geometrical quanti-
ty or set of quantities that serves as a reference or base 
for other quantities. In surveying, two types of datums 
are considered: a horizontal datum, which forms the 
basis for the computations of horizontal positions that 
consider the curvature of the earth, and a vertical da-
tum, to which elevations refer. Historically, horizontal 
datums were defined by an ellipsoid and the relation-
ship between the ellipsoid and a point on the topo-
graphic surface established as the origin of datum. 
This relationship can be defined by six quantities, gen-
erally (but not necessarily): the geodetic latitude, lon-
gitude, and the height of the origin, the two 
components of the deflection of the vertical at the or-
igin, and the geodetic azimuth of a line from the origin 
to some other point. GPS uses WGS-84 which, as in 
the newer datums, is earth-centered-earth-fixed 
(ECEF).
Geodetic height (ellipsoidal height): The height of a 
point above an ellipsoidal surface. The difference be-
tween a point's geodetic height and its orthometric 
height (height above ellipsoid) equals the geoidal sep-
aration.

Major Axis Minor Axis
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Geoid: A gravity based surface used to best represent 
the physical surface of the earth. The center of the 
geoid coincides with the true center of the earth. Its 
surface is an equipotential surface, meaning that at 
any point the geoid is perpendicular to the direction of 
gravity. The geoid can be visualized by imagining that 
the earth were completely covered by water. This water 
surface is an equipotential surface since the water 
flows to compensate for any height difference that oc-
curs.
Geoid height: See Geoidal separation 
Geoidal separation: The height difference between the 
ellipsoidal height and orthometric height at any given 
point on the earth’s surface. Worded differently, it is 
the separation between the geoid surface and ellipsoid 
surface at a given point on the earth’s surface.
Geoid96: The current geoid model covering the United 
States, Puerto Rico, and the Virgin Islands. The 
GEOID96 model was computed in October, 1996 us-
ing over 1.8 million terrestrial and marine gravity val-
ues. The result is a gravimetric geoid height grid with 
2’ x 2’ spacing in latitude and longitude. The 
GEOID96 model was developed to support direct con-
version between NAD83 GPS ellipsoidal heights and 
NAVD88 orthometric heights.
Geometric Dilution of Precision (GDOP): See Dilution 
of Precision 
Global Positioning System (GPS): Passive, satellite-
based navigation system operated by the Department 
of Defense. It’s primary mission is to provide passive 
global positioning/navigation for land-, sea-, and air-
based operations.
GPS consists of-
-a space segment (up to 24 NAVSTAR satellites in 6 
different orbits)
-the control segment (5 monitor stations, 1 master 
control station and 3 upload stations) the user seg-
ment (GPS receivers)
NAVSTAR satellites carry extremely accurate atomic 
clocks and broadcast coherent simultaneous signals.
GPS time: The time system upon which GPS is based. 
GPS time is an atomic time system and is related to 
International Atomic Time in the following manner:
International Atomic Time (IAT) = GPS + 19.000 sec
GPS week: GPS time started at Saturday/Sunday mid-
night, January 6, 1980. The GPS week is the number 
of whole weeks since GPS time zero.
Greenwich mean time (GMT): Time based on the 
Greenwich Meridian as a reference. In distinction from 
time based on a local meridian or the meridian of a 
time zone. 
Grid coordinates: Coordinates of a point on the physi-
cal earth based on a defined two dimensional grid sys-
tem. These coordinates are normally referred to as 
Easting and Northing.
Grid system: A grid system is a defined set of parame-
ters that, along with a map projection, are used to con-
vert geodetic coordinates (curved surface) to grid 
coordinates (flat surface).
GSD-95: GSD95 is the newest Canadian geoid model. 
It is a refinement to the previous model, GSD91, but 
continues to use the same format, grid spacing, and 
GRS80 reference ellipsoid (as used to define the 
NAD83 datum. The GSD95 model was develop to sup-

port the direct conversion between NAD83 GPS ellip-
soidal heights and CVD28 orthometric heights.

H
HI: Height of Instrument
Horizontal Dilution of Precision (HDOP): See Dilution 
of Precision 

I
Ionosphere: The layers of ionized air in the atmosphere 
extending from 70 kilometers to 700 kilometers and 
higher. Depending on frequency, the ionosphere can 
either block radio signals completely or change the 
propagation speed. GPS signals penetrate the iono-
sphere but are delayed. This delay induces error in the 
GPS measurements that can result in poor survey re-
sults. Most GPS receivers/processing software model 
the ionosphere to minimize its affects. Also, the ef-
fects of ionosphere can be nearly eliminated by using 
dual frequency receivers which can calculate the delay 
due to ionosphere.
Ionospheric delay: A wave propagating through the 
ionosphere [which is a non-homogeneous (in space 
and time) and dispersive medium] experiences delay. 
Phase delay depends on electron content and affects 
carrier signals. Group delay depends on dispersion in 
the ionosphere as well, and affects signal modulation 
(codes). The phase and group delay are of the same 
magnitude but opposite sign.
Item: A set of visual elements representing any object 
from a collection on a map document. Typically, an 
item is made up of an icon and a label assigned to the 
icon.
ITRF: International Terrestrial Reference Frame. A 
world spatial reference system co-rotating with the 
Earth in its diurnal motion in space. More information 
at http://itrf.ensg.ign.fr/.

J
Julian date: The number of days that have elapsed 
since 1 January 4713 B.C. in the Julian calendar. GPS 
time zero is defined to be midnight UTC, Saturday/
Sunday, 6 January 1980 at Greenwich. The Julian 
date for GPS time zero is 2,444,244.5.

K
Kinematic initialization bar: A metal attachment of 
fixed length (0.2 meters) used to expedite the initial-
ization process of a kinematic survey. Two receivers are 
attached to the kinematic initialization bar, one over a 
known location. They act as a fixed baseline and allow 
the receivers to initialize (accurate position/ambiguity 
resolution) more rapidly than if the receivers were to 
initialize across a baseline of unknown length.
Kinematic surveying: A form of continuous differential 
carrier-phase surveying requiring only short periods of 
data observations. Operational constraints include 
starting from or determining a known baseline, and 
tracking a minimum of four satellites. One receiver is 
statically located at a control point, while others are 
moved between points to be measured. 

L
L1: The primary L-band signal radiated by each 
NAVSTAR satellite at 1575.42 MHz. The Ll beacon is 
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modulated with the C/A and P codes, and with the NAV 
message. 
L2: The secondary L-band signal radiated by each 
NAVSTAR satellite at 1227.60 MHz and is modulated 
with the P code and the NAV message.
Lambert Conformal Conic: A conformal conic map pro-
jection on which all meridians are represented by 
equally spaced straight lines that radiate from a com-
mon point outside the map limits, and the parallels are 
represented by circular arcs with this common point 
for a center and intersect the meridians at right angles. 
Smallest distortion for middle latitudes. In the United 
States, the Lambert Conformal Conic projection is the 
basis of State Plane Coordinate System (SPCS) for 
states with predominant east-west orientation.
Latitude: Angle generated by the intersection of the 
semi-major axis of the datum reference ellipsoid and 
the ellipsoid normal (line running perpendicular to the 
ellipsoid surface) at the point of interest. Latitude is 
one of the positional elements when defining the geo-
detic coordinates of a point.
Layer: 1)A set of parameters defining the graphical 
representation on a map document of any object from 
a given collection - 2) A name given to geographical 
objects of the same family (e.g. trees, fire hydrants, 
etc.).
Legend: The set of layers making up the content of a 
map document. Each layer defines the representation, 
on the map document, of any object from a given col-
lection.
Local grid coordinates: Coordinates of a point on the 
physical earth, based on an arbitrarily defined two di-
mensional grid system. These coordinates are normally 
referred to as Easting and Northing.
Local grid system: A local plane coordinate system 
usually defined for use on a small survey project. The 
defining parameters for the system are usually an ori-
gin with arbitrarily determined horizontal coordinates 
(such as 0,0 or 1000,1000) and an arbitrary direction 
(boundary line or backsight to another point). The local 
system usually stands on it’s own, with no known rela-
tionship with any other defined coordinate system. 
This relation may be determined though if the coordi-
nates of a sufficient number of points can be deter-
mined in both coordinates systems between which a 
relationship is sought.
Longitude: The length of the arc or portion of the 
Earth’s equator between the meridian of a given place 
and the prime meridian expressed in degrees west or 
east of the prime meridian to a maximum of 180 de-
grees.

M
Map projection: Any systematic method of represent-
ing the whole or a part of the curved surface of the 
Earth upon another surface.
Minimally constrained adjustment: When performing a 
least-squares adjustment on GPS data, the mathemat-
ics require that the horizontal coordinates of at least 
one point and the vertical coordinates of at least one 
point (may or may not be the same point) be held fixed 
(constrained) to known or arbitrarily selected values. 
One horizontal position and one vertical position is the 
minimum set of constraints. An adjustment performed 

holding fixed the minimum set of constraints is re-
ferred to as a minimally constrained adjustment.
Misclosure: See Error of Closure 
Multipath: The reception of a satellite signal both 
along a direct path and along one or more reflected 
paths. The reflected signals are caused by reflecting 
surfaces near the GPS antenna. The resulting signal 
results in an incorrect pseudorange measurement. The 
classical example of multipath is the ghosting that ap-
pears on television when an airplane passes overhead.
Multipath error: A GPS positioning error resulting from 
the use of reflected satellite signals (multipath) in the 
position computation.

N
NAD27: North American Datum, 1927.   
NAD83: North American Datum, 1983.   
Navstar: The name of GPS satellites, built by Rockwell 
International, which is an acronym formed from Navi-
gation System with Time And Ranging.
Northing: The distance northward from an east-west 
line that passes through the origin of a grid. 

O
Object: A unit of information from a collection.
Observable: In GPS surveying, the observable is anoth-
er name for the raw data being collected (observed) by 
the GPS receiver.
Observation: The act of recording (GPS) data at a site. 
An example usage of the term would be, ‘The observa-
tion at point 0001 lasted 1 hour’. Observation is usu-
ally interchangeable with the term occupation.
Obstruction: Physical feature that blocks the satellite 
direct line of site from the point of observation. GPS 
signals are very weak. They can be blocked from reach-
ing the GPS antenna by objects between the antenna 
and the satellites. Classic examples of obstructions are 
trees and buildings.
Occupation: The period of recorded data for a site. For 
example, a 1-hour period of data collection on a survey 
point is considered an occupation. Occupation is usu-
ally interchangeable with the term observation.
Orthometric elevation (orthometric height): The height 
of a point above the geoid. Orthometric elevation is of-
ten equated with mean-sea-level elevation.
OSU91A: A global geoid model. Technically, it is a 
high resolution spherical harmonic model (degree 
360). The errors in the geoid defined by this model are 
estimated at 28 cm RMS over the oceans and 46 cm 
RMS over the continents. This model was developed 
by Richard Rapp and his colleagues at Ohio State Uni-
versity.

P
Partially constrained adjustment: In a partially con-
strained adjustment, the number of constraints ap-
plied are greater than what is required for a minimally 
constrained adjustment, and less than what is needed 
for a fully constrained adjustment. An example would 
be a network containing two known horizontal control 
points and only one vertical control point. Constraining 
these points would result in a partially constrained ad-
justment where the datum bias parameters could not 
fully be determined.
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P-Code: The protected or precise code used on both 
LIE and L2 GPIs beacons. This code will be made 
available by the DOD only to authorized users. The P 
code is a very long (about 1014 bits) sequence of 
pseudorandom binary biphase modulations on the 
GPS carrier at a chipping rate of 10.23 MHz which 
does not repeat itself for about 38 weeks. Each satel-
lite uses a one-week segment of this code which is 
unique to each GPS satellite, and is reset each week.
Phase center: The phase center of a GPS antenna is 
the physical location on the antenna where the raw 
GPS signals are observed. This is the physical location 
where the computed position will be determined. GPS 
antennas are manufactured to place the phase center 
as closely as possible to the physical center of the an-
tenna housing. To determine the position of a survey 
marker on the ground, the GPS antenna (and thus the 
phase center) is centered over the marker and the HI 
is measured to the survey marker for use during pro-
cessing.
Point positioning: See Autonomous position.
Point, Control: Surveyed point whose accurate position 
is already known. This known position can be set as a 
fixed input to the processing or simply used as com-
parison material to assess the quality of the survey.
Point, Control, Non-fixed: Control point whose know 
coordinates are only used to assess the quality of a sur-
vey.
Point, Control, Fixed: Control point whose know coor-
dinates are used as an input to the processing. The 
surveyed coordinates for this point are replaced with 
the known coordinates. This action is called “fixing” 
the control point.
Point, Intermediate: Logged point of lesser interest 
(e.g. a point in a trajectory)
Point, Logged: Point surveyed in the field in real-time 
or post-processing mode
Point, Reference: A point materialized in the field 
whose theoretical coordinates are known in the local 
system and that will be surveyed for calibration pur-
poses.
Point, Target: A point whose theoretical coordinates, 
known in the local system, are provided for staking-out 
purposes.
Polar Stereographic: Projection of points on the sur-
face of a sphere to a plane tangent at its pole. Most 
common map projection used for polar areas of the 
earth.
Position Dilution of Precision (PDOP): See Dilution of 
Precision. 
Post-processed position: The position of a survey point 
obtained from the processing of GPS raw data ob-
served simultaneously between this point an another 
point of known position.
Post-processing: The reduction and processing of GPS 
data after the data were collected in the field. Postpro-
cessing is usually accomplished on a computer in an 
office environment where appropriate software is em-
ployed to achieve optimum position solutions.
PPM: Part per million
PRN number: Satellite identification number
Process: A process describes the way a pair of obser-
vation files can be processed to form a baseline and to 
produce a vector.

Pseudorange: A measure of the apparent propagation 
time from the satellite to the receiver antenna, ex-
pressed as a distance. Pseudorange is obtained by 
multiplying the apparent signal-propagation time by 
the speed of light. Pseudorange differs from the actual 
range by the amount that the satellite and user clocks 
are offset, by propagation delays, and other errors.
The apparent propagation time is determined from the 
time shift required to align (correlate) a replica of the 
GPS code generated in the receiver with the received 
GPS code. The time shift is the difference between the 
time of signal reception (measured in the receiver time 
frame) and the time of emission (measured in the sat-
ellite time frame).

Q
QA: Quality Assurance. GPS post-processing software 
often has a number of different QA tests to ensure 
quality data is being used.

R
Random errors: Small, unpredictable errors caused by 
imperfections in the surveying equipment or operator 
procedures.
Raster map: A bitmap file, as opposed to a vector file, 
providing a visual representation (an image) of a map, 
a photo, etc. when edited
Raw data: GPS data which has not been processed or 
differentially corrected.
Recording interval: The time interval between the re-
cording of GPS raw data to the GPS receiver memory. 
For example, a recording interval of 10 seconds indi-
cates that GPS raw data will be stored to the GPS re-
ceiver memory once every 10 seconds.
Reference Station: A point (site) where crustal stabili-
ty, or tidal current constraints, have been determined 
through accurate observations, and which is then used 
as a standard for the comparison of simultaneous ob-
servations at one or more subordinate stations. Certain 
of these are known as Continuous Operating Reference 
Stations (CORS), and transmit reference data on a 24-
hour basis. Data from these sites are available for pub-
lic use and can be retrieved in one hour increments 
from the internet at: http://www.ngs.noaa.gov/cors/
cors-data.html .
Residual: The difference between the observed value 
and the computed value. In a least-squares adjust-
ment of GPS data, GPS vectors are adjusted in order 
to find the best fit for all vectors. The adjustment of 
each vector produces a residual(s) for the vector. The 
residual is the amount the vector was adjusted to make 
it fit in with all other vectors. The residual values are 
analyzed to determine if there is a potential problem 
with a vector(s) in the adjustment.
RINEX: Receiver INdependent EXchange format. A set 
of standard definitions and formats to promote the free 
exchange of GPS data and facilitate the use of data 
from any GPS receiver with any software package. The 
format includes definitions for three fundamental GPS 
observables: time, phase, and range. A complete de-
scription of the RINEX format is found in the Commis-
sion VIII International Coordination of Space 
Techniques for Geodesy and Geodynamics "GPSBUL-
LETIN" May-June,1989. 
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Root-Mean-Square (RMS): A statistical measure of the 
scatter of computed positions about a "best fit" posi-
tion solution. RMS can be applied to any random vari-
able. 
Rover: The GPS receiver that moves from site to site 
during a kinematics GPS survey.

S
Scale factor: A scale adjustment applied to ellipsoidal 
distances in order to reduce the distances to grid dis-
tances. This is the second and last step to converting 
measured distances to grid distances. The first step is 
to reduce measured distances to ellipsoidal distances 
by applying the elevation factor.
Seed coordinate: When processing GPS raw data col-
lected simultaneously between two points, the pro-
cessing requires that the coordinates of one of the two 
points be held fixed. Normally, these are the known co-
ordinates for one of the points. These coordinates are 
referred to as seed coordinates.
Selective Availability (SA): A Department of Defense 
program to control the accuracy of pseudorange mea-
surements, whereby the user receives a false pseudor-
ange which is in error by a controlled amount. 
Differential GPS techniques can reduce these effects 
for local applications.
Semi-major axis: One half of the major axis of an el-
lipse.
Semi-minor axis: One half the minor axis of an ellipse.
Session: A group of simultaneously collected GPS raw 
data. For example, if 4 GPS receivers collected data si-
multaneously on 4 points, the entire data set is con-
sidered a session. Within a session, GPS vectors can 
be computed between all points.
SHMP: Slant Height Measurement Point (GNSS An-
tenna specification).
Singularity: A condition that causes the inverse opera-
tion of a matrix to fail. Matrix inversion is an important 
operation in a least-squares adjustment. If a matrix in-
version cannot be performed due to a singularity, there 
will be no adjustment. One situation that will cause a 
singularity is attempting to adjust GPS vectors in a 
network in which parts of the network are not connect-
ed to other parts, i.e. two or more sets of points that 
do not have connectivity to each other.
Site: A location or survey point where GPS data is col-
lected.
Site ID: An alphanumeric identifier for a survey point. 
Each survey point must have a unique site ID. Other-
wise, the processing will have problems determining 
which point certain observations belong to.
Slant height: The distance from the survey marker to 
the edge of the antenna ground plane. Using the slant 
height and radius of the GPS antenna, the true vertical 
height or HI of the antenna can be determined. The HI 
is used in the processing to determine the location of 
the survey marker on the ground.
Spheroid: See ellipsoid.
Standard Error (standard deviation): The goal of any 
measurement is to find the true value. Since all mea-
surements contain error, the true value is never ob-
served. In order to qualify measurements, an error 
estimate is statistically derived for each measurement. 
A standard error estimate indicates there is a 66% 
probability that the true value of a measurement falls 

within the range generated by subtracting and adding 
the error estimate to the measured value. For example, 
if a measurement of 50.5 meters has a 95% error of 
0.1 meters, then there is a 95% probability that the 
true value is between 50.4 – 50.6 meters. The 66% 
value is derived from a normal distribution.   For a nor-
mally distributed variable, the standard error is the 
bound within which 66% of the samples of the vari-
able fall.
Static surveying: A method of GPS surveying that in-
volves simultaneous observations between stationary 
receivers. Post-processing computes the vector be-
tween points.
SV: Satellite vehicle or space vehicle.
System, Geocentric: A coordinate system based on the 
definition of a datum providing a horizontal system 
only
System, Geographic: A coordinate system based on 
the definition of a datum providing a horizontal and 
vertical system
System, Projected: A coordinate system based on the 
definition of a datum and a projection.

T
Tau test: The Tau test is a blunder detection QA test 
performed on adjusted survey measurements (GPS 
vectors). The test examines the size of the measure-
ment residuals and compares it statistically to an ex-
pected distribution. If the residual is larger than 
expected, the observation is flagged as a potential 
blunder.
Time Dilution of Precision (TDOP): See Dilution of Pre-
cision. 
Transverse Mercator: Mercator projection turned 90o 
in azimuth. The central meridian is represented by a 
straight line, corresponding to the line which repre-
sents the equator on the regular Mercator map projec-
tion. In the United States, the Transverse Mercator is 
the base used in the State Plane Coordinate System 
(SPCS) for states with predominant north-south ex-
tent.

U
UTC: Time as maintained by the U.S. Naval Observa-
tory. Because of variations in the Earth's rotation, UTC 
is sometimes adjusted by an integer second. The ac-
cumulation of these adjustments compared to GPS 
time, which runs continuously, has resulted in an 11 
second offset between GPS time and UTC at the start 
of 1996. After accounting for leap seconds and using 
adjustments contained in the navigation message, 
GPS time can be related to UTC within 20 nanosec-
onds or better.
UTM: Universal Transverse Mercator Map Projection. A 
special case of the Transverse Mercator projection. Ab-
breviated as the UTM Grid, it consists of 60 north-
south zones, each 6 degrees wide in longitude.

V
Variance of unit weight: A statistical quality indicator 
of a least-squares adjusted network. The expected val-
ue of the variance of unit weight is 1. A value below 1 
is an indication that the uncertainties assigned to the 
measurements are too optimistic. A value greater than 
1 is an indication that the either the uncertainties as-
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signed to the measurements are too pessimistic or that 
there is one or more blunders in the data set adjusted.
Vector: The spatial line, described by 3D components, 
between two points. In GPS surveying, a vector is the 
product of processing raw data collected on two points 
simultaneously.
Vertical Dilution of Precision (VDOP): See Dilution of 
Precision

W
WGS84: The datum that GPS positions and vectors are 
referenced to. This datum is basically equivalent to the 
NAD83 datum used in the United States. The differ-
ence is too small to have any impact on GPS positions 
and vectors.
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Chapter 1: Tutorial Supplement

Important Notes

1. The first tutorial introduces notions and elements of the software that are 
not repeated in Tutorials #2 and #3. For this reason, reading Tutorial#1 
first is highly recommended. Tutorials #2 and #3 can then be read in any 
order. Tutorial #4 is the continuation of Tutorial #3 and –obviously, for this 
reason, should be run after Tutorial #3.

2. Unless otherwise specified, GNSS Solutions is assumed to be used with 
only the basic options enabled. This means you should only see the follow-
ing two options enabled when selecting the Tools>Preferences command:

3. It is also assumed that GNSS Solutions was installed with the default 
choices.

4. The screenshots illustrating this Tutorials chapter were obtained with a 
former version of GNSS Solutions. Because our processing algorithms are 
continuously refined for maximum accuracy, you should consider it as 
acceptable that slight differences may show up between the results shown 
on these screens and those obtained with the current version of GNSS 
Solutions.
1
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Tutorial #1: Static Survey

(Average time required to complete this tutorial: 30 minutes.)

Preamble
The purpose of this tutorial is to familiarize yourself with the use of GNSS So-
lutions in static surveys.
You will work on an example of a geodetic network survey. In this type of survey, 
operators customarily introduce a significant amount of redundancy in their 
observations for the purpose of securing their results in terms of precision.
In this example, you will assume that among the points that have been sur-
veyed in the field, two of them are 3D known points.
One of them will be closely involved in the processing: At one step in the post-
processing, you will ask GNSS Solutions to use this point as a “fixed” control 
point, meaning that you will introduce its true coordinates in the processing, 
instead of letting the program use those surveyed.
The other will be used for the sole purpose of making sure the required level 
of accuracy has effectively been achieved in the survey.
2
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Step #1: Creating a project
- To start the program, from the Windows task bar, select successively Start, 

Programs, GNSS Solutions and then GNSS Solutions again. The Welcome dia-
log box opens:

- Click on the Create a new project button. The New dialog box opens.
- In the Project name field, type a name for the new project.
3
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Step #1: Creating a project
For example, type in Tuto_1.

- Click on the Modify Default Settings button. This opens the Default Project 
Settings window with the Region tab selected by default.

- In the list attached to the Spatial Reference System field, select <New>. In 
the new dialog box that opens, the SELECT a PREDEFINED system option is 
checked by default.

- Keep this default selection and simply click on the Next> button.
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- In the new dialog box that appears, make the following selection:

- Click Finish. This takes you back to the previous dialog box where the name 
of the chosen system now appears in the upper field

- In the Time zone and Linear unit fields underneath, make the following 
choices:
5
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- Click on the OK button twice. The following dialog box is now displayed:

Step #2: Downloading/Processing Raw Data
(This step includes defining control points and running data processing)
- Insert the GNSS Solutions CD-ROM in the computer’s CD drive.
- Click on the Import Raw Data from Files or ProMark 500 button. As a result, a 

new project, named “Tuto_1”, opens in the GNSS Solutions main window 
and then the Browse dialog box opens.

- Using the Look in combo box, select the following folder on the GNSS Solu-
tions CD-ROM: Samples\Static\.

- While holding down the Shift key ( ), click on the first, and then on the 
last filename in the list to select all the observation files (GPS data files) 
present in the folder.
6
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- Click the Open button to start importing these files into the project. A mes-
sage then appears denoting data loading in progress.
In the Importing GPS Data dialog box that appears afterward (see figure 
below), GNSS Solutions shows the properties of the raw data files you want 
to import (on top).
You can also define control points. For those points you will want to fix, you 
will be able to enter their true coordinates (at the bottom of the dialog 
box).

- Click in the Name cell located underneath the Control Points header. A down 
arrow then appears in this cell.

- Click on this down arrow and then, from the drop-down list that appears, 
select the first point you want to use as a control point.

- Here select “PM-A”:
7
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- As a result, the other cells in the row show all the properties of the newly 
chosen control point, as deduced from one of the data files you want to 
import.

- Enter the true coordinates of the “PM-A” point (Easting: 313903.539; 
Northing: 273628.423 and Ellips Height: 13.622) and then make sure 
Hor.&Ver. is selected in the Fixed cell. This will transform the point into a 
fixed 3D control point:

- In the row underneath, click in the Name cell and select “FLEU” as the 
second control point. As a result, the other cells in this row show all the 
properties of the newly chosen control point, as deduced from one of the 
data files you want to import.

- This control point should not be fixed as it is only for control. Enter its true 
coordinates (Easting: 309318.584; Northing: 262591.667 and Ellips 
Height: 32.746) and select “Blank” in the Fixed cell. On the other hand 
you need to select Hor.&Ver. in the Control cell to inform GNSS Solutions 
that this point will be used as a 3D control point:
8
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- Click on the OK button and select To Import and Process Baselines:

This enables GNSS Solutions to import the files and then automatically 
process the baselines using the control point “PM-A”. At the end of the 
processing phase, GNSS Solutions shows the results of the processing. 
These results are detailed in the next step.
9
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Step #3: Analyzing the project content after Download
This step gives us the opportunity to introduce the different parts that can 
be seen in the GNSS Solutions main window (see example below).

The Command pane (1) is designed to help you choose the right command 
at the right time. The available commands are organized by topic and are 
in fact those accessible from the menu bar but here they are shown as 
icons, with command names displayed after icons.

(1)
(2)

(3)

Topic 
bars

Name of the coordi-
nate system chosen 
for the project is re-

called here
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The number of topics contained in the tab is context-sensitive. To open a 
topic when several topics are available, click the horizontal topic bar show-
ing the name of the topic.

 In this tutorial, you will be prompted to work with these icons rather 
than use the commands from the Project menu on the GNSS Solutions 
menu bar. You can however use the Project menu if you prefer.
The View pane (2) is a display area shared by all the views open in the 
project. Click on one of the tabs shown at the bottom of this pane to 
change the view displayed in the pane.
Currently, the View pane shows a map of the data you have just imported. 
Note that the displayed coordinates are in compliance with your choice of 
spatial reference system and the grid coordinates + map scale have been 
updated to match the locations of these points.
When several documents are open in a project, you choose the one you 
want to display in the View pane by simply clicking on the corresponding 
tab located at the bottom of the View pane. (These tabs will be visible only 
if the View>As Worbook option is checked –it is by default.)

Using the  button in the upper right edge of one of these documents, 
you can also dock this document to make it always visible. By default, the 
Workbook.tbl document is docked in the lower part of the View pane and 
occupies all the width of the GNSS Solutions main window (for the display 
of a maximum of columns at a time).

- The Output pane (3) contains message lines that attest to the different 
operations you run in GNSS Solutions (in the present step, data import). If 
you close this pane, GNSS Solutions will open it automatically when the 
functions you run in GNSS Solutions result in user messages sent to this 
pane.
11
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Analyzing the content of the project. On the Survey View:

- The vectors determined by GNSS Solutions are shown as green/red seg-
ments depending on whether they respectively passed or failed the QA 
test. The size and shape of the error ellipse as well as the vertical error (a 
vertical segment) for each vector are represented at mid-distance along the 
vector. Please refer to the legend shown in the lower right on the map to 
assess the error ellipse and the vertical error attached to each vector.

- The location of each control point is represented by a dark blue triangle. 
The name of this point is displayed next to it. The letters “H” and/or “V” 
by the triangle icon indicate that the control point has been fixed horizon-
tally and/or vertically.

- The location of each point where static occupation took place is repre-
sented by a flag icon on top of an upright stick. The name of the point is 
displayed next to it.
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- Each imported file is represented by a diskette icon. The name of the file 
is displayed in gray characters next to the diskette icon. Each of these 
icons is positioned on the map based on the straight GPS solution GNSS 
Solutions determines from the corresponding data file.

In the Workbook table:
- Click on the Points tab and resize the window if necessary. This table looks 

like this:

This table gathers all numeric values and processing parameters resulting 
from the processing you have just run. Use the horizontal scroll bar to 
access the right-hand part of the table. Also, click on the different tabs 
located at the bottom of the pane to access the various categories of 
results. For example in this tutorial, results are displayed on the following 
tabs: Files, Points, Control positions, Vectors, Repeat Vectors and Control 
tie.

- Click on the Vectors tab to see the solution status of each vector. Here they 
have all been fixed.
13
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On the Time view:
- To view this diagram, click on the Time View.tvw tab and resize the View 

pane if necessary. This diagram looks like this:

This diagram shows the imported raw data files (observation files) versus 
time. Inside rectangles showing the time spans of observation files are the 
names of the points where static occupations took place.

- The first 5 buttons on the map toolbar (located at the bottom of the GNSS 
Solutions main window) can be used on the Time view after clicking any-
where on this view. This means you can perform the following actions on 
the Time view: select, zoom in, zoom out, zoom to fit and grab.

Note: A click on  when the Importing GPS data window is open (see Step #2: 
Downloading/Processing Raw Data on page 6) allows you to display the Time 
view BEFORE importing data files.
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Step #4: Adjusting the Network
- Press the F7 key or, in the Command pane, click on the Adjustment topic 

bar and then on the Adjust Network icon. GNSS Solution starts adjusting 
the network. The adjustment results are then available on the different 
views. Below is what you can see on the Survey View:

- Vectors now appear as thick green lines, indicating that each of them has 
passed the QA test.

- Error ellipses are now provided for the surveyed points and so are centered 
at these points.

- If you double-click the “FLEU” point (used for control only), you will notice 
that the accuracy obtained for this point complies with the general level of 
accuracy required for the survey. This level is indicated on the Miscella-
neous tab of the Project Settings dialog. (To open this dialog, click on the 
Project topic bar in the Command pane and then click on the Project Set-
tings icon.)
15
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Step #5: Importing a Raster Image
In this step, you will have to use the GNSS Solutions installation CD-ROM 

that you have already inserted in the computer’s CD drive.

1. Selecting a Raster Image for Import:
- In the Command pane, click on the Map topic bar and then on the Import 

Raster Map icon. This causes the Browse dialog box to appear.
- From the Look in combo box, select the following folder on the GNSS Solu-

tions CD-ROM: ..\Samples\Maps\Raster\.
 Supported formats: BMP, JPG, JPEG2000 or non-compressed TIF.

- Select the JPG file stored in this folder and click Open. A new dialog box 
opens showing part of the map stored in the JPG file.
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As this map is dimensionless, you need to give it geographical dimensions. 
To do this, you have to define at least three reference points whose coordi-
nates are accurately known in the system used (see procedure below).

2. Sizing & Importing the Raster Image:
 Refer to the numeric values contained in the two dialog boxes below to complete 

the present step.

- Right-click on the map and select Add reference points
- Click exactly on the red mark located in the upper-left corner of the map 

and then enter the point coordinates in the dialog box that shows up 
nearby. Please, enter the coordinates provided in the figure below and then 
click OK.
17
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- Use the horizontal and vertical scroll bars to access the lower-right part of 
the map. Click exactly on the mark located in the lower-right corner of the 
map. As previously, enter its coordinates (refer to the figure below to know 
which values to enter).

- Enter the third and last reference point: Use the vertical scroll bar to 
access the upper-right part of the map. Click exactly on the mark located 
in the upper-right corner of the map. Enter its coordinates, which are the 
following: East: 309863.0000 and North 262710.000. Click OK. 

- Then enter the name of the map in the Map name field (For example, type 
“Nantes_NE”) and make sure the selected coordinate system is “FRANCE/
NTF/Lambert II”.
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- Click OK to close the dialog box. As a result, the raster map now appears 
on the Survey View. Zoom in repeatedly around the “FLEU” point to clearly 
see this map:
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If you obtain something different on your screen –a distorted image for exam-
ple– it means you probably made a mistake when entering the coordinates of 
the reference points or maybe you did not choose the right coordinate system. 
In either case, you have to resume the import operation and first of all delete 
the raster map you have incorrectly imported.
To delete the raster map:
- Right-click anywhere on the Survey View and select Legend to open the 

Map Properties dialog box
- Scroll-down the list displayed in this dialog until you see the Nantes_NE 

layer (last in the list)

- Select this layer and then click on 
- Click OK to close this dialog. As a result, the map disappears from both the 

Survey View and the project.
- Resume step#5.
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Step #6: Importing a Vector Layer
In this step, you will have to use the GNSS Solutions installation CD-ROM 

that you have already inserted in the computer’s CD drive.
- Click on the Import Vector Map button This causes the Browse dialog box to 

appear
- From the Look in combo box, select the following folder on the GNSS Solu-

tions CD-ROM: ..\Samples\Maps\Vector\.
- Select the file stored in this folder and click Open.

As a result, the vector layer is imported into the project.
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Note that the order in which layers are listed in the Legend tab of the Map Prop-
erties dialog box impacts the way layers are superimposed on the map.
The mechanism is summarized in the figure below:

(To display the legend, right-click anywhere on the map and select Legend)
As shown above, the first layer in the list is brought to front, the last one is sent 
to back. Intermediate layers occupy intermediate positions between the front 
and the back. GNSS Solutions always places raster map layers you import at 
the bottom of the list as they are more liable than any other layer to mask all 
others.
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Step #7: Exporting Data to a File
- In the workbook, click on the Points tab and then select all the points listed 

on this tab. To do this, click once in the leftmost cell in the first row and 
then, while holding down the Shift key ( ), click anywhere in the last row. 

- In the upper-left pane of the GNSS Solutions main window, click on the 
Export topic bar and then on Export Geo Data to File

- In the dialog box that appears, make the following two choices:
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Step #7: Exporting Data to a File
- Click OK. A new dialog box appears asking you to choose a folder where to 
store the export file and name this file. Select the “Tuto_1” project folder 
in the Save in field. Then, type in “MyPoints.txt” as the file name:

- Click Save. The end of data export is denoted by the following message in 
the Output pane:
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Step #8: Creating a Report
- Press the F9 key or, in the Command pane, click on the Export topic bar 

and then on the Land Survey Report icon. This opens a new dialog box in 
which you can define the content of the report.

- Choose freely the items you would like to include in the report (clear those 
you do not want).

- Then, in the Report name field, enter “MyReport”.
- Click OK. GNSS Solutions then starts creating the report document. This 

document displays in the View pane as it is being created. Once GNSS 
Solutions has finished creating the report, a new tab mentioning the name 
of the report appears in the View pane.

Step #9: Closing the project
- Select File>Close. This saves and closes the project contained in the work-

space, and the workspace as well.
End of Tutorial #1.
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Tutorial #2: “Stop & Go” Survey

(Average time required to complete this tutorial: 20 minutes.)

Preamble
The purpose of this tutorial is to familiarize yourself with the use of GNSS So-
lutions in Stop & Go surveys.
The Stop & Go survey you will be working on in this tutorial was run as follows:
- A base station was installed and operated at a known 3D point for about an 

hour. The raw data collected during this time at the base station has 
resulted in an observation file that you will import into this tutorial project.

- A rover was moved from point to point in Stop & Go mode within this 
period of time. Initialization took place at a known point. The raw data col-
lected during this time by the rover has resulted in a single observation file 
that you will also import into this tutorial project.

It is a good practice during a Stop & Go survey to collect data at a known point. 
This point is visited in the same way as are all the points you need to survey. 
After processing the collected data in GNSS Solutions, you will be able to qual-
ify the results of the survey using this point as a non-fixed control point. In our 
tutorial such a point was visited.
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Step #1: Creating a New Project
- In the Command pane, click on the Project topic bar and then on the Create 

New Project icon. In the New dialog box that opens, type in a name for the 
new project in the Project name field. For example, type in Tuto_2:

- Click on the Modify Default Settings button. In the new dialog box that 
appears, select FRANCE/NTF/Lambert II as the spatial reference system to be 
used in the new project. Keep the default selection in the Time zone field. 
Choose “Meters” in the All Distances in field.
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- Click on the OK button twice. The following dialog box is displayed:

- Click on Do Not Import Anything Now. This closes the dialog box and you can 
now see the blank project open in the main window.

Step #2: Creating the Control Point Used for Initialization
When field initialization is performed at a known point –which is the case in 
this example– you must define this point as a control point in the project before 
processing the files. Otherwise GNSS Solutions will process the files as if ini-
tialization had been performed in OTF.

 For kinematic surveys that you initialized with the initializer bar or in OTF, GNSS 
Solutions will automatically process the files without the need for you to enter any 
additional information.

- Click anywhere inside the Survey View to activate the map tool bar (located 
at the bottom of the GNSS Solutions main window).
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- On the map toolbar, click 
- Move the mouse cursor back onto the Survey View and click anywhere 

within this view. This opens the Point dialog box in which you can fully 
define the known point.

- Keep the default choice for the point type (“Control Point”) as this is 
exactly what we want this point to be.

- Enter the name of the point (“2979”) in the field underneath
- Enter the coordinates of “2979” in the three control coordinate fields. 

These coordinates are:
• Easting: 309999.772
• Northing: 262521.064
• Height: 14.084
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Step #3: Downloading/Processing Raw Data
- Click OK to create the point and close the dialog.
- Right-click anywhere on the Map view and select Zoom to Fit. The Survey 

View now shows this point at its true location on the map.

Step #3: Downloading/Processing Raw Data
(This step includes defining the base position as a control point.)
- Insert the GNSS Solutions CD-ROM in the computer’s CD drive.
- In the Command pane, click on the Import topic bar and then on the Import 

Raw Data from Files or ProMark 500 icon. This opens the Browse dialog box.
- Using the Look in combo box, select the following folder on the GNSS Solu-

tions CD-ROM: Samples\Stop&go\.

- While holding down the Shift key ( ), click on the first, and then on the 
last filename to select all the observation files (GPS data files) present in 
the folder.

- Click the Open button to start importing these files into the project. A mes-
sage then appears denoting data loading in progress.
In the Importing GPS Data dialog box that appears afterward (see figure 
below), GNSS Solutions shows the properties of the raw data files you want 
to import (on top). 
You can also right now define the control point and enter the true coordi-
nates of this point (at the bottom). Note that in this dialog box, GNSS 
Solutions also mentions the control point already present in the project 
(here point “2979”).

- Click in the Name cell located underneath the Control Points header. A down 
arrow then appears in this cell.
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- Click on this down arrow and then, from the drop-down list that appears, 
select the point you want to use as the control point. Here you can only 
select “FLEU”  so select now this point.

This causes the other cells in this row to show all the properties of the 
newly chosen control point, as deduced from one of the data files you want 
to import:
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Step #3: Downloading/Processing Raw Data
- Enter the true coordinates of the “FLEU” point (Easting: 309318.584, 
Northing: 262591.667, Height: 32.746) and then fix this point horizon-
tally and vertically to transform this point into a 3D control point (select 
Hor&Ver in the Fixed cell):

- Click on the OK button and then select To Import and Process Baselines:

This enables GNSS Solutions to import the files and then automatically 
process the baseline between the two points. At the end of the processing 
phase, GNSS Solutions shows the results of the processing. These results 
are detailed in the next step.
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Step #4: Analyzing the Results
On the Survey View:

- The two control point are each represented by a dark blue triangle. The 
name of this point is displayed next to it. The letters “H” and “V” by the 
triangle icons indicate that the control points have been fixed horizontally 
and vertically.
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- The location of each point where static occupation took place is repre-
sented by a flag on top of an upright stick. The name of the point is dis-
played next to it.

- The point “B7006C05” is not a point that you surveyed but represents the 
location where GNSS Solutions placed the rover’s data file when you 
imported this file into the project (this position was determined in autono-
mous GPS mode using the data from the file). Do not delete this point as 
this would cause the corresponding observation file to be deleted as well.

In the Workbook table:
- Click on the Points tab and resize the window if necessary. This table looks 

like this:

The Workbook table gathers all numeric values and processing parameters 
resulting from the processing you have just run. Use the horizontal scroll 
bar to access the right-hand part of the table.
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Also, click on the different tabs located at the bottom of the pane to 
access the various categories of results. For example in this tutorial, results 
are displayed on the following tabs: Files, Occupations, Points, Control 
positions, Vectors and Control tie. A very important thing to do is to check 
that all vectors have a “fixed” solution status. This is the case here for all 
vectors.

On the Time view:
- To view this diagram, click on the Time View tab and resize the View pane if 

necessary. After appropriate zoom-in and grab operations using the rele-
vant buttons on the map toolbar (located at the bottom of the GNSS Solu-
tions main window), the diagram should look like this:
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Step #5: Qualifying the Results
This diagram shows the imported raw data files (observation files) versus 
time. The raw data file represented on top of this diagram was recorded at 
the base station (control point “FLEU”) and is the longest in time. It is 
represented as a single gray rectangle covering about 1 hour. The name of 
the point appears inside the rectangle.
The raw data file just underneath was recorded by the rover. Several dis-
tinct rectangles are shown for this file. Each of them represents a static 
occupation on a point. The name of this point appears inside the rectan-
gle. Dotted lines between rectangles represent periods of time during 
which the operator walked from one point to the next one.

Note: A click on  when the Importing GPS data window is open (see Step #3: 
Downloading/Processing Raw Data on page 30) allows you to display the Time 
view BEFORE importing data files.

Step #5: Qualifying the Results
As mentioned at the beginning of this tutorial, one of the points visited during 
the survey is in fact a known point. Its true coordinates are:
- Easting: 309959.300
- Northing: 262324.400
- Height: 7.970
This point was named “2584” by the field data collector. If you transform this 
point into a control point, GNSS Solutions will provide the total error between 
the true and surveyed locations of this point thus giving a good idea of how 
accurate the survey was.
- Click on the Survey View tab and then double-click the “2584” point to 

open its Properties window.
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- On the Point tab, in the upper-left corner, change the point type to “Control 
Point”

- Now enter its true coordinates (see values given above) in the 3 fields 
located underneath the Control section (after entering the height value, 
click inside any other valid field to validate the height value). As a result, 
the dialog box now displays the total error between the surveyed and true 
coordinates.
Here the error is compatible with the level of accuracy required. This level 
is indicated on the Miscellaneous tab of the Project Settings dialog. (To 
open this dialog, in the Command pane, click on the Project topic bar and 
then on the Project Settings icon.)
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Step #6: Exporting Data to a File
- Click on the Points tab in the workbook.
- Select the 1st to 7th points in the table. To do this, click once in the left-

most cell in the first row and then, while holding down the Shift key ( ), 
click anywhere in the 7th row.

- In the Command pane, click on the Export topic bar and then on the Export 
Geo Data to File icon.

- In the dialog box that appears, make the following two choices:

- Click OK. A new dialog box appears asking you to choose a folder where to 
store the export file and name this file. Select the “Tuto_2” project folder 
in the Save in field.
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- Then, enter “Export1” in the File name field:

- Click Save. The end of data export is denoted by a message in the Output 
pane.
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Step #7: Creating a Report
- Press the F9 key or, in the Command pane, click on the Export topic bar 

and then on the Land Survey Report icon. This opens a new dialog box in 
which you can define the content of the report. 

- Choose freely the items you would like to include in the report (clear those 
you do not want).

- Then, in the Report name field, enter “MyReport”.
- Click OK. GNSS Solutions then starts creating the report document. This 

document displays in the View pane as it is being created. Once GNSS 
Solutions has finished creating the report, a new tab mentioning the name 
of the report appears in the View pane.

Step #8: Closing the project
- Select File>Close. This saves and closes the project contained in the work-

space, and the workspace as well. End of Tutorial #2.
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Tutorial #3: Real-Time Survey

(Average time required to complete this tutorial: 25 minutes.)

Preamble
With this tutorial, you will learn how to use GNSS Solutions before and after a 
real-time survey. The survey example includes staking-out and point logging 
operations.
In this example, the target and reference points are not created in the project, 
although this would be possible using the map toolbar. Instead, target and ref-
erence points are made available in the form of a text file that was especially 
prepared for you.
The field survey step will be bypassed, as it does not fall within the scope of 
this document. You will however be provided with a results file, as if you had 
performed the field survey by yourself, so that the post-survey steps can be run 
with GNSS Solutions.
In this survey example, the base station was operated on a reference point 
whose coordinates are accurately known in the local system used. In addition, 
this installation point was chosen to offer a clear view of the sky for best pos-
sible GPS reception.
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After surveying a couple of points that are also accurately known in the local 
system, the field operator was able to perform an in-the-field calibration allow-
ing her/him to refine the parameters of the local system used and afterwards, 
to survey all the other points with the same level of precision as the known 
points. With GNSS Solutions, you will be able to re-run this calibration at the 
office for safety or cross-checking purposes.
This tutorial is also valid for those of you who prefer to work with the base sta-
tion operated on an unknown point.
In this case however the calibration is essential, not to say vital, as it brings 
about a significant leap in the precision from a few meters (due to floating base 
station position determined in Autonomous GPS mode) to less than one centi-
meter. In addition, surveyors using this method will only obtain local coordi-
nates for their surveyed points whereas the first method would provide both 
WGS84 and local coordinates.
Choosing a method rather than the other then only depends on whether you 
need the true WGS84 coordinates for the surveyed points or not.
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Step #1: Enabling the RTK Functions
- From the menu bar, select Tools>Preferences.
- In the dialog that opens, check the Show RTK functions option
- Click OK.

 If you don’t need it in your applications, do not forget to disable this option after 
running this tutorial.

Step #2: Creating a New Project
- In the Command pane, click on the Project topic bar and then on the Create 

New Project icon. In the New dialog box that opens, type in a name for the 
new project in the Project name field. For example, type in Tuto_3:

- Click on the Modify Default Settings button. In the new dialog box that 
appears, select FRANCE/NTF/Lambert II as the spatial reference system to be 
used in the new project. Keep the default selection in the Time zone field. 
Choose “Meters” in the All Distances in field.

- Click on the OK button twice. The following dialog is now displayed:
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Step #3: Importing Points into the Project
- Click on Import Geo Data from Files. As a result, a new project, named 

“Tuto_3”, opens in the GNSS Solutions main window.
- In the dialog box that appears, make the following two choices: 

- Click OK. The Open dialog box now opens.
- Insert the GNSS Solutions CD-ROM in the computer’s CD drive
- Using the Look in combo box, select the following folder on the GNSS Solu-

tions CD-ROM: Samples\RealTime\.
- Select the txt file stored in this folder and click Open. GNSS Solutions 

starts importing the file into the project database. A message is displayed 
while data import takes place. At the end of the import phase, the 
imported points appear in the Survey View.
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Step #4: Uploading the Job to the Surveying Device
Before running this step, connect the Z-Max data collector to your office 

computer via a serial line and switch it on. If you do not have a data collector 
available, do not worry! Just skip ahead to step #6.
- On the data collector, launch the FAST Survey software. Make sure the 

selected Com port is the one you are actually using. Select the File tab, 
then the Data Transfer function and then the SurvCADD/Carlson Survey Trans-
fer function. The data collector screen should then display “File Transfer 
Utility... Awaiting Connection”.
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- On the GNSS Solutions side, in the Command pane, click on the Export 
topic bar and then on the Upload Positions to External Device icon. In the dia-
log box that opens, make the following choice:

- Click OK. Make the following selection:
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- Accept all the defaults by simply clicking OK. This opens the following dia-
log box asking you to connect and run the field terminal (which was done 
at the beginning of this step) and to specify the conditions of transfer 
(Automatic or not; Default=Automatic).

- In the combo box, select the port used (ActiveSync for a connection with a 
field terminal running FAST Survey) and then click OK. A number of mes-
sages are displayed in turn denoting transfer in progress (“Retrieving direc-
tory listing”, “File transfer...% complete”).

 Should GNSS Solutions fail to connect to the field terminal, please resume the 
above procedure in Manual Mode, i.e. clear the Automatic transfer check box when 
GNSS Solutions displays the above dialog box. This will open the SurvCom dialog 
box. You will then be able to check the PC port settings (cf. Options button) and 
resume data transfer manually from this dialog box (cf. Connect button).
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(Step #5: Field Survey)
A number of files need to be transferred for any job you wish to upload to the data 
collector: the CRD file, the SYS file, the INF file, the FCL file and the SCB file. 
When the transfer is automatic, GNSS Solutions knows which files to transfer. When 
the transfer is manual, you must select these files in the left-hand pane before 
uploading. For this tutorial, you would have to select the following files in the left-
hand pane before clicking the Transfer button (2nd button from the left in the lower 
part of the dialog box):

(Step #5: Field Survey)
Skipped. (This step does not fall within the scope of this manual.)
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Step #6: Downloading Results
In this step, because you are just working on an example, you will be asked 

to copy result files from the installation CD-ROM to the job folder. Make sure 
the installation CD-ROM is still in the CD-ROM reader on your PC.
Remember however that in normal conditions of use, before running this step, 
you should connect the data collector to your office computer via a serial line, 
switch it on, launch the FAST Survey software, select the File tab, the Data 
Transfer function and then run SurvCADD/Carlson Survey Transfer.
In the present case, just do the following:
- Run Windows Explorer.
- Open the Samples/RealTime/Results folder located on the installation CD-

ROM
- Copy the 6 files present in this folder to the “Job” folder of the Tuto_3 

project (If you skipped step #4, you need to create this folder first). If 
asked to do so, overwrite some of the files already present in the folder. 
This is at least what you should see in the job folder after copying the files:
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- Come back to GNSS Solutions. In the Command pane, click on the Import 
topic bar, and then on the Download Positions from External Device icon. In 
the dialog box that opens, make the following selections:

- Click OK. The following dialog box opens. Select the port used and clear 
the Automatic Transfer option:
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- Click OK. The Connecting to remote system... message is displayed until com-
munication with the data collector is established. Then the SurvCom dialog 
box opens.
If no data collector is connected to the PC, the Communications Failure mes-
sage will appear. In this case, click OK to open the SurvCom dialog box.

- Click  to close the SurvCom dialog box. The following dialog box now 
opens:

- Click OK. Sometimes, the coordinate system used in the field is different 
from the one defined in the project. This is the case for the present tuto-
rial. The following dialog box then appears in which you should choose 
which coordinate system to use in the project. In this example, choose 
“Project” as shown in the figure below and check the second option in the 
lower part of the box.
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- Click Go. This starts the download operation. Once download is complete, 
the Survey View looks like this:
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Step #7: Analyzing the Content of the Project after Down-
loading Results
- On the Survey View, zoom in on the area containing points using the zoom-

in button from the Map toolbar. To do this, draw a rectangle around this 
area and release the mouse button. You should then get a view like this 
one:

This map shows the location of each surveyed point (staked target: vertical 
flag+ leaning flag icon; reference: landmark icon; non-staked target: lean-
ing-flag-only icon). The leaning flag is just to remind you that each of these 
points was initially planned in the project for staking out purposes.
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Step #8: Performing Coordinate Calibration
- Zoom in on the area showing the three reference points

- On the Map toolbar, click on  and then make a multiple selection of 
these three points using the Ctrl key:

- On the GNSS Solutions menu bar, select Project>Coordinate calibration. The 
dialog box that opens is as follows:
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- Click the Compute button to let GNSS Solutions determine the local sys-
tem. Computation is immediate. Residuals are displayed in the dialog box 
on computation completion:

Clicking the OK button will allow GNSS Solutions to use the newly deter-
mined local system as the project’s new spatial reference system. Clicking 
Cancel would cause GNSS Solutions to continue using the coordinate sys-
tem initially chosen for the project. If you click OK, GNSS Solutions will 
then update points and vectors. In the upper-right corner of the map docu-
ment, the term “Fitted” will then be used to describe the new coordinate 
system used in the document. This system will also be used at project 
level.

 On the above dialog box, note that the characteristics of the local system can be 
displayed by clicking the Results button (then see these characteristics on the Pro-
jection and System tabs).

- Click OK to define the newly determined local system as the project’s new 
spatial reference system.

 You can rename the local system through Project>Edit Settings.
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Then click  located on the right of the Spatial Reference System field. Select the 
System tab, edit the System name field and click OK twice. The new name will then 
appear in the upper-right corner of the Survey View.

Note however that GNSS Solutions does not actually rename the system name. 
Instead it duplicates the “Fitted” system and then assigns the name you provide to 
the duplicate.

To delete the “Fitted” system, select Tools>Coordinate Systems, select “Fitted” in the 

list and click .

Step #9: Exporting Data to a File
- Click on the Points tab located at the bottom of the workbook displayed 

underneath the Survey View.
- Select the first 16 points on this tab. To do this, click once in the leftmost 

cell in the first row and then, while holding down the Shift key ( ), click 
anywhere in the 16th row.

- In the Command pane, click on the Export topic bar and then on the Export 
Geo Data to File... icon

- In the dialog box that appears, make the following two choices:
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- Click OK. A new dialog box appears asking you to name the export file.
- Choose the project folder where to store the export file and enter “Tar-

getPts” as the file name:

- Click Save. A Data export message appears briefly. The end of data export 
is denoted by the following message in the Output pane:

Step #10: Closing the Project
- Select File>Close. This saves and closes the project contained in the work-

space, and the workspace as well. End of Tutorial #3.
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Tutorial #4: Using the Advanced Functions

(Average time required to complete this tutorial: 8 minutes.)
You are supposed to have run Tutorial #3 before starting Tutorial #4.
This tutorial is designed to show how you can create a new document in a 
project using the Data Management option. You will discover that the 3 views 
appearing on the screen when creating a new project are basically documents 
that GNSS Solutions creates with default settings.
All other documents that you will create in the open project (as is the case with 
the document created in this tutorial) will necessarily be part of this project.

Step #1: Opening Tutorial #3
- In the Command pane, click on the Project topic bar and then on Continue 

“Tuto_3”. The Tuto_3 project then opens  in GNSS Solutions.

Step #2: Enabling the Data Management Option
- From the menu bar, select Tools>Preferences.
- In the dialog that opens, check the Data Management and RTK Functions 

options. (Keep the default options enabled –Guide user on startup and Show 
background map functions.)

- Click OK.
 If you don’t need them in your applications, do not forget to disable these two 

options after running this tutorial.
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- With the Data Management option enabled, the upper-left part of the 
GNSS Solutions main window looks like this:

The Command pane is now changed into what we call the “Workspace” pane 
that includes not only the Command tab but also the Collection and Document 
tabs.
The Command tab includes an additional command that allows you to create 
new documents in the project. You can create five different types of docu-
ments. In this tutorial, we will create a new map document. Notice that among 
the existing (default) views in the project, the Survey View is a map document, 
the workbook is a table document and the Time View is a time document.

Command tab

Collection tab

Document tab
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The Collection tab allows you to list the different collections present in the 
open project, list their properties, etc. We will not address this topic in detail 
in the present tutorial but you can read more information about collections in 
the Advanced Features Chapter of the GNSS Solutions Reference Manual.

Step #3: Creating a Map Showing the Precision Results
In this step, you will create a map document showing the level of horizontal 
precision achieved for each of the surveyed points.
- In the Workspace pane, click on the Command tab, then on the Project 

topic bar and then on the Create New Document icon.
- On the Documents tab of the New dialog box that opens, select Map in the 

list and overwrite “Document1” with “Precision results” in the File Name 
field on the right

- Click OK to close this dialog box. The new map document now appears in 
the View pane.

- On the Workspace pane, select the Collections tab and then drag and drop 
the Points collection in the new map document. The Layer Wizard: Data dia-
log box opens.
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- Click the Next> button. In the Layer Wizard: Style dialog box that appears, 
make the following selections:
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- Click the Finish button. The map document should now look like this:

- Right-click anywhere on the map document and select Legend. The Map 
Properties dialog box opens.

- On the Legend tab, click , then select Points in the list of collections 
and then click OK
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- Click the Next button. In the Layer Wizard: Style dialog box that appears, 
make the following selections (don’t forget to position the name under-
neath the point by checking the appropriate button – see arrow below): 

- Click the Finish button to close this dialog box, and then the OK button to 
close the Map Properties dialog box.
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The active map document should now show the name and horizontal preci-
sion for each point:

The map document can be printed or archived as any other type of docu-
ment. It can even be appended to the report you will address to your cus-
tomer.
Any other map document can be created following the instructions of 
step#3 whenever you need to emphasize a particular aspect of a survey. 
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